LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2013, 11:43 PM   #31
abcomp02
LQ Newbie
 
Registered: May 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by Habitual View Post
Are you sure?

please run this as root
Code:
whereis libtool autoconf
and report the output.

CentOS version? yawn.

I will NOT quote myself even for your benefit.

did you install these first?
Code:
# yum install autoconf automake gcc gcc-c++ git libtool make nasm pkgconfig wget zlib-devel
It's a Yes or No question that remains unanswered.

Don't be so disrespectful, or unfocused, whichever.

yum install libtool
Loaded plugins: fastestmirror, protectbase
Loading mirror speeds from cached hostfile
* addons: mirror.sanctuaryhost.com
* base: bay.uchicago.edu
* epel: mirrors.servercentral.net
* extras: mirror.steadfast.net
* updates: mirror.unl.edu
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libtool.i386 0:1.5.22-7.el5_4 set to be updated
--> Processing Dependency: autoconf >= 2.50 for package: libtool
--> Processing Dependency: automake >= 1.4 for package: libtool
--> Running transaction check
---> Package autoconf.noarch 0:2.59-12 set to be updated
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
libtool i386 1.5.22-7.el5_4 base 667 k
Installing for dependencies:
autoconf noarch 2.59-12 base 647 k
automake noarch 1.9.6-2.3.el5 base 476 k

Transaction Summary
================================================================================
Install 3 Package(s)
Upgrade 0 Package(s)

Total download size: 1.7 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): automake-1.9.6-2.3.el5.noarch.rpm | 476 kB 00:00
(2/3): autoconf-2.59-12.noarch.rpm | 647 kB 00:00
(3/3): libtool-1.5.22-7.el5_4.i386.rpm | 667 kB 00:00
--------------------------------------------------------------------------------
Total 2.6 MB/s | 1.7 MB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : autoconf 1/3
Installing : automake 2/3
Installing : libtool 3/3

Installed:
libtool.i386 0:1.5.22-7.el5_4

Dependency Installed:
autoconf.noarch 0:2.59-12 automake.noarch 0:1.9.6-2.3.el5

Complete!



BUT OLD VERSION


i need libtool-2.4.2 but i can not install in http://www.gnu.org/software/libtool/

rpm -ivh gcc-4.8.0-8.fc20.i686.rpm
error: Failed dependencies:
binutils >= 2.20.51.0.2-12 is needed by gcc-4.8.0-8.fc20.i686
cpp = 4.8.0-8.fc20 is needed by gcc-4.8.0-8.fc20.i686
libasan.so.0 is needed by gcc-4.8.0-8.fc20.i686
libatomic.so.1 is needed by gcc-4.8.0-8.fc20.i686
libc.so.6(GLIBC_2.11) is needed by gcc-4.8.0-8.fc20.i686
libc.so.6(GLIBC_2.7) is needed by gcc-4.8.0-8.fc20.i686
libgcc >= 4.8.0-8.fc20 is needed by gcc-4.8.0-8.fc20.i686
libgmp.so.10 is needed by gcc-4.8.0-8.fc20.i686
libgomp = 4.8.0-8.fc20 is needed by gcc-4.8.0-8.fc20.i686
libmpc.so.3 is needed by gcc-4.8.0-8.fc20.i686
libmpfr.so.4 is needed by gcc-4.8.0-8.fc20.i686
rpmlib(FileDigests) <= 4.6.0-1 is needed by gcc-4.8.0-8.fc20.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by gcc-4.8.0-8.fc20.i686

i will update centos verion?

Last edited by abcomp02; 05-30-2013 at 11:50 PM.
 
Old 05-31-2013, 12:00 AM   #32
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
?????????
What ??
"gcc-4.8.0-8.fc20.i686.rpm"

"fc20 " is a VERY VERY VERY early alpha TESTING ONLY rpm for the VERY VERY VERY early alpha testing of fedora 20
Fedora 19 is not even released yet

and you are trying to install that on the rather OLD CentOS 5

--- it will NOT WORK ----

now some fedora rpm's can be installed on cent
Fonts,icons,and a few things like that
BUT NOT base components of the operating system

Also gcc 4.8 is SO NEW that not many programs will yet build with it .Most programs will need some hacking of the soiurce code to build using gcc 4.8

there is a reason that CentOS 5 has gcc 4.1


Please fully explain what exactly it is you need
just installing ffmpeg and the codecs for x264

for that install "rpmforge"
install and configure "yum-priorities" plugin
and install ffmpeg ( see my above post -- a few above )


or
do you need , as in a "MUST USE!!!" ffmpeg-0.6.5-2.el6.x86_64.rpm
that is a centos 6 -64 bit program

it will NOT run nor even build on CentOS 5 32 bit operating system

Last edited by John VV; 05-31-2013 at 12:14 AM.
 
Old 05-31-2013, 12:41 AM   #33
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,163
Blog Entries: 10

Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by abcomp02 View Post
i will update centos verion?
Sure. why not.

But I have CentOS 5.9 x86_64 over here and my installed version is
Name : libtool
Arch : x86_64
Version : 1.5.22

So, yours is 'older', do you really believe that is the cause of this issue?
You "need" libtool-2.4.2, I did not see that requirement at http://ffmpeg.org/trac/ffmpeg/wiki/C...mpilationGuide
nor on the ubuntu link either.

I've installed ffmpeg at least 6 CentOS 5.9 x86_64 machines this week.

libtool version hardly mattered on 6 of them.
Quote:
i need libtool-2.4.2
says who? Not ffmpeg,that's for sure.

Well, then you'll need to probably install from source.
The latest stable version is http://ftpmirror.gnu.org/libtool/libtool-2.4.2.tar.gz INSTALL says:
The simplest way to compile this package is:
as root:
Code:
cd /usr/src/ && wget http://mirror.sbb.rs/gnu/libtool/libtool-2.4.2.tar.gz
tar zxf libtool-2.4.2.tar.gz
cd libtool-2.4.2
./configure
make
make install
John VV:
I saw that fc20 also. good catch.

OP: Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sbopkg - how to install svn versions of x264, ffmpeg, mplayer and why? pokipoki08 Slackware 5 02-01-2010 11:14 PM
trying to install ffmpeg using yum danpaluska Fedora 2 01-21-2010 01:20 PM
HowTo: Custom ffmpeg with x264 support for AMD64 on Debian Squeeze propofol Linux - Software 0 10-09-2009 01:34 AM
LXer: Upgrade To The Latest FFmpeg and x264 in Ubuntu Intrepid and Jaunty LXer Syndicated Linux News 0 08-30-2009 08:20 PM
AMD64:x264 ffmpeg problems chronosoft Ubuntu 1 06-10-2007 10:57 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration