LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-13-2011, 02:39 PM   #1
Gayan Sanjaya
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Rep: Reputation: Disabled
How to use usb-modeswitch Slackware


I have use ubuntu for about 1 year.And i want to learn slackware.so I install slackware 13.1 in to my laptop.Then i try to connect to internet using my Huawei HSDPA mobile 3g dongle.
Then i install usb modeswitch after reading several documentation in the internet.I follow the instruction in following documentation and try to configure etc/usb-modeswitch.conf using vi.
But my usb-modeswitch.conf file is as follow and don't now how to configure.




# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# This file is evaluated by the wrapper script "usb_modeswitch_dispatcher"
# in /usr/sbin
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0


# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" (and probably others)

EnableLogging=0
~
~
Please guide me to connect to internet using my dongle
 
Old 07-13-2011, 03:53 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello Gayan Sanjayan, welcome to the forums,

I'm not sure if you have to configure modswitch in order to connect to the internet.

Could you please leave the usb_modeswitch.conf file as it came with the installation of Slackware. Then connect your Huawei USB-device to the computer, open a terminal and execute the command
Code:
lsusb
and then please post the output of this command.

Markus
 
Old 07-14-2011, 09:57 AM   #3
Gayan Sanjaya
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
lsusb

lsusb gave me following output

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 003: ID 138a:0005 DigitalPersona, Inc
Bus 002 Device 004: ID 064e:a127 Suyin Corp.
Bus 002 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
 
Old 07-14-2011, 10:36 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Well, in the last line of your output you can see that the Huawei is already recognized as a Modem, so you don't need usb_modeswitch.

You'll have to check that the modules "usbserial" is loaded, this can be done with the lsmod command
Code:
lsmod | grep usbserial
I've found a tutorial for Slackware here: http://www.linuxquestions.org/linux/...ackware_13_how

Hope this helps

Markus
 
Old 07-14-2011, 11:31 AM   #5
Gayan Sanjaya
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
where is the Huawei section

I follow your link .It says Now edit and save the config file /etc/usb_modeswitch.conf using your favourite text editor and add the following line in the Huawei section
But as you can see there is no huawei section in my /etc/usb_modeswitch.conf file.It contain only 19 lines, 558 chars.What should i do then.
 
Old 07-14-2011, 11:38 AM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Well, I thought to skip the step with the usb_modeswitch.

You'll only have to configure pppoe with the appropriate data for your internetconnection via the Huawei. But I don't have such a device and don't have any experience with it.

There's one manual which is not for Slackware http://www.lampdocs.com/home-personal/pppoe-connection/ which means they use program which you don't find on Slackware.

Another manual is in german language: http://wiki.slackforum.de/UMTSVerbindungMitPPPD

If you have KDE installed, you may use the tool kppp which seems promising.

Markus
 
Old 07-14-2011, 02:12 PM   #7
Gayan Sanjaya
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
when i issuied lsmod | grep usbserial comman i got
usbserial 27618 1 option


when i issuied ACTION=="add" SUBSYSTEM=="usb", SYSFS{idProduct}=="0020", SYSFS{idVendor}=="8087" by following your link i got a error
bash: SYSFS{idProduct}==,0020: command not found

what should i do now?
 
Old 07-14-2011, 02:32 PM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by Gayan Sanjaya View Post
...
when i issuied ACTION=="add" SUBSYSTEM=="usb", SYSFS{idProduct}=="0020", SYSFS{idVendor}=="8087" by following your link i got a error
bash: SYSFS{idProduct}==,0020: command not found
This is a udev-rule, you cannot execute it on the commandline. Are you sure that you need it?

Did you take a look at kppp?

Markus
 
Old 07-14-2011, 02:52 PM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
mh, I will add an explanation here. You wrote that you've used Ubuntu for a year, how did you configure the USB-modem with Ubuntu? it will not be very different in Slackware. The difference is that Ubuntu comes with Gnome and therefore uses the Gnome-tools when an internet-connection has to be configured. Slackware doesn't use Gnome (by default) and one has to use other tools.

But I don't think that you'll need modeswitch or write udev-rules to get it work. You'll only have to find out where you can configure your authentication-data for the connection.

Markus
 
1 members found this post helpful.
Old 07-18-2011, 11:46 AM   #10
Gayan Sanjaya
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Wink It worked

Thank you very much for your help.As you said i didn't want to install usb-modeswich to connect.I install wvdail and with that i could connect to internet.
 
Old 07-18-2011, 12:08 PM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello Gayan Sanjaya,

I'm happy to read that you've got it working.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ModeSwitch and Detection of Wireless Modem? Novatian Ubuntu 3 03-23-2011 12:12 PM
usb-modeswitch under Lenny cccc Debian 2 02-10-2011 08:03 PM
Huwaei 1261 with usb modeswitch in Hardy 8.04 shivkiyer Linux - Networking 10 06-14-2010 02:48 AM
HP Deskjet (USB) & CUPS & Slackware 9.1: Unable to open USB device "usb:/dev/usb/lp0&qu arnostienen Slackware 2 01-29-2004 04:22 PM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration