LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2015, 04:49 AM   #1
sindh
LQ Newbie
 
Registered: Aug 2014
Posts: 23

Rep: Reputation: Disabled
How to use DPDK inside Linux containers?


Hi,
I am trying to use DPDK inside containers.

While running any example application in a container, I am getting the below error.
EAL: 20480 hugepages of size 2097152 reserved, but no mounted hugetlbfs found for that size
PANIC in rte_eal_init():
Cannot get hugepage information
6: [./build/l2fwd() [0x402a49]]
5: [/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7ffff761776d]]
4: [./build/l2fwd() [0x402093]]
3: [./build/l2fwd() [0x45f3bf]]
2: [./build/l2fwd() [0x401fd9]]
1: [./build/l2fwd() [0x464dd3]]
Aborted (core dumped)


The problem is with hugepages. I have allocated memory for hugepages in host. And it is visible in containers.
But while accessing hugepages through containers, it's giving the error, permission denied.

My host machine has Ubuntu 12.04.
DPDK version 1.7

Please let me know, if I miss any info to be provided.

Any help would be greatly appreciated.

Thank you
 
Old 03-25-2015, 04:28 AM   #2
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,307
Blog Entries: 2

Rep: Reputation: Disabled
The error
Quote:
EAL: 20480 hugepages of size 2097152 reserved, but no mounted hugetlbfs found for that size
The instructions.
Quote:
mkdir -p /mnt/huge
mount -t hugetlbfs nodev /mnt/huge
echo 64 > /sys/devices/system/node/node0/hugepages/hugepages-2048kB/nr_hugepages
The error suggests you have 20480 hugepages
Not 64 hugepages each 20480kB.
 
Old 03-25-2015, 05:01 AM   #3
sindh
LQ Newbie
 
Registered: Aug 2014
Posts: 23

Original Poster
Rep: Reputation: Disabled
Thanks for the reply.
This was resolved by adding the below line to the container config file.
lxc.mount.entry = /mnt/huge mnt/huge none bind,create=dir 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat Introduces New Linux OS for Containers jeremy Linux - News 0 03-05-2015 06:20 PM
LXer: Linux Containers Get Certified LXer Syndicated Linux News 0 03-12-2014 07:40 PM
LXer: LXC 1.0 Announced For Better Linux Containers LXer Syndicated Linux News 0 02-25-2014 09:11 PM
LXer: Linux Containers and Why They Matter LXer Syndicated Linux News 0 04-25-2013 06:10 AM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration