LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-03-2004, 11:14 PM   #1
Kilahchris
Member
 
Registered: Jan 2003
Location: NY
Distribution: Suse 9.0
Posts: 202

Rep: Reputation: 30
how to upgrade glib without harming dependencies


I want to upgrade glib because it is needed by another rpm package. however when i try to upgrade glib

I get this error

Quote:

linux:/home # rpm -Uvh --requires glib-devel-2.3.5-1.athlon.rpm glib-2.3.5-1.athlon.rpm
warning: glib-devel-2.3.5-1.athlon.rpm: V3 DSA signature: NOKEY, key ID e01260f1
error: Failed dependencies:
libglib-1.2.so.0 is needed by (installed) gtk-1.2.10-710
libglib-1.2.so.0 is needed by (installed) imlib-1.9.14-36
libglib-1.2.so.0 is needed by (installed) WindowMaker-applets-1.0-469
libglib-1.2.so.0 is needed by (installed) fvwm2-2.5.7-52
libglib-1.2.so.0 is needed by (installed) ghostscript-x11-7.07.1rc1-37
libglib-1.2.so.0 is needed by (installed) xmms-1.2.8-26
libglib-1.2.so.0 is needed by (installed) timidity-2.12.0-336
libglib-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.1.4-35
libglib-1.2.so.0 is needed by (installed) libdv-0.99-207
libglib-1.2.so.0 is needed by (installed) gocr-0.37-149
libglib-1.2.so.0 is needed by (installed) sane-1.0.10-203
libglib-1.2.so.0 is needed by (installed) gimp-1.2.5-43
libglib-1.2.so.0 is needed by (installed) kdebindings3-c-3.1.4-0
libglib-1.2.so.0 is needed by (installed) xmms-kde-3.0-511
libglib-1.2.so.0 is needed by (installed) kdebindings3-mozilla-3.1.4-0
libglib-1.2.so.0 is needed by (installed) basilisk-0.9-600
libglib-1.2.so.0 is needed by (installed) brahms-1.02-794
libglib-1.2.so.0 is needed by (installed) gtk-engines-0.12-806
libglib-1.2.so.0 is needed by (installed) karamba-0.17-197
libglib-1.2.so.0 is needed by (installed) psx-plugins-20021202-175
libglib-1.2.so.0 is needed by (installed) epsxe-1.5.2-183
libglib-1.2.so.0 is needed by (installed) pcsx-1.3-273
libglib-1.2.so.0 is needed by (installed) gxmhtml-1.4.1.7-463
libglib-1.2.so.0 is needed by (installed) orbit-0.5.17-223
libglib-1.2.so.0 is needed by (installed) oaf-0.6.10-321
libglib-1.2.so.0 is needed by (installed) gconf-1.0.9-546
libglib-1.2.so.0 is needed by (installed) libquicktime-0.9.1-388
libglib-1.2.so.0 is needed by (installed) mjpegtools-1.6.1-225
libglib-1.2.so.0 is needed by (installed) gkeeper-1.0-589
libglib-1.2.so.0 is needed by (installed) smpeg-gtv-0.4.5-57
libglib-1.2.so.0 is needed by (installed) spruce-0.6.5-791
libglib-1.2.so.0 is needed by (installed) wxGTK-2.4.1.2-43
libglib-1.2.so.0 is needed by (installed) wxGTK-gl-2.4.1.2-43
libglib-1.2.so.0 is needed by (installed) gentoo-0.11.34-142
libglib-1.2.so.0 is needed by (installed) orbit-devel-0.5.17-223
libglib-1.2.so.0 is needed by (installed) pinentry-0.6.9-133
libglib-1.2.so.0 is needed by (installed) kopete-0.7.3-21
libglib-1.2.so.0 is needed by (installed) ethereal-0.10.3-20
libglib-1.2.so.0 is needed by (installed) QtPixmap-0.26-68
libglib-1.2.so.0 is needed by (installed) gal-0.24-35
libglib-1.2.so.0 is needed by (installed) gamix-1.99.p13-356
libglib-1.2.so.0 is needed by (installed) gnome-libs-1.4.1.7-463
libglib-1.2.so.0 is needed by (installed) gnome-vfs-1.0.5-569
libglib-1.2.so.0 is needed by (installed) gtklp-0.9p-30
libglib-1.2.so.0 is needed by (installed) kino-0.6.4-145
libglib-1.2.so.0 is needed by (installed) gdk-pixbuf-0.18.0-447
libglib-1.2.so.0 is needed by (installed) grip-3.0.5-203
libglib-1.2.so.0 is needed by (installed) gnome-print-0.36-560
libglib-1.2.so.0 is needed by (installed) libglade-0.17-44
libglib-1.2.so.0 is needed by (installed) xmms-gnome2-0-300
libglib-1.2.so.0 is needed by (installed) alsaplayer-0.99.75-85
libglib-1.2.so.0 is needed by (installed) pmidi-1.5.4-593
libglib-1.2.so.0 is needed by (installed) audacity-1.2.0-53
libglib-1.2.so.0 is needed by (installed) freqtweak-0.5.2-41
libglib-1.2.so.0 is needed by (installed) gtkmm-1.2.10-143
libglib-1.2.so.0 is needed by (installed) gnomemm-1.2.4-40
libglib-1.2.so.0 is needed by (installed) gabber-0.8.7-557
libglib-1.2.so.0 is needed by (installed) broadcast2000-1.0c-665
libglib-1.2.so.0 is needed by (installed) zapping-0.6.7-62
libgmodule-1.2.so.0 is needed by (installed) gtk-1.2.10-710
libgmodule-1.2.so.0 is needed by (installed) imlib-1.9.14-36
libgmodule-1.2.so.0 is needed by (installed) WindowMaker-applets-1.0-469
libgmodule-1.2.so.0 is needed by (installed) fvwm2-2.5.7-52
libgmodule-1.2.so.0 is needed by (installed) ghostscript-x11-7.07.1rc1-37
libgmodule-1.2.so.0 is needed by (installed) xmms-1.2.8-26
libgmodule-1.2.so.0 is needed by (installed) timidity-2.12.0-336
libgmodule-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.1.4-35
libgmodule-1.2.so.0 is needed by (installed) libdv-0.99-207
libgmodule-1.2.so.0 is needed by (installed) gocr-0.37-149
libgmodule-1.2.so.0 is needed by (installed) sane-1.0.10-203
libgmodule-1.2.so.0 is needed by (installed) gimp-1.2.5-43
libgmodule-1.2.so.0 is needed by (installed) kdebindings3-c-3.1.4-0
libgmodule-1.2.so.0 is needed by (installed) xmms-kde-3.0-511
libgmodule-1.2.so.0 is needed by (installed) kdebindings3-mozilla-3.1.4-0
libgmodule-1.2.so.0 is needed by (installed) basilisk-0.9-600
libgmodule-1.2.so.0 is needed by (installed) gtk-engines-0.12-806
libgmodule-1.2.so.0 is needed by (installed) karamba-0.17-197
libgmodule-1.2.so.0 is needed by (installed) psx-plugins-20021202-175
libgmodule-1.2.so.0 is needed by (installed) epsxe-1.5.2-183
libgmodule-1.2.so.0 is needed by (installed) pcsx-1.3-273
libgmodule-1.2.so.0 is needed by (installed) gxmhtml-1.4.1.7-463
libgmodule-1.2.so.0 is needed by (installed) oaf-0.6.10-321
libgmodule-1.2.so.0 is needed by (installed) gconf-1.0.9-546
libgmodule-1.2.so.0 is needed by (installed) libquicktime-0.9.1-388
libgmodule-1.2.so.0 is needed by (installed) mjpegtools-1.6.1-225
libgmodule-1.2.so.0 is needed by (installed) gkeeper-1.0-589
libgmodule-1.2.so.0 is needed by (installed) smpeg-gtv-0.4.5-57
libgmodule-1.2.so.0 is needed by (installed) spruce-0.6.5-791
libgmodule-1.2.so.0 is needed by (installed) wxGTK-2.4.1.2-43
libgmodule-1.2.so.0 is needed by (installed) wxGTK-gl-2.4.1.2-43
libgmodule-1.2.so.0 is needed by (installed) gentoo-0.11.34-142
libgmodule-1.2.so.0 is needed by (installed) orbit-devel-0.5.17-223
libgmodule-1.2.so.0 is needed by (installed) pinentry-0.6.9-133
libgmodule-1.2.so.0 is needed by (installed) kopete-0.7.3-21
libgmodule-1.2.so.0 is needed by (installed) ethereal-0.10.3-20
libgmodule-1.2.so.0 is needed by (installed) QtPixmap-0.26-68
libgmodule-1.2.so.0 is needed by (installed) gal-0.24-35
libgmodule-1.2.so.0 is needed by (installed) gamix-1.99.p13-356
libgmodule-1.2.so.0 is needed by (installed) gnome-libs-1.4.1.7-463
libgmodule-1.2.so.0 is needed by (installed) gnome-vfs-1.0.5-569
libgmodule-1.2.so.0 is needed by (installed) gtklp-0.9p-30
libgmodule-1.2.so.0 is needed by (installed) kino-0.6.4-145
libgmodule-1.2.so.0 is needed by (installed) gdk-pixbuf-0.18.0-447
libgmodule-1.2.so.0 is needed by (installed) grip-3.0.5-203
libgmodule-1.2.so.0 is needed by (installed) gnome-print-0.36-560
libgmodule-1.2.so.0 is needed by (installed) libglade-0.17-44
libgmodule-1.2.so.0 is needed by (installed) xmms-gnome2-0-300
libgmodule-1.2.so.0 is needed by (installed) alsaplayer-0.99.75-85
libgmodule-1.2.so.0 is needed by (installed) audacity-1.2.0-53
libgmodule-1.2.so.0 is needed by (installed) freqtweak-0.5.2-41
libgmodule-1.2.so.0 is needed by (installed) gtkmm-1.2.10-143
libgmodule-1.2.so.0 is needed by (installed) gnomemm-1.2.4-40
libgmodule-1.2.so.0 is needed by (installed) gabber-0.8.7-557
libgmodule-1.2.so.0 is needed by (installed) zapping-0.6.7-62
libgthread-1.2.so.0 is needed by (installed) xmms-1.2.8-26
libgthread-1.2.so.0 is needed by (installed) kdeaddons3-kicker-3.1.4-35
libgthread-1.2.so.0 is needed by (installed) xmms-kde-3.0-511
libgthread-1.2.so.0 is needed by (installed) karamba-0.17-197
libgthread-1.2.so.0 is needed by (installed) spruce-0.6.5-791
libgthread-1.2.so.0 is needed by (installed) wxGTK-2.4.1.2-43
libgthread-1.2.so.0 is needed by (installed) wxGTK-gl-2.4.1.2-43
libgthread-1.2.so.0 is needed by (installed) kopete-0.7.3-21
libgthread-1.2.so.0 is needed by (installed) gnome-vfs-1.0.5-569
libgthread-1.2.so.0 is needed by (installed) kino-0.6.4-145
libgthread-1.2.so.0 is needed by (installed) xmms-gnome2-0-300
libgthread-1.2.so.0 is needed by (installed) alsaplayer-0.99.75-85
libgthread-1.2.so.0 is needed by (installed) audacity-1.2.0-53
libgthread-1.2.so.0 is needed by (installed) freqtweak-0.5.2-41
libgthread-1.2.so.0 is needed by (installed) gabber-0.8.7-557
glib2 is needed by (installed) linc-1.0.3-68
glib2-devel is needed by (installed) linc-devel-1.0.3-68
glib2-devel is needed by (installed) orbit2-devel-2.6.3-29

if i force install this latest version of glib it will cause most of the programs on that list not to work. However Suse 9.0 Yask package manager does not show an update for glib???

how can i install this latest version of Glib and still have programs like xmms to still work correctly????
 
Old 09-04-2004, 12:17 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
You can't glibc is the main underpinning of any linux system once you upgrade it all your other packages have to be either built for it or if doing a source based install built with it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with GLib and related dependencies Godboo Linux - Newbie 1 05-30-2004 05:11 PM
how do I upgrade to glib 2.4.0? emanresu Linux - Software 7 04-25-2004 01:14 PM
Difficult with Dependencies for the GIMP and uninstalling previous version of GLIB harryman100 Linux - Software 0 03-25-2004 02:42 AM
Trying to upgrade glib to 2.0.0 augamecock Linux - General 1 03-20-2002 06:04 PM
glib upgrade ??? webboss Linux - Software 0 10-01-2001 05:55 AM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration