LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2016, 12:30 AM   #1
sangijosh
LQ Newbie
 
Registered: Jan 2016
Posts: 1

Rep: Reputation: Disabled
how to type back slash? Altgr+ vertical line does not work.


how to type backslash? Alt gr+ vertical line does not work.
 
Old 01-29-2016, 02:02 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,104

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267
that depends on your keyboard layout, so hard to say anything from here. Usually it is not far from |, actually on the "default" English layout it is the same key (with and without shift).
 
Old 01-29-2016, 04:26 AM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
On my layout (English-UK) you use Shift-|, not Alt-gr. The key is located in the lower left-hand corner of my keyboard (Logitech K120).
jdk
 
Old 01-29-2016, 04:44 AM   #4
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 5,999

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Quote:
Originally Posted by jdkaye View Post
On my layout (English-UK) you use Shift-|, not Alt-gr. The key is located in the lower left-hand corner of my keyboard (Logitech K120).
jdk
I'm confused now - on my GB keyboards the backslash doesn't need shift it's the pipe symbol which does.
 
Old 01-29-2016, 08:42 AM   #5
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
black slash
Code:
/
forward slash
Code:
\
problem is most people get these backwards...
 
Old 01-29-2016, 08:44 AM   #6
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
I'm confused now - on my GB keyboards the backslash doesn't need shift it's the pipe symbol which does.
quick solution, don't use your shift key when you need to get a blackslash...

mine is US and I have that same problem btw.... if one can call it a problem...

it's located right side just under the BackSpace key..

I just push it with my index finger, works every time

Last edited by BW-userx; 01-29-2016 at 08:47 AM.
 
Old 01-29-2016, 01:27 PM   #7
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,162

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
What sort of keyboard do you use? The backslash is in QWERTY, QWERTZ, and AZERTY.
 
Old 01-29-2016, 03:54 PM   #8
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,176

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
imho(*) backslash is this: \
and on my keyboard (scandinavian) it's reached with AltGr and the plus sign in the top row (i know, it sucks).
i usually use my thumb for AltGr

(*) also wikipedia's
 
Old 01-29-2016, 03:57 PM   #9
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Quote:
Originally Posted by BW-userx View Post
black slash
Code:
/
forward slash
Code:
\
problem is most people get these backwards...
No, you have it backwards.

https://en.wikipedia.org/wiki/Slash_(punctuation)
https://www.cs.ucsb.edu/~pconrad/top...sForwardSlash/
http://www.howtogeek.com/181774/why-...rward-slashes/
http://pc.net/helpcenter/answers/bac..._forward_slash

Last edited by suicidaleggroll; 01-29-2016 at 04:00 PM.
 
Old 01-29-2016, 04:39 PM   #10
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Point proven

the way I was taught in college was it is back slash because it ends on the back stroke, /

the foreward slash ends on the forward stroke /

so blame that college teacher dude ---

Last edited by BW-userx; 01-29-2016 at 04:42 PM.
 
Old 01-30-2016, 02:56 AM   #11
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
I'm confused now - on my GB keyboards the backslash doesn't need shift it's the pipe symbol which does.
No, you're not. My mistake. No shift required for \. I'm the one who was confused, not you.
jdk
 
Old 01-30-2016, 08:01 AM   #12
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by jdkaye View Post
No, you're not. My mistake. No shift required for \. I'm the one who was confused, not you.
jdk
you're the exact reason they invented voice recognition software

Just funnin ya
 
Old 01-30-2016, 08:03 AM   #13
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 5,999

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Quote:
Originally Posted by jdkaye View Post
No, you're not. My mistake. No shift required for \. I'm the one who was confused, not you.
jdk
Ah, thanks, I'm often confused so thought it was me.
 
Old 01-30-2016, 11:47 AM   #14
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,162

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
Out of curiosity, I've been looking at where the "" goes in those keyboards that don't have it printed, but require AltGr. I never realised there were so many possibilities!
_ # < / + Q '

Of course, there's always
Compose / /
 
Old 01-30-2016, 02:17 PM   #15
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
you're the exact reason they invented voice recognition software

Just funnin ya
I should know. That's one of the things I worked on before I retired.
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to type backslash and the vertical line in the terminal? WillingToLikeLinux Linux - Newbie 10 06-11-2009 01:24 PM
AltGr key does not work OlegL Debian 5 09-17-2004 03:22 AM
AltGr key does not work OlegL Linux - Laptop and Netbook 2 08-30-2004 10:35 AM
How do I type 0 with a slash thru it? kc0cxa Linux - General 2 03-06-2004 12:44 AM
Slash is back up. jeremy LQ Suggestions & Feedback 0 09-04-2000 02:55 PM


All times are GMT -5. The time now is 02:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration