LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2004, 07:16 AM   #1
Pedal2Metal
LQ Newbie
 
Registered: Oct 2004
Location: South San Francisco, Ca.
Distribution: 7.3
Posts: 23

Rep: Reputation: 15
How to turn swat on??


I am trying to configure Samba.

I used swat but it said:

An error occured while loading http://127.0.0.1:901/:

Could not connect to host 127.0.0.1 (port 901)

So I used "ifconfig" to check the addressing and the loopback exists.

So then I used "chkconfig" for swat and bash replied that it was off.

How do I turn swat on??
 
Old 10-21-2004, 09:37 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I believe you don't 'start' swat, and it would seem that I am correct:
http://us1.samba.org/samba/docs/man/swat.8.html

I would guess that you don't have Samba running, and that's the reason for the connection error.

Cool
 
Old 10-22-2004, 12:59 AM   #3
emailssent
Member
 
Registered: Sep 2004
Posts: 312

Rep: Reputation: 30
@Pedal2Metal

Type

#nmap localhost

901/tcp open samba-swat

show the output of above command here , and if u could not find any samba-swat entry in your output then try this,

#chkconfig --list|grep swat
swat: off

if above command shows u swat off then do this

#chkconfig swat on


and get back here for any query further.



-jack
 
Old 10-22-2004, 01:01 AM   #4
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Not to be rude but swat is for idiotes. Go into /etc/samba and edit smb.conf. Just read the smb.conf documentation and you will be fine.

inetd or xinetd are daemons that runs a service or server when someone is trying to access a port. A service like swat can be loaded when someone access the port that swat uses. The amount of time swat is loaded depends how fast your hard drive can access files and how many processes are being run at the same time. Yes, swat have to be loaded in order for you to access it.

In Redhat based distributions you can type "service swat start" to start swat manually. The program chkconfig is used to set services to be run and not run at certain runlevels during bootup or during changing from one level to another.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 09:39 AM
Swat paolo623 Linux - Newbie 6 05-31-2005 08:49 AM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 03:22 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 08:05 AM
I need help with swat, please jr_906 Linux - Networking 3 03-06-2002 11:00 PM


All times are GMT -5. The time now is 04:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration