LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2004, 12:21 PM   #1
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Rep: Reputation: 15
how to turn on hd dma acceleration


I recently compiled my slackware kernel (first time ever - i was excited!) but my dma seems to be turned off (sound skips on xmms every now and then and other slow startup issues).

I would not only like to turn it on, but have it turned on automatically at each startup. how can i do this. thanks
 
Old 08-23-2004, 12:26 PM   #2
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
I believe its

# hdparm -d 1

hdparm is to set hd parameters,
-d option to enable/disable dma
1 is on

try google "man hdparm" or type
$man hdparm at console

try
#hdparm -v

to print the current info on drives. You can also try doing

#hdparm -iv - little more info i believe.


Last edited by tuxrules; 08-23-2004 at 12:29 PM.
 
Old 08-23-2004, 12:29 PM   #3
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
will that only turn it on once or each time? is there a config file somewhere that would have information like this. i will also google some more. thanks though.
 
Old 08-23-2004, 12:34 PM   #4
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
here are the google search results
 
Old 08-23-2004, 12:41 PM   #5
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
i already did the google and found a lot. but i got this error:
============================
root@darkstar:/home/jason# hdparm -d 1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
=============================

what is this?
 
Old 08-23-2004, 12:46 PM   #6
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
are you sure thats the drive you wanna set dma for?? I mean hard drive???
 
Old 08-23-2004, 12:58 PM   #7
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
yes
 
Old 08-23-2004, 01:03 PM   #8
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
one of the sites i just found has someone saying
"looks like you forgot to enable via support"

is this possible? or does the via support mean a via chipset (which i do not have - i have nforce2)
 
Old 08-23-2004, 01:07 PM   #9
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
I am not sure that could be the problem but likely it could be. I remember opting for dma option during my slack compile. Try compiling again...also save your current config file so that you dont have to make all the choices once again.
 
Old 08-23-2004, 01:15 PM   #10
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
how do i save the current config - and after, how do i use it during my compile. to compile i used a guide here at lq.... i have it printed out here..... thanks for all the help.
 
Old 08-23-2004, 01:21 PM   #11
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
Go to /usr/src and you'll you see a directory named after your kernel version (something like linux-2.6.x).

cd into the directory
and type ls -a. You'll see a .config file. just save that file to another location (i generally save it in my home directory).

within the linux directory

type
# make mrproper
# make clean

and then copy the .config file again to the directory.

#make menuconfig and now you'll see all your options checked.

then the usual steps to follow.
 
Old 08-23-2004, 01:25 PM   #12
jasonmantey
Member
 
Registered: Aug 2003
Location: Michigan, USA
Distribution: Currnetly SuSE 8.2, but Fedora and Mandrake in the past
Posts: 40

Original Poster
Rep: Reputation: 15
thanks a million.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Turn DMA On Optimistic Debian 8 10-17-2005 07:59 PM
DMA acceleration on Ubuntu walding Linux - Hardware 4 09-19-2005 06:16 PM
kernel 2.6.8.1 dma turn off cb951303 Slackware 12 09-05-2004 04:20 PM
how to turn off dma for harddisk? bejamex Linux - Newbie 1 06-13-2003 12:18 PM
GF4 - Need to turn on 3d acceleration seraphim Linux - Hardware 3 05-01-2003 07:13 PM


All times are GMT -5. The time now is 04:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration