LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to switch to console login? (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-switch-to-console-login-110630/)

miica 10-30-2003 08:16 PM

how to switch to console login?
 
i am using redhat 7.2 and have problem login through X display, i want to switch to console mode and login. how to do that?

my linux will start X everytime, but i cannot login because of the X display problem, i need to do this through console mode.

Thanks

frandalla 10-30-2003 08:25 PM

go to /etc/inittab
you'll find something similar to this:
# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

Change your id:xx:initdefault to 3 (like mine)
reboot and you'll login through text

Demonbane 10-30-2003 08:26 PM

ctrl + alt + F1-6
if that's what you're looking for.

miica 10-30-2003 08:59 PM

thanks for all replying,

frandalla's suggestion might work, but i need to be able to login to edit some files. i cannot login through X, linux tries run X at the login, but failed everytime because of some display problems, so the screen flash everytime, i can't type anything, i need to stop linux from trying to run X and then i login through the console mode.

sorry, i should have tell that i am running my redhat in vmware 4.0.5, i want to login to install vmware-tools, before that, my video driver couldn't work.

Demonbane's suggestion doesn't work, i press ctrl + alt + F1 to F6, but it doesn't stop linux's attempts to run X. the screen is flashing between the console mode and X mode.

i do not intend to confuse you all by not explain clearly, but my english is really that sucks.

any other ways? Thanks again.

dalek 10-30-2003 09:46 PM

Try booting to failsafe. It sounds like you x is messed up or the video drivers. Not sure which though.

If that fails do this, ctrl alt backspace. That will usually kick x's but right out the door.

If you get it to a command line, make sure you change the inittab file so it will boot to command line instead of x. If you need to test a setting just type in startx and see if it smokes or not. If not it should come back to a prompt and tell you what went wrong, sort of.

Hope that helps.

:D :D :D

miica 10-30-2003 10:45 PM

just now, i realized that i can reboot my computer and login to my redhat, but not boot it in my XP's vmware. so all of the above actually works and i already found what i want. thanks you all. :>

Thanks.


All times are GMT -5. The time now is 12:54 PM.