LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-13-2009, 06:51 PM   #1
samsearcher
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Rep: Reputation: 0
how to stop the screen blanking on crunchbang linux


I have installed crunchbang linux and every thing seems to work fine but the screen blanks after 10 min. I have been trying to find an answer on how to stop this with now luck. Anybody got any thoughts on this?
 
Old 06-13-2009, 06:54 PM   #2
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
As in what; your X server dies? What desktop environment are you using? Log files? Have you tried anything to fix this? More information is needed here.
 
Old 06-13-2009, 06:58 PM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
disable the screensaver
if you have a laptop, look at the settings for powermanagement

Last edited by repo; 06-13-2009 at 07:11 PM.
 
Old 06-13-2009, 07:07 PM   #4
samsearcher
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I think crunchbang is using openbox. The screen is blanking in like a screen saver set to blank. If you press a key the screen returns. I have installed gconf-edit and changed the setting to 180 min and this had no effect. I also tried adding this line in xorg.conf
under Section "ServerLayout"
Option "BlankTime" "180"
and it didn't change a thing.
Not sure what to try next.
 
Old 06-13-2009, 07:10 PM   #5
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Have you got more than one screensaver set? Is it as repo suggested and is due to power management settings?

Failing that, time to start going through log files
 
Old 06-14-2009, 11:16 AM   #6
Mehall
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by samsearcher View Post
I think crunchbang is using openbox. The screen is blanking in like a screen saver set to blank. If you press a key the screen returns. I have installed gconf-edit and changed the setting to 180 min and this had no effect. I also tried adding this line in xorg.conf
under Section "ServerLayout"
Option "BlankTime" "180"
and it didn't change a thing.
Not sure what to try next.
It's not set in gconf or xorg.conf

As you said, Crunchbang uses openbox.

The best place to ask about this issue is either the Crunchbang forums or the IRC channel.

However, in Crunchbang 8.10.02, if that is the version you are running the screensaver can be set/changed from an option in the menu.

Right-click on the desktop to bring up the menu (or press Super+Space ) go to "Preferences" then "Screensaver and Power Management"

You can disable the screen saver from there.
 
Old 06-15-2009, 01:01 PM   #7
samsearcher
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Mehall View Post

However, in Crunchbang 8.10.02, if that is the version you are running the screensaver can be set/changed from an option in the menu.

Right-click on the desktop to bring up the menu (or press Super+Space ) go to "Preferences" then "Screensaver and Power Management"

You can disable the screen saver from there.
Thanks Mehall
You would would think that would work but the option Preferences, Screensaver or Power Management are not in the menu.

That is why I have been trying to find the config file used in openbox or Crunchbang so I could just edit that.
 
Old 06-15-2009, 02:13 PM   #8
samsearcher
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
here is what I have found that worked. This has removed the screen saver which is ok for me.
I did a this from the root directory in a terminal.

sudo find -iname autostart.sh

This returned
./home/[yourusername]/openbox/autostart.sh
./etc/xdg/openbox/autostart.sh
./etc/skel/.config/openbox/autostart.sh

then I did this

sudo vim /etc/[yourusername]/openbox/autostart.sh
and in
sudo vim /etc/skel/.config/openbox/autostart.sh

and commented out this line in autostart.sh

#gnome-screensaver &


I also removed them
sudo apt-get remove gnome-screensaver
sudo apt-get remove gnome-power-manager


This might not be right for most people but in my case I only use the this old p2 dell laptop for watching a stock ticker and irc. I don't want it to ever blank. I turn it off when I'm not there.
 
Old 06-16-2009, 02:23 PM   #9
Mehall
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Just had a look in an old menu.xml config file from my crunchbang install (I say old, because I'm on windows now, but they're the same)

the program you wanna run is:

gnome-screensaver-preferences

That's what my link to "Screensaver and power management" links to, so that's where you can fix it (hopefully)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Blanking Out JMJ_coder Slackware 4 09-09-2007 07:45 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
how to stop the monitor from blanking soup Slackware 6 04-02-2004 05:48 AM
Can't stop KDE/Mandrake 9.2 from blanking screen themusk Linux - Software 1 03-20-2004 09:49 PM
screen blanking rekonrad Linux - General 2 09-07-2003 08:23 PM


All times are GMT -5. The time now is 01:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration