LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to stop the screen blanking on crunchbang linux (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-stop-the-screen-blanking-on-crunchbang-linux-732756/)

samsearcher 06-13-2009 06:51 PM

how to stop the screen blanking on crunchbang linux
 
I have installed crunchbang linux and every thing seems to work fine but the screen blanks after 10 min. I have been trying to find an answer on how to stop this with now luck. Anybody got any thoughts on this?

jamescondron 06-13-2009 06:54 PM

As in what; your X server dies? What desktop environment are you using? Log files? Have you tried anything to fix this? More information is needed here.

repo 06-13-2009 06:58 PM

disable the screensaver
if you have a laptop, look at the settings for powermanagement

samsearcher 06-13-2009 07:07 PM

I think crunchbang is using openbox. The screen is blanking in like a screen saver set to blank. If you press a key the screen returns. I have installed gconf-edit and changed the setting to 180 min and this had no effect. I also tried adding this line in xorg.conf
under Section "ServerLayout"
Option "BlankTime" "180"
and it didn't change a thing.
Not sure what to try next.

jamescondron 06-13-2009 07:10 PM

Have you got more than one screensaver set? Is it as repo suggested and is due to power management settings?

Failing that, time to start going through log files

Mehall 06-14-2009 11:16 AM

Quote:

Originally Posted by samsearcher (Post 3573029)
I think crunchbang is using openbox. The screen is blanking in like a screen saver set to blank. If you press a key the screen returns. I have installed gconf-edit and changed the setting to 180 min and this had no effect. I also tried adding this line in xorg.conf
under Section "ServerLayout"
Option "BlankTime" "180"
and it didn't change a thing.
Not sure what to try next.

It's not set in gconf or xorg.conf

As you said, Crunchbang uses openbox.

The best place to ask about this issue is either the Crunchbang forums or the IRC channel.

However, in Crunchbang 8.10.02, if that is the version you are running the screensaver can be set/changed from an option in the menu.

Right-click on the desktop to bring up the menu (or press Super+Space ) go to "Preferences" then "Screensaver and Power Management"

You can disable the screen saver from there.

samsearcher 06-15-2009 01:01 PM

Quote:

Originally Posted by Mehall (Post 3573493)

However, in Crunchbang 8.10.02, if that is the version you are running the screensaver can be set/changed from an option in the menu.

Right-click on the desktop to bring up the menu (or press Super+Space ) go to "Preferences" then "Screensaver and Power Management"

You can disable the screen saver from there.

Thanks Mehall
You would would think that would work but the option Preferences, Screensaver or Power Management are not in the menu.

That is why I have been trying to find the config file used in openbox or Crunchbang so I could just edit that.

samsearcher 06-15-2009 02:13 PM

here is what I have found that worked. This has removed the screen saver which is ok for me.
I did a this from the root directory in a terminal.

sudo find -iname autostart.sh

This returned
./home/[yourusername]/openbox/autostart.sh
./etc/xdg/openbox/autostart.sh
./etc/skel/.config/openbox/autostart.sh

then I did this

sudo vim /etc/[yourusername]/openbox/autostart.sh
and in
sudo vim /etc/skel/.config/openbox/autostart.sh

and commented out this line in autostart.sh

#gnome-screensaver &


I also removed them
sudo apt-get remove gnome-screensaver
sudo apt-get remove gnome-power-manager


This might not be right for most people but in my case I only use the this old p2 dell laptop for watching a stock ticker and irc. I don't want it to ever blank. I turn it off when I'm not there.

Mehall 06-16-2009 02:23 PM

Just had a look in an old menu.xml config file from my crunchbang install (I say old, because I'm on windows now, but they're the same)

the program you wanna run is:

gnome-screensaver-preferences

That's what my link to "Screensaver and power management" links to, so that's where you can fix it (hopefully)


All times are GMT -5. The time now is 04:55 AM.