LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-16-2011, 09:10 AM   #1
linux in malawi
LQ Newbie
 
Registered: Jun 2011
Location: Blantyre malawi
Distribution: Redhat 9, fedora 13 and ubuntu 10.4
Posts: 9

Rep: Reputation: Disabled
Smile how to solve smb.conf and swat problems


how to set smb.conf to its original format.i think i have mess it up since am learning Linux from scratch.another problem is how to solve UNABLE TO CONNECT TO HOST LOCALHOST (901) ERROR.i have set 'disable=no' in /etc/swat file and swat,samba and xinetd are all running.thanks 4 ur answer.if there is any confusion let me no.
 
Old 06-16-2011, 10:50 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,848

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
how to set smb.conf to its original format
Restore your back up, the one you made before you edited the smb.conf file. If you do not have a backup, there is no way to 'restore' it.

Quote:
UNABLE TO CONNECT TO HOST LOCALHOST
Open a konsole and run the command 'ifconfig' with out the quotes. See if you have anything that resembles this:

Quote:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6076 errors:0 dropped:0 overruns:0 frame:0
TX packets:6076 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:399512 (390.1 KiB) TX bytes:399512 (390.1 KiB)
Localhost is the loopback interface, usually IP address 127.0.0.1. If this interface is there, then put http:127.0.0.1 in the location bar, and anything else you need.

If it is not there, try 'ifconfig lo up' ( no quotes). Then try again.

It may also be your /etc/hosts file has not been updated. Add a line for localhost if it is not there. You need to be root to do that. The line should look like this -

Quote:
127.0.0.1 localhost
 
Old 06-16-2011, 11:53 PM   #3
linux in malawi
LQ Newbie
 
Registered: Jun 2011
Location: Blantyre malawi
Distribution: Redhat 9, fedora 13 and ubuntu 10.4
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hie camorrie
i did not save smb.conf,can uninstall & reinstall samba package or even upgrade samba resets smb.conf file to its default?

On swat, i typed ifconfig on prompt as root user.it showed that the lo interface was up and running,and 127.0.0.1 was present in /etc/hosts.when i typed 127.0.0.1:901 or localhost:901 the out come was still 'could not connect to host 127.0.0.1 or localhost (901)
 
Old 06-17-2011, 12:17 AM   #4
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 386
Blog Entries: 3

Rep: Reputation: 25
Maybe this one help.
http://www.linuxquestions.org/questi...server-886172/
 
Old 06-17-2011, 09:34 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,848

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
i did not save smb.conf,can uninstall & reinstall samba package or even upgrade samba resets smb.conf file to its default?
It may be a lot less painful to post the smb.ocnf file you have, and tell us in words what you are trying to accomplish. Basic smb.conf files are not that hard to create.

Port 901, I think is for swat. What I always do is install Webmin, and access swat trough Webmin. Webmin gives you remote access to a lot of useful things.

If port 901 is not responding, either it is not open, ( possibly the daemon is not running ) or you have a firewall blocking access.
 
Old 06-18-2011, 11:19 PM   #6
linux in malawi
LQ Newbie
 
Registered: Jun 2011
Location: Blantyre malawi
Distribution: Redhat 9, fedora 13 and ubuntu 10.4
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hie
i installed redhat 8.0 in vmware for learning purpose.i ve reinstalled redhat 8.0 OS on vmware so that i should start anew with you guys.i ve already trust in you linux guys,i know that i will know much from this community.dont fed up with my linux questions,AM LEARNING through this community.
 
Old 06-18-2011, 11:36 PM   #7
plckiran
LQ Newbie
 
Registered: Mar 2010
Location: India,Hyd
Posts: 6

Rep: Reputation: 1
Use snapshot feature in vmware to record HDD before you make any changes to OS.In case you mess up you can always come back to the snapshot time configuration.
 
1 members found this post helpful.
Old 06-19-2011, 10:36 AM   #8
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,647

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by linux in malawi View Post
Hie
i installed redhat 8.0 in vmware for learning purpose.i ve reinstalled redhat 8.0 OS on vmware so that i should start anew with you guys.i ve already trust in you linux guys,i know that i will know much from this community.dont fed up with my linux questions,AM LEARNING through this community.
If you want to learn, then I'd strongly suggest not loading Redhat 8...it's VERY old, and things have moved on quite a bit since then. Load a current, up-to-date distro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
smb.conf (logon path / problems with profiles)) geodo Linux - Newbie 0 12-02-2004 07:40 AM
Problems with smb.conf irishmage Linux - Networking 1 05-11-2004 05:55 PM
Problems with smb.conf - only Linux box on a 3-computer network [42]Sanf0rd Linux - Newbie 2 04-22-2004 11:17 PM
Fedora smb.conf problems. robojerk Linux - Networking 1 03-29-2004 07:00 PM
Problems connecting to samba shares from w2k or XP systemafter configuring smb.conf f marvc Linux - Software 0 06-09-2003 07:12 AM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration