LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2014, 07:57 AM   #16
Teufel
Member
 
Registered: Apr 2012
Distribution: Gentoo
Posts: 548

Rep: Reputation: 132Reputation: 132

Do you have Grub bootloader installed? Assuming it is. Maybe menu was set to GRUB_TIMEOUT=0 so you do not see any menu, however it must be there.
Reboot your computer, immediately after POST messages press cursor down (or cursor up) keyboard key and hold it until menu appears. When it appear, navigate to first item and press "e" - it will switch you to menu edit mode. Append " single" to line that contains your kernel filename. Press F10 key. It should boot you into single-user mode, when you'll be asked for password type root password and hit Enter. Now you at runlevel 3 and can install your driver.
 
Old 11-08-2014, 08:14 AM   #17
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,602

Rep: Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882
If you are just installing the NVIDIA drivers then I believe the commend you are looking for is:
Code:
sudo service mdm stop
There is simply no need to go changing runlevels or messing around with GRUB just to stop X for a little while. When you're finished you can run:
Code:
sudo service mdm start
Though I would suggest rebooting if installing graphics drivers if for no other reason than to check that they are loaded correctly on boot.
 
Old 11-08-2014, 08:20 AM   #18
mjolnir
Member
 
Registered: Apr 2003
Posts: 750

Rep: Reputation: 83
@273 Those are essentially the two commands I use with Ubuntu 14.04 except that I use "lightdm" in place of "mdm".
 
Old 11-08-2014, 08:31 AM   #19
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,602

Rep: Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882
Quote:
Originally Posted by mjolnir View Post
@273 Those are essentially the two commands I use with Ubuntu 14.04 except that I use "lightdm" in place of "mdm".
Indeed. For Gnome-based systems you use "gdm" and for KDE ones "kdm". Unless, of course, you use a different display manager but, in that case, you ought to know what you installed and that will tell you which service to start and stop. I think on systems other than Debian and Red Hat based ones you may need to refer to /etc/init.d/[gdm|kdm|...] or /etc/rc.d/[gdm|kdm|...] instead of using the "service" command.
 
Old 11-09-2014, 07:29 AM   #20
Hairyloon
LQ Newbie
 
Registered: Mar 2008
Posts: 29

Rep: Reputation: 15
Quote:
Originally Posted by 273 View Post
There is simply no need to go changing runlevels or messing around with GRUB just to stop X for a little while.
Though the NVIDIA instructions make the point that if you automatically run X at boot and the graphic drivers don't work, then you might be a little bit stuck.

Thanks for the suggestions, I'll try when I get home.
 
Old 11-09-2014, 09:27 AM   #21
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,602

Rep: Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882Reputation: 1882
Quote:
Originally Posted by Hairyloon View Post
Though the NVIDIA instructions make the point that if you automatically run X at boot and the graphic drivers don't work, then you might be a little bit stuck.

Thanks for the suggestions, I'll try when I get home.
You should not be stuck at all -- you simply press Ctrl+Alt+F2 and go to the terminal and start again. Just because your system is set up to attempt to start a window manager doesn't mean you're stuck with it -- this isn't Windows...
 
Old 11-09-2014, 08:17 PM   #22
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by Hairyloon View Post
Though the NVIDIA instructions make the point that if you automatically run X at boot and the graphic drivers don't work, then you might be a little bit stuck.

Thanks for the suggestions, I'll try when I get home.
You can run X at boot but you can log into console to stop it.
All you have to do to get into console is <Ctrl+Alt+(Fn1-7)> & stop the DM
 
Old 04-25-2015, 12:21 PM   #23
Commander Angry
LQ Newbie
 
Registered: Apr 2015
Posts: 1

Rep: Reputation: Disabled
Old thread, new information

Yes I know this thread is old, however this following is some updated information that people may find useful these days. To get to a console, you need to shutdown the display manager.One common display manager is "lightdm" or on Mint it's "mdm". You can use "ps aux | grep dm" to look for a running display maanger process, but you should be careful as that list might have multiple items containing those two characters. It's a process started by root and may also appear on the line for your running X.

To get started, once you know your display manager, open a terminal window and type:

sudo service mdm stop
(change mdm to the running display manager)

When you want to return to the desktop, type this:

sudo service mdm start
(again change to the display maanger you used previously)

If you're looged in as root, you do not need to sudo these commands. Quick, easy and painless and worked for me on Mint 17.1 to install the latest nVidia drivers.


-CA
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to shutdown X server in Redhat 8 Eric3 Linux - Newbie 4 10-20-2005 02:51 PM
My Server won't off when i shutdown kamtono Mandriva 1 09-30-2003 09:46 AM
X server shutdown michael_mead Mandriva 2 08-25-2003 09:36 AM
mysterious server shutdown buttnutt Linux - Security 4 06-30-2003 07:04 AM
how can I remote shutdown other WinNT server from Linux Server? adelel Linux - Networking 2 01-06-2002 12:21 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration