LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how to share a folder in samba with no need of user password with write permission (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-share-a-folder-in-samba-with-no-need-of-user-password-with-write-permission-886003/)

golden_boy615 06-13-2011 04:03 AM

how to share a folder in samba with no need of user password with write permission
 
hello
I would like to know how can I share a folder in samba with no need of user and password with write permission, with no need of using guest user.

thanks.

Rearden888 06-13-2011 10:39 PM

I have a home file server set up this way. In the smb.conf file make sure you have the
Code:

# security = user
commented out.

Also, when you define your shares:
Code:

[1tb]
    comment = 1tb
    read only = no
    locking = no
    path = /media/1tb
    guest ok = yes

Then make sure you run chmod a+w to the path.

Keep in mind, this is incredibly insecure and really only appropriate in a very small, contained network, if even then really. You're basically letting anyone who can connect to the network have write access to that share. I only do it this way in order to make things easier for my wife, and I keep very good backups of everything in that folder ;)

golden_boy615 06-14-2011 01:33 AM

it does not work.this is what I did:
Quote:


[global]
workgroup = workgroup-DOMAIN
netbios name = workgroup
server string = workgroup File Server
enable privileges = yes
interfaces = lo,eth0,tap0
bind interfaces only = Yes
passdb backend = ldapsam:ldapi://%2fvar%2frun%2fslapd%2fldapi
ldap ssl = Off
log level = 1
syslog = 0
log file = /var/log/samba/%m
max log size = 50
vfs objects = full_audit
full_audit:success = connect opendir open disconnect unlink mkdir rmdir rename
full_audit:failure = none
smb ports = 137 138 139 445
name resolve order = wins bcast hosts
time server = Yes
printcap name = CUPS
wins support = Yes
dns proxy = Yes
ldap suffix = dc=RAAD,dc=raad,dc=com
ldap machine suffix = ou=Computers
ldap user suffix = ou=Users
ldap group suffix = ou=Groups
ldap idmap suffix = ou=Idmap
ldap admin dn = cn=ebox,dc=RAAD,dc=raad,dc=com
map acl inherit = Yes
printing = cups
security = user

[nopass]
comment = nopass
path = /home/samba/shares/nopass
browseable = Yes
locking = no
guest ok = yes
force create mode = 0777
force directory mode = 0777
vfs objects = full_audit recycle
recycle: versions = Yes
recycle: repository = /home/.Recycles/%U/%I_%S_%T_RecycleBin
recycle: keeptree = Yes
recycle: excludedir = /tmp|/var/tmp
recycle: directory_mode = 0700


but it does not let me use it it wants user and pass from me .

what is wrong ?

Rearden888 06-15-2011 08:09 PM

You have to comment out the security = user line.


All times are GMT -5. The time now is 07:23 PM.