LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2012, 04:18 AM   #1
madhavmahesh
LQ Newbie
 
Registered: Dec 2012
Posts: 5

Rep: Reputation: Disabled
how to setup BSNL broadband connection on ubuntu 10.10


can any one tel me how to setup BSNL broadband connection on ubuntu 10.10 plz....,


thanks inadvance...,
 
Old 12-18-2012, 06:40 AM   #2
Inkit
Member
 
Registered: Feb 2011
Location: India
Distribution: Mint 10
Posts: 142

Rep: Reputation: 15
I don't rightly understand the question. Do you mean you have a BSNL landline with broadband or are you talking about the cellone 3G mobile broadband service that BSNL is providing? I can help if you let me know exactly what it is you need.
 
Old 12-18-2012, 07:14 AM   #3
madhavmahesh
LQ Newbie
 
Registered: Dec 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi Inkit thank you for the reply...,
ha i have a BSNL broadband connection and i connected the ethernet cable to my lapi(lapi is having ubuntu 10.10)..., then it is showing the eth0 is "connection established"...,
but when i open the firefox and try to open google..., it is not opening...,
 
Old 12-18-2012, 07:41 AM   #4
salman108
LQ Newbie
 
Registered: Dec 2012
Posts: 14

Rep: Reputation: Disabled
Quote:
Originally Posted by madhavmahesh View Post
hi Inkit thank you for the reply...,
ha i have a BSNL broadband connection and i connected the ethernet cable to my lapi(lapi is having ubuntu 10.10)..., then it is showing the eth0 is "connection established"...,
but when i open the firefox and try to open google..., it is not opening...,
eth0 is up and running, is it getting the correct IP address ?

are you able to ping your local gateway, which I assume would be from your /24 network.

do this.

ifconfig eth0

what ever your ip address is a.b.c.d

now try to ping a.b.c.1

if you are able to do that, try to ping 4.2.2.2 ( this is an international DNS server)

If you can do both, means your Router is not setting the DNS server, for which you need to change your eth0 setting and forward all DNS to the gateway.
 
Old 12-18-2012, 09:17 AM   #5
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
Use Networkmanager to set up a dsl connection if you are using a modem and not a router.
Otherwise if your router is configured to connect automatically, then set up a automatic connection in NetworkManager.

or use #sudo pppoeconf from konsole/terminal.

Last edited by amani; 12-18-2012 at 09:18 AM.
 
Old 12-18-2012, 11:30 AM   #6
hemasri
LQ Newbie
 
Registered: Apr 2009
Location: India
Distribution: rhel 5
Posts: 7

Rep: Reputation: 0
first u have to configure your modem in router mode,after this configaration in /etc/reslov.conf enter your dns server ip then u r able to connect internet
 
Old 12-18-2012, 12:24 PM   #7
madhavmahesh
LQ Newbie
 
Registered: Dec 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi salman i done as u said...,

here the

~$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 5c:f9:dd:4a:68:f3
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::5ef9:ddff:fe4a:68f3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:94 errors:0 dropped:0 overruns:0 carrier:3
collisions:0 txqueuelen:1000
RX bytes:1766 (1.7 KB) TX bytes:19447 (19.4 KB)
Interrupt:47



~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=0.752 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=0.584 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=2.42 ms

~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=0.752 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=0.584 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=2.42 ms

is it ok plz guide me...,
 
Old 12-18-2012, 12:25 PM   #8
madhavmahesh
LQ Newbie
 
Registered: Dec 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi hemasri
Quote:
first u have to configure your modem in router mode,after this configaration in /etc/reslov.conf enter your dns server ip then u r able to connect internet
can u plz tell me in detail wat i have to do...,
 
Old 12-19-2012, 03:32 AM   #9
salman108
LQ Newbie
 
Registered: Dec 2012
Posts: 14

Rep: Reputation: Disabled
Can you please ping 4.2.2.2 and let me know the results ?


Quote:
Originally Posted by madhavmahesh View Post
hi salman i done as u said...,

here the

~$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 5c:f9:dd:4a:68:f3
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::5ef9:ddff:fe4a:68f3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:94 errors:0 dropped:0 overruns:0 carrier:3
collisions:0 txqueuelen:1000
RX bytes:1766 (1.7 KB) TX bytes:19447 (19.4 KB)
Interrupt:47



~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=0.752 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=0.584 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=2.42 ms

~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=0.752 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=0.584 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=2.42 ms

is it ok plz guide me...,
 
Old 12-19-2012, 05:46 AM   #10
madhavmahesh
LQ Newbie
 
Registered: Dec 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
hi salman i retried the commands..., plz check it...,

n plz dont mine i want early...., i need to install ns2,34 in my lapi..., plz..., anyone...,
~$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 5c:f9:dd:4a:68:f3
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::5ef9:ddff:fe4a:68f3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:442 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:1522 (1.5 KB) TX bytes:41409 (41.4 KB)
Interrupt:47

~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=128 time=2.16 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=128 time=0.849 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=128 time=1.89 ms
64 bytes from 192.168.1.1: icmp_req=4 ttl=128 time=0.523 ms
64 bytes from 192.168.1.1: icmp_req=5 ttl=128 time=0.675 ms
64 bytes from 192.168.1.1: icmp_req=6 ttl=128 time=1.55 ms
64 bytes from 192.168.1.1: icmp_req=7 ttl=128 time=1.87 ms
^C
--- 192.168.1.1 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6003ms
rtt min/avg/max/mdev = 0.523/1.361/2.164/0.617 ms

~$ ping 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.
From 192.168.1.1 icmp_seq=1 Destination Net Unreachable
From 192.168.1.1 icmp_seq=2 Destination Net Unreachable
From 192.168.1.1 icmp_seq=3 Destination Net Unreachable
From 192.168.1.1 icmp_seq=4 Destination Net Unreachable
From 192.168.1.1 icmp_seq=5 Destination Net Unreachable
From 192.168.1.1 icmp_seq=6 Destination Net Unreachable
From 192.168.1.1 icmp_seq=7 Destination Net Unreachable
^C
--- 4.2.2.2 ping statistics ---
7 packets transmitted, 0 received, +7 errors, 100% packet loss, time 6002ms
 
Old 12-24-2012, 12:10 PM   #11
hemasri
LQ Newbie
 
Registered: Apr 2009
Location: India
Distribution: rhel 5
Posts: 7

Rep: Reputation: 0
if u send u r modem model i will guide u how to connect to internet
pls checkout this link guides u well

http://mydataone.net/router/wa3002g4.html
 
Old 12-25-2012, 06:56 AM   #12
jsaravana87
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 558
Blog Entries: 5

Rep: Reputation: Disabled
As you mentioned connection established is established.Try out my changing the firefox setting to Auto detect proxy setting and try to connect internet
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to configure bsnl broadband connection in fedora 7 bhavanipraveen Linux - Networking 4 04-28-2011 05:03 AM
How to start BSNL Broadband connection on Ubuntu Linux 10.4 lts dil1857 Linux - Networking 2 09-08-2010 06:41 AM
Configuring BSNL broadband connection shree_gn Linux - Newbie 7 09-09-2009 04:31 PM
how to make broadband (bsnl) connection on Suse linux? sakshi Linux - Newbie 5 02-15-2009 11:11 AM
BSNL Broadband setup prashullegaddi Linux - Networking 0 10-02-2007 10:14 AM


All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration