LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2007, 07:02 AM   #1
Manjunatha Lokesh
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Unhappy How to set up Open SSH to work without password


Hi,

I have setup the Open SSH and configured it and I have generated public and private keys and copied public key to server location by following steps given in open ssh document, But still it is asking for password while logging in to server location, as per document it should not ask for password it has to read password from public Authorized key for known users.


The configuration steps are given in

%HOME_PATH%\OpenSSH\docs\quickstart.txt
%HOME_PATH%\OpenSSH\docs\ readme.txt
%HOME_PATH%\OpenSSH\docs\ key_authentication.txt



Here are the steps I followed to configure SSH.

1) Install Open SSH
2) Create proper group and passwd files. To add local groups to the group file, use the -l switch, for domain groups, use the -d switch:
3) mkgroup -l >> ..\etc\group (local groups)
4) mkgroup -d >> ..\etc\group (domain groups)
5) mkpasswd -l [-u <username>] >> ..\etc\passwd (add username to passwd - local user)
6) mkpasswd -d [-u <username>] >> ..\etc\passwd (add username to passwd - domain user)
7) To Key Authentication with SSH create unique public/private key pair using ssh-keygen -t keytype
8) ssh-keygen -t rsa
9) Putting created Public Key on the Server, copy the public key to /home/username/.ssh/
10) Place Key in the Authorized Keys File, append the key you copied to a file called authorized_keys or authorized_keys2
11) Fix StrictModes (Windows Only), turning StrictModes off in the sshd.conf file under the etc directory and restarting the service.
12) Set the following options under %HOME_PATH%\OpenSSH\etc\ssh_config file
a. PasswordAuthentication no
b. PubkeyAuthentication yes under
13) Set the following options under %HOME_PATH%\OpenSSH\etc\sshd_config file
a. PubkeyAuthentication yes
b. AuthorizedKeysFile .ssh/authorized_keys
c. PasswordAuthentication no
d. PermitEmptyPasswords yes


Could you please check why it is not working and please let me know what other setting I have to do to make it work.


Thanks,


Manjunatha L
manjunatha.lokesh@oracle.com
 
Old 09-26-2007, 08:17 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Welcome to LQ!

I've always found this tutorial to be an excellent method to follow. It is a little dated, but the basics are still the same.

One thing in your procedure that does stand out is the location of the sshd_config file. It is likely NOT in the %HOME_PATH% directory, assuming that this variable is pointing toward a directory in /home. Usually, the sshd config file is in /etc/ssh, so it is possible that you haven't changed the sshd configuration for your running server. Of course be sure to restart the server once you've made your changes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh keeps asking for password, have set up passwordless gorbgorb Linux - Networking 4 03-21-2007 05:24 PM
root password doesn't work for ssh linuxuser00 Linux - Newbie 5 01-31-2007 12:05 PM
How to set power-on password in AIX work station unixrao AIX 6 10-26-2006 12:47 AM
ssh password set to NULL? SiLiCoN Linux - Security 2 09-20-2004 07:53 AM


All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration