LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2001, 09:34 AM   #1
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
How to set up Linux with a cable connection?


How do I set up Linux to use my cable connection? When it booted up, it found the network card, and it supposedly set it up, but I am still not connected. What should I do?
 
Old 08-09-2001, 09:51 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
The easiest way for someone new with Linux is to use Linuxconf. There you will find the settings configuration to put in your DNS, IP and other info for your connection. Don't know your info, call your ISP or if you have Windows you can get the info there, from winipcfg, ipconfig or whatever.....
 
Old 08-09-2001, 09:57 AM   #3
simpilot
LQ Newbie
 
Registered: Aug 2001
Location: Dallas, TX
Distribution: RedHat 7.1
Posts: 8

Rep: Reputation: 0
How about whyn the cable modem ISP is setup for DHCP, as many are now ?
 
Old 08-09-2001, 10:16 AM   #4
d3funct
Member
 
Registered: Jun 2001
Location: Centralia, WA
Posts: 274

Rep: Reputation: 31
If your cable modem ISP is setting you up with a DHCP address, all you have to do is su - root and run "setup" in the menu option "network" tell it to use DHCP, then run /etc/rc.d/init.d/network restart. You should be able to get out now.
 
Old 08-09-2001, 05:44 PM   #5
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
Here is some more info.
My cable provider (cox @home) uses DHCP. When I run netconfig, I set it to DHCP and click OK to go to the next screen, but it pops up a message and quickly goes back to the first screen. The message reads "Sending ??????? for IP information...". I don't know what the second word is, but I know is 7 characters long. Just about anything I do in Linuxconf pops up "Invalid line 1 in /etc/resolv.conf". resolv.conf contains one line and one word: "search". What should my resolv.conf look like?
 
Old 08-10-2001, 12:04 AM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
the resolv.conf file is where your DNS server listings are.
Try putting in your actual ISP's DNS server names here like in this format:

Code:
nameservers  192.0.0.1
nameservers  192.0.0.2
 
Old 08-10-2001, 12:13 AM   #7
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
I don't know what my ISP's DNS server names are. In Windows DNS is disabled, and I don't have any problem with Windows connecting.
 
Old 08-10-2001, 12:32 AM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
try configuring in netconfig then instead of linuxconf.
sorry, its netcfg and you need to be root.
 
Old 08-10-2001, 02:06 PM   #9
d3funct
Member
 
Registered: Jun 2001
Location: Centralia, WA
Posts: 274

Rep: Reputation: 31
Also, you should be able to get all of your resolve info from your network configuration properties in windows when connected to your ISP from your windows box. You will also need a "search" entry with a domain defined in /etc/resolv.conf. I'm using the search domain as is on my linux box because I use AT&T @home and I assume your using @home also. You'd think it would be just "home.com" or some such, but it is actually "yourlocale.state.home.com", mine is in Olympia, Washington (olmpi1.wa.home.com, that's just my domain. You'll need to know this for DNS resolution)

/etc/resolv.conf should look something like this:

search youlocale.state.home.com
nameserver 111.222.333.444
nameserver 555.666.777.888

You can add this manually from the command line as well as using "netcfg", but you have to be root to do either.
 
Old 08-10-2001, 05:24 PM   #10
simpilot
LQ Newbie
 
Registered: Aug 2001
Location: Dallas, TX
Distribution: RedHat 7.1
Posts: 8

Rep: Reputation: 0
In a windoz box you can run the command "winipcfg" select the ethernet adapter from the dropdown menu and it will give you all the info that your looking for.
 
Old 08-10-2001, 05:25 PM   #11
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
Here is output from netcfg 2> netcfg.txt:

Traceback (innermost last):
File "/usr/lib/rhs/netcfg/netcfg.py", line 24, in ?
from rhtkinter import *
File "/usr/lib/rhs/python/rhtkinter.py", line 52, in ?
e = Entry()
File "/usr/lib/python1.5/lib-tk/Tkinter.py", line 1354, in __init__
Widget.__init__(self, master, 'entry', cnf, kw)
File "/usr/lib/python1.5/lib-tk/Tkinter.py", line 1078, in __init__
BaseWidget._setup(self, master, cnf)
File "/usr/lib/python1.5/lib-tk/Tkinter.py", line 1055, in _setup
_default_root = Tk()
File "/usr/lib/python1.5/lib-tk/Tkinter.py", line 886, in __init__
self.tk = _tkinter.create(screenName, baseName, className)
TclError: no display name and no $DISPLAY environment variable

The $DISPLAY environment variable doesn't exist, what should it look like?

Also, when I shut down I get:

shutting down interface eth0 down: error fetching interface information: device not found
 
Old 08-10-2001, 05:35 PM   #12
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
In my Windows box, everything is either set to 'auto' or 'disabled'. When I go to Network properties and get properties on TCP/IP -> D-Link ...... , DNS is disabled, Gateway is left blank, WINS config is disabled, and IP address is obtained automatically.
 
Old 08-10-2001, 07:46 PM   #13
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally posted by justin19fl
In my Windows box, everything is either set to 'auto' or 'disabled'. When I go to Network properties and get properties on TCP/IP -> D-Link ...... , DNS is disabled, Gateway is left blank, WINS config is disabled, and IP address is obtained automatically.
if your using DHCP yes, it will show up with nothing cause Windows automatically gets that info once on the net, if you have 95/98 type winipcfg in the start/run box.... that should get the info when your on the net in windows, dns, gateway...etc...
if your using NT, type in the DOS prompt ipconfig /all and then you should get the info from there.
 
Old 08-10-2001, 09:08 PM   #14
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
Ok, I've printed all of the info that I can get from 'WinIPcfg', and now I'm running around in 'linuxconf' plugging numbers. The only problem is it keeps wanting numbers that I don't have, and I have too many numbers that it don't want.
 
Old 08-10-2001, 09:20 PM   #15
justin19fl
Member
 
Registered: Apr 2001
Location: Pensacola, Florida
Distribution: Red Hat 9
Posts: 42

Original Poster
Rep: Reputation: 15
What do I put down for host name, primary name + domain, net device, and kernel module?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Cable connection in linux but not windows?! Guitarist88 Linux - Networking 1 08-19-2004 02:19 AM
direct connection to Linux through a serial cable 0perat0r Linux - Newbie 5 08-03-2004 03:04 PM
Linux is hell!!! cant make cable connection! HELP!! polopolo Linux - Newbie 3 04-07-2004 02:19 PM
Need to connect Linux PC on a Mac Airport/cable connection tigerflag Linux - Networking 6 08-23-2002 01:18 PM
Linux Driver for COM21 Doxport Cable Modem with USB Connection deray Linux - Hardware 2 06-17-2002 04:52 PM


All times are GMT -5. The time now is 05:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration