LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-20-2012, 10:47 AM   #1
mvreddy
LQ Newbie
 
Registered: Apr 2012
Posts: 2

Rep: Reputation: Disabled
Unhappy How to set the default boot to windows7?


Hi all!
I have the HP laptop Pavilion dv6-3121 loaded with dual O/S windows 7 and Fedora 16. My laptop is set to go with fedora as default boot. when I power off the system when I reboot again then only I am getting my option to enter the GRUB to go with either windows or linux. In case if I restart the machine I am not getting the GRUB options and is directly logging into fedora. As a result i am unable to logon to windows. Please help me out in this regard
Thanks in advance.
 
Old 08-20-2012, 10:54 AM   #2
Vegan
Member
 
Registered: Aug 2010
Location: Idaho
Distribution: Arch, Ubuntu, Fedora
Posts: 114
Blog Entries: 2

Rep: Reputation: 10
edit /boot/grub/menu.lst as root.

You can change the default os to windows from there. you can also set how many seconds the boot menu shows.
 
Old 08-20-2012, 12:22 PM   #3
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Quote:
Originally Posted by Vegan View Post
edit /boot/grub/menu.lst as root.

You can change the default os to windows from there. you can also set how many seconds the boot menu shows.
On Fedora 16, that should be:
Code:
/boot/grub2/grub.cfg
Inside there, you'll find several different lines that start with "menuentry", such as:
Code:
menuentry 'Fedora (3.4.7-1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
These are your boot options in grub, the first one is zero, and they increase from there. You set the default with the line that says 'set default="0"'. So if you have four entries, the first three are various Fedora kernel versions and the last one is Win7, you would change 'set default="0"' to 'set default="3"'.
 
Old 09-02-2012, 11:52 AM   #4
mvreddy
LQ Newbie
 
Registered: Apr 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
thanks all for the kind replies.
The problem is resolved by changing the boot configuration file as suggested.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Making windows7 default boot moonmoth Linux - General 2 07-12-2011 04:04 PM
ubuntu 10.4 grub set default kernel to boot fyoder Linux - Software 2 10-02-2010 04:18 PM
New windows7 netbook, how to set up dual boot? sls54 Linux - Newbie 16 08-10-2010 12:02 AM
How to set (or delete) default gateway at boot? colucix VectorLinux 6 07-05-2009 04:15 PM
How to set the default boot operating system at the boot menu Niceman2005 Linux - General 2 04-12-2006 10:46 PM


All times are GMT -5. The time now is 04:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration