LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-28-2009, 01:37 AM   #1
Dbajaj
LQ Newbie
 
Registered: Dec 2009
Posts: 4

Rep: Reputation: 0
Lightbulb How to set keys of the keyboard


Hi all
I am facing a problem with my keyboard keys.I am using Qwerty keyboard with 107 keys on Fedora10.When I press a key it inserts wrong character.Following are the Table of keys and its inserted character.

Key ============== Insertion
@ ============================= "
" ============================== @
# ==============================
\ =============================== #
swift+\ =============================== ~
swift+~
Further, I don't know which key I use for inserting "\" character, which I need frequently.

I would appreciate your help in resolving this issue.

Thanks in Advance
Dbajaj

Last edited by Dbajaj; 12-28-2009 at 01:43 AM.
 
Old 12-28-2009, 02:01 AM   #2
raj.darkmystery
LQ Newbie
 
Registered: Oct 2009
Posts: 28

Rep: Reputation: 15
m having the same problem but my OS is vista... anyone knows how to resolve this issue?
while other OS's solaris, ubuntu, mandriva over VBox r working fine and displaying correct characters

Last edited by raj.darkmystery; 12-28-2009 at 02:02 AM.
 
Old 12-28-2009, 01:07 PM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,180

Rep: Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801Reputation: 801
This is just a question of having the correct keyboard driver loaded. For example, using a UK driver with a US keyboard causes @# to come out as ". The is only found on UK keyboards, so you're clearing using the driver gb.

If you have 107 keys, you presumably need an appropriate East Asian driver. Enter the menu at System - Preferences - Hardware - Keyboard and click on the Layout tab. You can then add the appropriate driver, set it as the default, and then remove the unwanted one.
 
1 members found this post helpful.
Old 12-29-2009, 01:11 AM   #4
Dbajaj
LQ Newbie
 
Registered: Dec 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Wink Thanks

My problem has been solved.
Thanks Lot DavidMcCann
 
Old 12-30-2009, 12:11 AM   #5
raj.darkmystery
LQ Newbie
 
Registered: Oct 2009
Posts: 28

Rep: Reputation: 15
yeah thanks David... my keyboard is working fine now... i was not knowing that troubleshoot is so simple.. thanks again...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB keyboard function keys/numeric keys on boot raypen Linux - Hardware 4 04-17-2008 04:07 PM
Keyboard Multimedia keys l00zer Linux - Hardware 3 04-01-2007 09:17 PM
usb keyboard and soundcard conflict (sound set to keyboard?) netsurf Linux - Hardware 2 04-09-2005 08:08 AM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 10:36 PM
Bind keyboard keys DigitalTygrrr Linux - Hardware 1 07-24-2003 11:23 PM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration