LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2009, 02:58 AM   #1
gajidele
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Rep: Reputation: 0
How to set AUTONEG OFF on RedHat WS 4 update 5


We run Redhat Workstation 4 update 5 (64-bit) and tried to set the autoneg off using the following command and received errors:

#ethtool -s ethx autoneg off speed 1000 duplex full

Cannot set new settings: Invalid argument
not setting speed
not setting duplex
not setting autoneg

Secondly,

editted the file /etc/sysconfig/network-scripts/ifcfg-ethx to include the following line:

ETHTOOL_OPTS="autoneg off speed 1000 duplex full"

and run the command: #service network restart

This action disabled the interface. We have rebooted and the interface is still disabled. We have chenged the ifcfg-ethx file back to the original form and rebooted, still the same problem.

Please help out with some advise.
 
Old 01-07-2009, 07:21 AM   #2
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
Can you bring it up with ifconfig?

Code:
ifconfig eth0 media 1000baseTX mediaopt full-duplex $IP-ADDRESS
 
Old 01-07-2009, 07:40 AM   #3
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
If you are forcing the speed and duplex settings of the interface, I don't think you need to specify Autoneg off.. That's sorta redundant.
ethtool -s eth0 speed 1000 duplex full

and remember if you are forcing speed and duplex on a NIC you MUST do the same to the switchport the device is connected to, or you will cause a duplex mismatch.


not sure why your nic didn't come back up.. is there anything in your logs ?
cat /var/log/dmesg | grep -i eth
 
Old 01-07-2009, 07:42 AM   #4
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by arckane View Post
Can you bring it up with ifconfig?

Code:
ifconfig eth0 media 1000baseTX mediaopt full-duplex $IP-ADDRESS
I don't think that will work.

OP,do you have Realtek PCI/PCcard/s and what driver do you use for it,if so?
 
Old 01-07-2009, 08:24 AM   #5
gajidele
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Entries in /var/log/dmesg
divert: not allocating divert_blk for non-ethernet device lo
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.42-rh.
divert: allocating divert_blk for eth0
eth0: forcedeth.c: subsystem: 0103c:12fe bound to 0000:00:08.0
divert: allocating divert_blk for eth1
eth1: forcedeth.c: subsystem: 0103c:12fe bound to 0000:00:09.0


# lspci |grep -ethernet
00:08.0 Ethernet controller: nVidia Corporation MCP55 Ethernet (rev a3)
00:09.0 Ethernet controller: nVidia Corporation MCP55 Ethernet (rev a3)

System is HPxw 9400.


Entries in /var/log/dmesg relating to ethernet:
 
  


Reply

Tags
network


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change autoneg settings petervanderkamp Linux - Networking 0 09-28-2007 01:25 AM
autoneg issue jj3666 Linux - Networking 3 04-10-2006 03:23 PM
RedHat Enterprise. How to go from V3 Update 1 to V3 Update 3? vectorz2 Linux - Software 3 05-07-2005 02:50 AM
redhat linux update databse's type and utility like windows update services kamii47 Linux - General 1 04-18-2005 05:50 AM
Quota:cannot be set and update swmok Linux - Software 1 10-22-2003 07:30 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration