LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-10-2008, 10:32 PM   #1
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Rep: Reputation: 15
how to run vmware on ubuntu,


why it told me the ./install .pl command not found when i type sudo ./install.pl ????
thanks very much !!!!!!!!!!!!!!!!!!!!!!!
 
Old 10-10-2008, 10:47 PM   #2
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
why it told me there is no " ./install.pl " when i execute sudo ./install.pl ? thanks

thanks advance
 
Old 10-11-2008, 12:19 AM   #3
klearview
Member
 
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
Maybe because there was no install.pl in the directory you were in? install.pl was not executable?

Make sure you are in the right directory (or use the full path i.e. /home/username/path/to/install.pl) and install.pl has executable permission (used 'chmod a+x install.pl').

Hope this helps but if no luck post output from 'ls -la' here.
 
Old 10-11-2008, 12:20 AM   #4
lucktsm
Member
 
Registered: May 2004
Location: Atlanta, GA USA
Distribution: Redhat ES4, FC4, FC5, slax, ubuntu, knoppix
Posts: 155

Rep: Reputation: 30
Don't use the ./ it will be in the installation directory of vmware.
 
Old 10-11-2008, 03:25 AM   #5
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
so~what is the other way??????
 
Old 10-11-2008, 03:43 AM   #6
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
i wanna run vmware on ubuntu, and i follow the steps that wiki told me to tpye this command"sudo ./install.pl"
and this is the output of ls -la thanks!

drwxr-xr-x 63 j j 4096 2008-10-11 16:23 .
drwxr-xr-x 3 root root 4096 2008-07-25 23:23 ..
drwxr-xr-x 3 j j 4096 2008-10-03 15:25 Academic
drwx------ 3 j j 4096 2008-07-27 10:54 .adobe
drwxr-xr-x 4 j j 4096 2008-10-10 22:48 .aMule
-rw------- 1 j j 7873 2008-10-11 13:02 .bash_history
-rw-r--r-- 1 j j 220 2008-07-25 23:23 .bash_logout
-rw-r--r-- 1 j j 2940 2008-07-25 23:23 .bashrc
drwxr-xr-x 5 j j 4096 2008-10-11 10:55 BTDOWNLOAD
drwxr-xr-x 4 j j 4096 2008-08-19 19:33 .cache
drwx------ 2 j j 4096 2008-07-26 11:34 .chewing
drwx------ 3 j j 4096 2008-08-31 11:05 .compiz
drwxr-xr-x 7 j j 4096 2008-08-31 10:24 .config
drwxr-xr-x 4 j j 4096 2008-10-11 11:14 deb
drwxr-xr-x 2 j j 4096 2008-10-11 16:11 Desktop
-rw------- 1 j j 28 2008-10-11 15:53 .dmrc
drwxr-xr-x 13 j j 4096 2008-10-11 02:02 Documents
-rw------- 1 j j 16 2008-07-25 23:27 .esd_auth
drwxr-xr-x 4 j j 4096 2008-10-11 14:30 .eva
drwxr-xr-x 8 j j 4096 2008-10-11 15:13 .evolution
lrwxrwxrwx 1 j j 26 2008-07-25 23:23 Examples -> /usr/share/example-content
drwxr-xr-x 2 j j 4096 2008-10-11 02:01 .FBReader
drwxr-xr-x 2 j j 4096 2008-08-02 14:25 .fontconfig
drwx------ 6 j j 4096 2008-10-11 15:53 .gconf
drwx------ 2 j j 4096 2008-10-11 16:39 .gconfd
drwxr-xr-x 22 j j 4096 2008-10-04 00:56 .gimp-2.4
-rw-r----- 1 j j 0 2008-10-11 14:53 .gksu.lock
drwxr-xr-x 3 j j 4096 2008-08-31 10:57 .gnome
drwx------ 19 j j 4096 2008-10-11 16:16 .gnome2
drwx------ 2 j j 4096 2008-07-25 23:27 .gnome2_private
drwx------ 2 j j 4096 2008-10-11 15:53 .gnupg
drwxr-xr-x 2 j j 4096 2008-08-04 14:27 .gstreamer-0.10
-rw-r--r-- 1 j j 92 2008-10-11 16:00 .gtk-bookmarks
dr-x------ 2 j j 0 2008-10-11 15:53 .gvfs
-rw------- 1 j j 4609 2008-10-11 15:53 .ICEauthority
drwxr-xr-x 2 j j 4096 2008-07-26 10:01 .icons
drwxr-xr-x 2 j j 4096 2008-08-02 20:20 Incomplete
drwx------ 3 j j 4096 2008-07-26 10:04 .kde
-rw------- 1 j j 35 2008-10-01 00:09 .lesshst
drwx------ 5 j j 4096 2008-08-03 21:09 .licq
drwxr-xr-x 3 j j 4096 2008-07-25 23:27 .local
drwx------ 3 j j 4096 2008-07-27 10:54 .macromedia
drwxr-xr-x 3 j j 4096 2008-07-26 10:05 .mcop
-rw------- 1 j j 31 2008-10-11 14:40 .mcoprc
drwx------ 3 j j 4096 2008-07-25 23:27 .metacity
drwx------ 4 j j 4096 2008-08-24 19:35 .mozilla
drwx------ 3 j j 4096 2008-08-24 19:35 .mozilla-thunderbird
drwxr-xr-x 2 j j 4096 2008-07-28 10:49 .mplayer
drwxr-xr-x 5 j j 4096 2008-10-03 10:24 Music
drwxr-xr-x 3 j j 12288 2008-10-11 15:13 .nautilus
drwx------ 3 j j 4096 2008-10-11 02:01 .openoffice.org2
drwxr-xr-x 2 j j 4096 2008-09-15 21:50 Photos
drwxr-xr-x 12 j j 4096 2008-09-29 22:46 Pictures
-rw------- 1 j j 12288 2008-07-31 22:20 .practice.swp
-rw------- 1 j j 12288 2008-07-31 22:32 .professor.swp
-rw-r--r-- 1 j j 586 2008-07-25 23:23 .profile
drwxr-xr-x 2 j j 4096 2008-07-25 23:27 Public
drwxr-xr-x 2 j j 4096 2008-07-26 11:40 .pulse
-rw------- 1 j j 256 2008-07-25 23:27 .pulse-cookie
drwx------ 5 j j 4096 2008-09-04 21:50 .purple
drwxr-xr-x 2 j j 4096 2008-07-26 10:04 .qt
-rw------- 1 j j 24904 2008-10-09 12:04 .recently-used
-rw-r--r-- 1 j j 459489 2008-10-11 16:23 .recently-used.xbel
drwx------ 4 j j 4096 2008-07-26 12:37 .scim
drwxr-xr-x 3 j j 4096 2008-08-16 22:05 .smplayer
drwx------ 2 j j 4096 2008-07-25 23:27 .ssh
drwx------ 2 j j 4096 2008-08-03 21:03 .stardict
-rw-r--r-- 1 j j 0 2008-07-25 23:30 .sudo_as_admin_successful
drwxr-xr-x 2 j j 4096 2008-07-25 23:27 Templates
drwxrwxrwx 3 j j 4096 2008-08-14 21:32 .Tencent
drwxr-xr-x 2 j j 4096 2008-07-27 22:12 THEME
drwxr-xr-x 6 j j 4096 2008-07-27 21:44 .themes
drwx------ 5 j j 4096 2008-09-15 21:49 .thumbnails
drwxr-xr-x 5 j j 4096 2008-07-26 11:57 .transmission
drwxr-xr-x 2 j j 4096 2008-08-04 11:13 .update-manager-core
drwx------ 2 j j 4096 2008-08-04 12:46 .update-notifier
drwxr-xr-x 4 j j 4096 2008-09-15 17:13 Videos
drwxr-xr-x 3 j j 4096 2008-07-28 11:17 .vlc
drwxr-xr-x 2 j j 4096 2008-10-05 23:36 .wapi
drwxr-xr-x 4 j j 4096 2008-08-04 10:05 .wine
-rw------- 1 j j 121 2008-10-11 15:53 .Xauthority
drwxr-xr-x 2 j j 4096 2008-08-03 10:09 .xinput.d
-rw-r--r-- 1 j j 146 2008-09-04 22:35 .xscreensaver-getimage.cache
-rw-r--r-- 1 j j 4318 2008-10-11 16:40 .xsession-errors
 
Old 10-11-2008, 03:59 AM   #7
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
As klearview already pointed out, there is no install.pl in the current directory. I assume you are new to linux, so... when you type ./something it means that something is a file or a directory under the current working directory.

This told, before running the install script you have to be sure you are in the directory where the script resides. What other previous steps you've done so far? Maybe you have extracted a vmware archive somewhere, e.g. a file named something.tar.gz or something.tar.bz2...
 
Old 10-11-2008, 09:03 AM   #8
LinuxCrayon
Member
 
Registered: Nov 2007
Location: Georgia, USA
Distribution: FreeBSD
Posts: 274

Rep: Reputation: 31
Please don't double post.
 
Old 10-11-2008, 09:29 AM   #9
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
oooooooooooooooooooooooook
 
Old 10-11-2008, 09:47 AM   #10
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
yeah, i am new to linux , i have done this "sudo apt-get install build-essential " and "cd /home/j/deb/vmware" and download a package named "VMware-workstation-6.0.5-109488.i386.tar.gz" and i extracted it to here "/home/j/deb/vmware " and then i did this" sudo ./install.pl " and it told me that "./install.pl command not found" thanks!!!!!!!!!!!!!!!!1
 
Old 10-11-2008, 11:11 AM   #11
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Can you do a "locate install.pl" to find out which directory contains the file?
 
Old 10-11-2008, 11:19 AM   #12
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Well, you have your directory deb and I presume that vmware is under it. So you need to change directory into deb, which you do thusly from your home directory (j):

cd deb

Once in deb, execute ls -al and make sure vmware is there, then cd vmware. From there you should be able to run your install script.
 
Old 10-11-2008, 11:40 AM   #13
LinuxCrayon
Member
 
Registered: Nov 2007
Location: Georgia, USA
Distribution: FreeBSD
Posts: 274

Rep: Reputation: 31
Quote:
Originally Posted by lucktsm View Post
Don't use the ./ it will be in the installation directory of vmware.
Why would you NOT use the ./ ?
 
Old 10-11-2008, 09:27 PM   #14
topheraholic
Member
 
Registered: Aug 2008
Location: shanghai
Distribution: ubuntu
Posts: 128

Original Poster
Rep: Reputation: 15
j@sfz-laptop:~$ cd deb
j@sfz-laptop:~/deb$ ls -la
total 28544
drwxr-xr-x 4 j j 4096 2008-10-11 11:14 .
drwxr-xr-x 63 j j 4096 2008-10-12 10:15 ..
drwxr-xr-x 2 j j 4096 2008-08-20 20:22 dic
-rw-r--r-- 1 j j 10009454 2008-08-16 19:37 essential-20071007.tar.bz2
-rw-r--r-- 1 j j 4870522 2008-08-14 21:30 linuxqq_1.0-Preview1_i386.deb
drwxr-xr-x 4 j j 4096 2008-10-11 11:14 vmware
-rw-r--r-- 1 j j 14276518 2008-08-16 19:55 w32codecs_20071007-0.1_i386.deb
j@sfz-laptop:~/deb$ cd vmware
j@sfz-laptop:~/deb/vmware$ sudo ./install.pl
sudo: ./install.pl: command not found

see? that is all! everytime i did i got this prompt!! i donot know what should i do!
thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Old 10-11-2008, 09:35 PM   #15
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Are you sure it isn't called vmware_install.pl? Run ls -al on your vmware directory to find out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HowTo for setting up VMware to run XP kromberg Linux - Software 4 07-17-2008 10:37 AM
VMware cannot run anymore sigkill Linux - Software 2 01-31-2008 08:29 AM
VMware servers don't run dtakle Linux - Software 2 08-14-2006 05:14 PM
Can't run vmware as non-root user dx0r515t Slackware 4 08-10-2006 07:31 PM
Distro to run VMware 4.0.5 tekoa Linux - Newbie 1 04-10-2005 07:45 PM


All times are GMT -5. The time now is 11:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration