LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2010, 01:24 AM   #16
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled

mikabrown85, please stop advertising here. This is the second post of yours that has been reported for advertising.
 
Old 10-25-2010, 01:49 AM   #17
SeZen
LQ Newbie
 
Registered: Oct 2010
Posts: 10

Original Poster
Rep: Reputation: 0
this is what i found :

[frdeni@localhost ~]$ lspci |grep -i audio
00:08.0 Audio device: nVidia Corporation Device 0d94 (rev a2)
 
Old 10-25-2010, 02:05 AM   #18
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
I don't see what's so special about that device; you should be able to use the in-kernel driver. Can you run lsmod | grep snd and post the results please?
 
Old 10-29-2010, 01:53 AM   #19
SeZen
LQ Newbie
 
Registered: Oct 2010
Posts: 10

Original Poster
Rep: Reputation: 0
the result :


root@localhost frdeni]# lsmod | grep snd
snd_hda_intel 26760 3
snd_hda_codec 77988 1 snd_hda_intel
snd_hwdep 7560 1 snd_hda_codec
snd_seq_dummy 2696 0
snd_seq_oss 31712 0
snd_seq_midi_event 7236 1 snd_seq_oss
snd_seq 54672 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 7248 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 44672 0
snd_pcm 82664 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 22124 2 snd_seq,snd_pcm
snd_mixer_oss 16612 1 snd_pcm_oss
snd 62564 16 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_tim er,snd_mixer_oss
soundcore 8128 1 snd
snd_page_alloc 9164 2 snd_hda_intel,snd_pcm
[root@localhost frdeni]#
 
Old 10-29-2010, 01:55 AM   #20
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The drivers are loaded, it should work. Have you tried playing with the volume controls?
 
Old 10-29-2010, 02:32 AM   #21
runlevel0
Member
 
Registered: Mar 2005
Location: Hilversum/Holland
Distribution: Debian GNU/Linux 5.0 (“Lenny”)
Posts: 290

Rep: Reputation: 31
Quote:
Originally Posted by SeZen View Post
it's that one : NVIDIA-Linux-x86-256.53.run and i was thinking it was both a video and soundcard. Because there is nohing said, nowhere about a soundcard on macbook pro 13". So i'm still with my "no sound problem" and i really don't know where to begin to fix it.
Open a terminal, it works pretty much as in Mac OS X, thus no explanation is needed. Go to the directory where you put the file in and just do:

./NVIDIA-Linux-x86-256.53.run (note the dot-slash)

That's all
 
Old 10-30-2010, 02:31 AM   #22
SeZen
LQ Newbie
 
Registered: Oct 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks Nylex but il still have no sound.
 
Old 10-30-2010, 02:47 AM   #23
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,020

Rep: Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455
have you checked the sound level ?
sometimes PCM can get set to 0
or the mute can get turned on

r-click the volume control
or trom the terminal
Code:
 alsamixer
 
Old 10-30-2010, 03:03 AM   #24
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by runlevel0 View Post
Open a terminal, it works pretty much as in Mac OS X, thus no explanation is needed. Go to the directory where you put the file in and just do:

./NVIDIA-Linux-x86-256.53.run (note the dot-slash)

That's all
Please read past the first post in the thread in future. The OP misunderstood that these were just video drivers and they have a problem with sound.
 
Old 11-03-2010, 05:00 PM   #25
SeZen
LQ Newbie
 
Registered: Oct 2010
Posts: 10

Original Poster
Rep: Reputation: 0
I checked again, volume is at 100% but still no sound.
 
Old 11-04-2010, 01:12 AM   #26
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Are you sure that the volume controls aren't muted?
 
Old 11-04-2010, 01:31 AM   #27
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,020

Rep: Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455Reputation: 2455
r-click on the sound icon and select preferences
and see what is there
is the system using pulse-audio ? if so there will be just ONE control displayed from the command " alsamixer"

if alsa there will be a BUNCH of controls displayed


every so often with pulse there can be a missing program "pavucontrol "
 
Old 11-06-2010, 06:46 AM   #28
SeZen
LQ Newbie
 
Registered: Oct 2010
Posts: 10

Original Poster
Rep: Reputation: 0
NYLEX : I already check that the volume wasn't mute a long time ago, and i checked again : It isn't mute.

JOHN VV : There is only one control display on the command alsa mixer. So what can i do ?
 
Old 11-06-2010, 10:13 AM   #29
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by SeZen View Post
JOHN VV : There is only one control display on the command alsa mixer. So what can i do ?
Have you checked in your kde/gnome system settings mulitmedia audio output settings? You may have more than one device and your system is pointed to the wrong one. Only having one control on the aslamixer (you are using alsa, yes?) is not a good sign.
ciao,
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to run executable files? Kelley Linux - Newbie 33 03-20-2015 07:54 AM
[SOLVED] can not run executable files in slackware 13 seflyer Slackware 8 04-26-2010 05:01 PM
Cant't run executable files on Mandrake 9.1 alex101 Mandriva 4 10-14-2003 10:36 AM
run executable files ZeRo69er Linux - Software 4 08-07-2003 02:26 AM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration