LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2009, 09:30 AM   #1
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Rep: Reputation: 15
how to reset grub timer for selecting which OS to initiate?


should be a simple process, but I have been unable to edit the boot/grub/menu.lst file because I have no idea how to log in as su in the editor program. I've tried to sudo, but my password is rejected (it is correct however). I realize I'm doing something backwards, or forgetting a step....... but then.... I'm a newbie.

system: dual boot, XP & Debian on a PC computer
Debian is default OS, but I'm allowed only 5 seconds to select; would like to change to at least 30 sec.
 
Old 04-14-2009, 09:43 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Use sudo or gksudo on a program, thus:

gksudo gedit /boot/grub/menu.lst
 
Old 04-14-2009, 09:48 AM   #3
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
very strange. I can log in as root when using only "su", but doing as you suggested, and as I mentioned earlier ( I think ) using "sudo" does not recognize my password as legitimate.
 
Old 04-14-2009, 10:57 AM   #4
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
FIXED

thanks for trying to help. I was able to figure out a solution. I went to Debian applications; utilities; root terminal; logged in as root; and was able to initiate gedit from there.
I still don't know why I wasn't able to use my root password in "sudo".... because it's my valid root password.... but that's another issue I don't have to worry about right now.
 
Old 04-14-2009, 11:41 AM   #5
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by Perquisitor View Post
very strange. I can log in as root when using only "su", but doing as you suggested, and as I mentioned earlier ( I think ) using "sudo" does not recognize my password as legitimate.
Curious - that suggests that you are not a sudoer. You should look into that.

Did the root terminal work with the root password or your user password?
Anyway - glad to see you worked it out.
 
Old 04-14-2009, 01:11 PM   #6
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
Quote:
I still don't know why I wasn't able to use my root password in "sudo".... because it's my valid root password.... but that's another issue I don't have to worry about right now.
You are asked to enter your own user password for sudo not your root password.

If am wrong correct me!

Cheers!
 
Old 04-15-2009, 08:36 AM   #7
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
@baig: you are correct - well spotted. With sudo, you do indeed enter your user password, not the root one.

Presumably the root terminal used also asked for a password - and the user password was entered. Usually the root terminal just calls something like

gksudo bash

... only it goes through the gui.
 
Old 04-15-2009, 10:41 AM   #8
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
what I did was access Root Terminal and use my root password. I hadn't thought that using my "user" password for sudo was correct. I think I'll try that.

now that's very strange. I tried calling up gedit from terminal console by typing: sudo gedit. I was prompted to enter a password; I used my user password. I was denied access. says that my user name (not password) is not in the sudoers file, and that this incident will be reported. interesting.
 
Old 04-15-2009, 10:56 AM   #9
saivin
Member
 
Registered: Dec 2008
Location: Bengaluru, India
Distribution: CentOS, openSUSE, Mandriva, Slackware
Posts: 111

Rep: Reputation: 19
Debian does not automatically enable 'sudo' as Ubuntu does. Its not neccessary to use 'sudo'. 'su' is just as fine. But some consider 'sudo' provides better security than 'su' though. To enable 'sudo' in your Debian system,

Code:
su
type your 'root' password and execute
Code:
visudo
go to line
Code:
## Allow root to run any commands anywhere
root    ALL=(ALL)       ALL
below it, add a line same as the above but instead of 'root' give your username. For eg:
Code:
perquisitor  ALL=(ALL)  ALL
Save it with ':qw' (without quotes) and may be have to logout n log back in(?). After this you can use 'sudo' command. But remember you need to enter your 'user' password with 'sudo' and NOT the 'root' password.

Last edited by saivin; 04-15-2009 at 10:59 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
TCP_KEEPIDLE timer is not reset following the exchange of data lokesh_c2004 Linux - Networking 0 12-24-2008 03:13 AM
Fedora Installer Crashes after selecting where to install GRUB simonpcook Fedora 2 05-18-2008 07:09 PM
Selecting GRUB options over rdp phillips321 Linux - General 2 11-15-2006 08:48 PM
i8xx TCO timer: failed to reset... slackb0t Slackware 0 04-28-2005 10:44 PM
Selecting New Kernel In Grub Causes Reboot deucedlt Linux - Newbie 2 10-18-2004 07:19 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration