LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2007, 08:24 AM   #1
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Rep: Reputation: 16
How to record your own voice in KDE


Was trying to record my kid's voice using a cheap microphone in KDE.
Tried all the possible setting of Kmix but the recording is very very soft.

Anyone have ever tried and know how to do this simple thing?
 
Old 12-17-2007, 08:56 AM   #2
LinuxCrayon
Member
 
Registered: Nov 2007
Location: Georgia, USA
Distribution: FreeBSD
Posts: 274

Rep: Reputation: 31
While I don't know of any native application to record sound, there is Audacity. I've used it multiple times...mostly to edit songs down to a 40 second clip for a ring tone, but also to record myself playing sax. It's an excellent tool!
 
Old 12-17-2007, 09:10 AM   #3
lpn1160
Member
 
Registered: May 2004
Location: USA
Distribution: pclinuxos
Posts: 37

Rep: Reputation: 15
have a look at this.

http://linuxreviews.org/man/arecord/
 
Old 12-17-2007, 09:43 AM   #4
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
I assume normal playback is working correctly?

Check you have the mic plugged into the mic socket on your sound card and not the line in. The line in socket can result in very quiet input.

Also, verify that the input is not being taken from a different mic - you might have a built-in mic in your computer and think you are talking into the external one you have plugged in, but find the actual recording is coming from the internal one. The distance from the active mic could account for strangely quiet recordings, especially if you hear a lot of fan/hard disk noise, and/or keyboard noise when you type.

You said you tried all possible mixer settings. I'd like to verify that you tried all these. The mixer checklist is:
  1. Input tab / Mic level slider = near the top;
  2. red indicator under Mic slider is selected (bright red)
  3. The green indicator above the Mic slider is used to send mic input out through the speakers. This is useful sometimes, but beware of feedback. It's probably better to leave this off unless you use headphones to listen to the audio output.
  4. Input tab / Capture red indicator is selected
  5. Switches tab / Mic Boost is selected (yellow indicator)
  6. Switches tab / Mic select is on the right input (just try each one)
If all this is set and it is still not working, please post the output of the amixer command in [code] tags here. amixer is in the alsa-utils package in Ubuntu... not sure about other distros.

[edit]P.S. what distro are you using?[/edit]
 
Old 12-18-2007, 04:28 AM   #5
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by matthewg42 View Post
I assume normal playback is working correctly?

Check you have the mic plugged into the mic socket on your sound card and not the line in. The line in socket can result in very quiet input.

Also, verify that the input is not being taken from a different mic - you might have a built-in mic in your computer and think you are talking into the external one you have plugged in, but find the actual recording is coming from the internal one. The distance from the active mic could account for strangely quiet recordings, especially if you hear a lot of fan/hard disk noise, and/or keyboard noise when you type.
Noted. Went ahead and tried the physical setup in windows and recorded okay. Booted back into Debian (and openSUSE) and the recording is super soft :-(

Quote:
You said you tried all possible mixer settings. I'd like to verify that you tried all these. The mixer checklist is:
  1. Input tab / Mic level slider = near the top;
  2. red indicator under Mic slider is selected (bright red)
  3. The green indicator above the Mic slider is used to send mic input out through the speakers. This is useful sometimes, but beware of feedback. It's probably better to leave this off unless you use headphones to listen to the audio output.
  4. Input tab / Capture red indicator is selected
  5. Switches tab / Mic Boost is selected (yellow indicator)
  6. Switches tab / Mic select is on the right input (just try each one)
If all this is set and it is still not working, please post the output of the amixer command in [code] tags here. amixer is in the alsa-utils package in Ubuntu... not sure about other distros.
All the tabs are moved to the maximum but still the same thing.

amixer output as follow
Quote:
Simple mixer control 'Headphone',0
Capabilities: pswitch
Playback channels: Front Left - Front Right
Mono:
Front Left: Playback [on]
Front Right: Playback [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%]
Front Right: Playback 255 [100%]
Simple mixer control 'Front',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Front Line',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Front Mic',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Center',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 30 [97%] [on]
Simple mixer control 'LFE',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 31 [100%] [on]
Simple mixer control 'Side',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Line',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'Mic',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [on]
Front Right: Playback 31 [100%] [on]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined cswitch cswitch-joined
Playback channels: Mono
Capture channels: Mono
Mono: Playback [off] Capture [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 0 [0%] [on]
Front Right: Capture 0 [0%] [on]
Simple mixer control 'Capture',1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 0 [0%] [on]
Front Right: Capture 0 [0%] [on]
Simple mixer control 'Input Source',0
Capabilities: enum
Items: 'Mic' 'Front Mic' 'Line' 'Front Line'
Item0: 'Mic'
Simple mixer control 'Input Source',1
Capabilities: enum
Items: 'Mic' 'Front Mic' 'Line' 'Front Line'
Item0: 'Mic'
Any idea what's wrong with the settings?
 
Old 12-18-2007, 07:31 AM   #6
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 383

Rep: Reputation: 31
Quote:
Originally Posted by matthewg42 View Post
  1. Input tab / Mic level slider = near the top;
  2. red indicator under Mic slider is selected (bright red)
  3. The green indicator above the Mic slider is used to send mic input out through the speakers. This is useful sometimes, but beware of feedback. It's probably better to leave this off unless you use headphones to listen to the audio output.
  4. Input tab / Capture red indicator is selected
  5. Switches tab / Mic Boost is selected (yellow indicator)
  6. Switches tab / Mic select is on the right input (just try each one)
Quote:
Originally Posted by lazylogic View Post
All the tabs are moved to the maximum but still the same thing.
Mic Boost is not to be moved to maximum it is an on/off switch and it was the problem with me
you will find it in the switches tab in kmix (if you are using KDE)
 
Old 12-18-2007, 08:11 AM   #7
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Not all audio devices will have a mic boost btw, so if you can't find it, it might not be relevant for the device you have.
 
Old 12-18-2007, 08:14 AM   #8
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by AGazzaz View Post
Mic Boost is not to be moved to maximum it is an on/off switch and it was the problem with me
you will find it in the switches tab in kmix (if you are using KDE)
Oops, forgot to mention that Kmix doesn't show any Mic Boost option

Last edited by lazylogic; 12-18-2007 at 08:17 AM.
 
Old 12-18-2007, 08:14 AM   #9
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
I do notice in the amixer output two mix levels - "Front Mic" and "Mic". Are there two Mic sockets, or a built-in mic (if you are using a laptops this might be the case).

It could be that Windows is automatically selecting the external mic when present, but ALSA is still using the internal mic. Find it and test it by rubbing you fingers over it as you record to see if you get loud sound from that mic.
 
Old 12-18-2007, 08:20 AM   #10
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by matthewg42 View Post
I do notice in the amixer output two mix levels - "Front Mic" and "Mic". Are there two Mic sockets, or a built-in mic (if you are using a laptops this might be the case).

It could be that Windows is automatically selecting the external mic when present, but ALSA is still using the internal mic. Find it and test it by rubbing you fingers over it as you record to see if you get loud sound from that mic.
Using a desktop with 2 microphone input, one at the front and another at the back of the CPU. Both tested and not much luck
 
Old 12-18-2007, 08:26 AM   #11
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
I'm stumped.
 
Old 12-18-2007, 08:31 AM   #12
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by matthewg42 View Post
I'm stumped.
That's okay , thanks for trying anyway :-)
 
Old 12-18-2007, 08:32 AM   #13
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Oh hang on - the volume for capture says 0% in your amixer output...?
 
Old 12-18-2007, 04:29 PM   #14
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by matthewg42 View Post
Oh hang on - the volume for capture says 0% in your amixer output...?
But all sliders are at maximum. Any idea what can be done ?
 
Old 12-18-2007, 07:07 PM   #15
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Try using alsamixer in a terminal. This is a text-mode mixer, so it's not as nice to use but it might show some extra controls which don't show in kmix. This is pure speculation on my part - I have never seen kmix omit anything, but it's worth having a look at.

Left/right cursor keys to choose which control to select, up/down to change the levels. All the controls probably don't fit on one screen, and you can continue to press the right cursor to scroll to more controls.

The space key selects channels from alternatives, e.g. using mic instead of line in (a red L R CAPTUR indicator shows at the bottom of a control when this is done). You can toggle mute with the m key. This appears as MM at the bottom of a volume control when muted, OO otherwise. The escape key exits.

Importantly, you select groups of controls with the tab key. The selected group can be seen next to "View:" at the top left. Check all groups.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound recording: can record my voice once wordx Linux - Laptop and Netbook 2 08-16-2007 02:04 AM
Cannot record voice/audio krishnakumar85 Linux - Newbie 2 02-27-2007 04:29 AM
i can not record my voice. bruse Linux - Software 2 09-02-2006 10:17 PM
Voice Record in Binary format knockout_artist Linux - Software 5 12-28-2005 02:27 PM
can't record voice through mic irvken Linux - Software 2 04-28-2005 01:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration