LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2005, 06:30 PM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
How to re-insmod allready loaded modules?


Hi, this is my problem:
My TV card (a Haupauge HVR-1100) does not work.
dmesg returns:
Code:
cx2388x dvb driver version 0.0.4 loaded
cx88[0]: Your board isn't known (yet) to the driver.  You can
cx88[0]: try to pick one of the existing card configs via
cx88[0]: card=<n> insmod option.  Updating to the latest
cx88[0]: version might help as well.
cx88[0]: Here is a list of valid choices for the card=<n> insmod option:
cx88[0]:    card=0 -> UNKNOWN/GENERIC
cx88[0]:    card=1 -> Hauppauge WinTV 34xxx models
cx88[0]:    card=2 -> GDI Black Gold
cx88[0]:    card=3 -> PixelView
cx88[0]:    card=4 -> ATI TV Wonder Pro
cx88[0]:    card=5 -> Leadtek Winfast 2000XP Expert
cx88[0]:    card=6 -> AverTV Studio 303 (M126)
cx88[0]:    card=7 -> MSI TV-@nywhere Master
cx88[0]:    card=8 -> Leadtek Winfast DV2000
cx88[0]:    card=9 -> Leadtek PVR 2000
cx88[0]:    card=10 -> IODATA GV-VCP3/PCI
cx88[0]:    card=11 -> Prolink PlayTV PVR
cx88[0]:    card=12 -> ASUS PVR-416
cx88[0]:    card=13 -> MSI TV-@nywhere
cx88[0]:    card=14 -> KWorld/VStream XPert DVB-T
cx88[0]:    card=15 -> DVICO FusionHDTV DVB-T1
cx88[0]:    card=16 -> KWorld LTV883RF
cx88[0]:    card=17 -> DViCO - FusionHDTV 3 Gold
cx88[0]:    card=18 -> Hauppauge Nova-T DVB-T
cx88[0]:    card=19 -> Conexant DVB-T reference design
cx88[0]:    card=20 -> Provideo PV259
cx88[0]:    card=21 -> DVICO FusionHDTV DVB-T Plus
cx88[0]:    card=22 -> pcHDTV HD3000 HDTV
cx88[0]:    card=23 -> digitalnow DNTV Live! DVB-T
cx88[0]:    card=24 -> Hauppauge WinTV 28xxx (Roslyn) models
cx88[0]:    card=25 -> Digital-Logic MICROSPACE Entertainment Center (MEC)
cx88[0]:    card=26 -> IODATA GV/BCTV7E
cx88[0]: subsystem: 0070:9402, board: UNKNOWN/GENERIC [card=0,autodetected]
cx2388x v4l2 driver version 0.0.4 loaded
I want to gice it a try with 'card=1' so i need to insmode it, like the first few lines tell me, but how can i do this?

when i try to remoce the module with modprobe -r, it tells me that it is being used.
and just re-insmoding the module files does not work.

Please help, polemon
 
Old 09-18-2005, 07:01 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
You could try, dangerous as it is, rmmod -f.
 
Old 09-18-2005, 08:32 PM   #3
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
ok, i make my card work, but there's still an issue, i can't get no TV stations...
sad as hell

Anyways, i couldn't unload them, because there were still some active dependencys.
i had to unload:

cx8800
cx88_dvb
cx88xx

(in that order)

loading and unloading, i did with modprobe, didn't use insmod anywhere

Last edited by polemon; 09-18-2005 at 08:55 PM.
 
Old 02-25-2006, 01:22 PM   #4
piffy
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Suse, Knoppix
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by polemon
ok, i make my card work, but there's still an issue, i can't get no TV stations...
sad as hell

loading and unloading, i did with modprobe, didn't use insmod anywhere
I have your very same problem. Did you make any progress? The card works fine under winxp but I'd like to use it under LInux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI drivers not loaded at boot, and cannot insmod. Suggestions? Kramer Linux - Software 2 11-02-2005 07:06 AM
Change Loaded Modules thadco Linux - Hardware 1 09-06-2005 08:58 PM
What modules loaded in a apache2 gianh Linux - Software 0 05-27-2004 08:31 AM
Find out which modules are loaded? redneon Linux - General 8 05-25-2004 01:03 PM
A question about modules and insmod... Defboy2k Linux - Newbie 3 11-05-2002 05:48 AM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration