LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-26-2012, 05:30 AM   #16
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled

have u noticed line 9 in /etc/fstab file / was in .....
i just assumemed tha is the partition / is.
df -h gives
Code:
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1       7.5G  2.5G  4.7G  36% /
udev            241M  4.0K  241M   1% /dev
tmpfs           100M  756K   99M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            248M  128K  248M   1% /run/shm
and fdisk -l gives
Code:
Disk /dev/sda: 8589 MB, 8589934592 bytes
255 heads, 63 sectors/track, 1044 cylinders, total 16777216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009cf50

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    15728639     7863296   83  Linux
/dev/sda2        15730686    16775167      522241    5  Extended
/dev/sda5        15730688    16775167      522240   82  Linux swap / Solaris
 
Old 12-26-2012, 05:32 AM   #17
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, then it is all clear, substitute in your lilo.conf the line
Code:
root = "UUID=7c37411f-3ff6-4de2-b35b-5f3605ad7ad5"
with
Code:
root = /dev/sda1
and then run lilo, but without the -v option.

Markus
 
Old 12-26-2012, 05:52 AM   #18
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
still says this
Code:
Fatal: raid_setup: stat("ata-VBOX_HARDDISK_VBf8f45f35-9b533ad8")
 
Old 12-26-2012, 05:59 AM   #19
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, also you should substitute
Code:
boot =  ata-VBOX_HARDDISK_VBf8f45f35-9b533ad8
with
Code:
boot = /dev/sda
this will write the bootloader to the MBR

Markus
 
Old 12-26-2012, 06:11 AM   #20
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
ya i did but the oly thing it did is that it changed thje error message like
Code:
Fatal: raid_setup: stat(sda)
 
Old 12-26-2012, 06:13 AM   #21
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
mh, I had often Slackware installed on Virtualbox with lilo as bootloader but never had such problems.
Could you please post your complete lilo.conf file?

Markus
 
Old 12-26-2012, 06:22 AM   #22
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Dear Markus it worked i forgot /dev in /dev/sda
u have been very helpful.I am very grateful.But it doesn't have the the graphical interface.Is it normal.It wrote /usr/......read -only???
 
Old 12-26-2012, 06:25 AM   #23
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by micflunu View Post
Dear Markus it worked i forgot /dev in /dev/sda
u have been very helpful.I am very grateful.But it doesn't have the the graphical interface.Is it normal.It wrote /usr/......read -only???
Which graphical interface do you mean?

And what wrote /usr/.... read-only? could you please post the complete message?

Markus
 
Old 12-26-2012, 07:07 AM   #24
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Its just it doesn't have a user interface.It loads like a dos kind.It just does this long cmd line check.then it says
Code:
The disk drive for / is not ready yet or isn't present.Continue to wait,or press S to skip mounting or M for manual recovery.
when i press any of it dispalys the following among soooo many other things
Code:
cannot create /var/lib/update/fsck-at-reboot: Read-only file system
 
Old 12-26-2012, 07:33 AM   #25
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
Hi markus is there any way i cld solve this thing pls??
 
Old 12-26-2012, 07:37 AM   #26
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
You could try to delete the line "read-only" from lilo.conf and rerun lilo.

As for the graphical interface, have you already installed X11? if yes, you should at first create a user (don't run X as root) and then login as the user and execute
Code:
startx
you will end up in twm which is the most simple windowmanager (if you haven't already installed another WM).

Markus
 
Old 12-26-2012, 07:45 AM   #27
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,523

Rep: Reputation: 235Reputation: 235Reputation: 235
That is likely the result of an incorrect /etc/fstab file. The entry for / does not match in all likelihood. I would encourage you to use UUID's, even though it's not intuitive.

# cat /proc/partitions
# blkid /dev/sda1

To get started with UUIDs anyway. UUIDs are partition specific. Although I suspect that your current dilema is that your /etc/fstab file still uses the UUID while the rest of your setup does not. And that UUID may be incorrect. It's really easy to fat finger a string that long. And other frustrations with a fresh install.

Last edited by Shadow_7; 12-26-2012 at 07:46 AM.
 
1 members found this post helpful.
Old 12-26-2012, 07:52 AM   #28
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Well, that's a good idea, you could use try the following fstab
Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    defaults            1       1
/dev/sda5       swap            swap    defaults            0       0
Markus
 
Old 12-26-2012, 07:56 AM   #29
micflunu
Member
 
Registered: Oct 2012
Posts: 62

Original Poster
Rep: Reputation: Disabled
ya i wld but it is not able to open it in gedit.i cnn't edit it.What sld i do??
 
Old 12-26-2012, 08:02 AM   #30
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
How did you edit the /etc/lilo.conf before it worked? with the install-CD? probably you should boot with the install-CD.

And please write correct english. I'm no native English speaker and don't want to guess what you want to say.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista + Slackware dual boot (same hdd): Is it safe to install LILO to MBR? and_ru General 15 09-27-2009 12:54 AM
Mbr lilo (error load operating system) hellasyoda Slackware 14 04-20-2008 04:05 PM
Install Lilo in MBR during instalation of SuSE 9.3 (with dual boot Windows XP) cangussu.br Linux - Newbie 2 05-05-2005 10:46 PM
How i make LILO in MBR with Bootable CD ? saffron Linux - General 4 10-17-2003 10:28 AM
Do not want lilo in my MBR, want to use System Commander to boot rdaves@earthlink.net Linux - General 4 09-21-2001 11:55 PM


All times are GMT -5. The time now is 05:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration