LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-17-2009, 03:52 AM   #1
kushanxp
LQ Newbie
 
Registered: Sep 2006
Posts: 13

Rep: Reputation: 0
Unhappy How to mount NTFS in read/write mode in SuSE Enterprise 11


Hi Guys,

i can mount the NTFS in read only mode, but i need write access too.
how can i mount NTFS partition in read/write mode..?

can anyone help me..?
 
Old 12-17-2009, 03:58 AM   #2
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Quote:
Originally Posted by kushanxp View Post
Hi Guys,

i can mount the NTFS in read only mode, but i need write access too.
how can i mount NTFS partition in read/write mode..?

can anyone help me..?
Dear Kushanxp,

Try,

Code:
# mount -o rw,remount /dev/sdax
replace sdax with the windowz partition.
 
Old 12-17-2009, 04:04 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
If you want to mount NTFS partitions you will need ntfs-3g package. And it should most probably be installed by default.

Just use it to mount the partitions.

mount -t ntfs-3g /dev/sdax /mnt/windows

Where sdax is the windows partition and /mnt/windows is the directory where partition is to be mounted. Both should exist before you can mount.
 
Old 12-17-2009, 04:13 AM   #4
sumeet inani
Member
 
Registered: Oct 2008
Posts: 881
Blog Entries: 26

Rep: Reputation: 47
Hope you have properly shut down windows OS (i.e no power failure or forced reboot or hibernation ) because in those cases the ntfs partition is locked & does not mount so if problem had occured then reboot into windows & shutdown properly.

Now Let us see if you have ntfs-3g.
Assume your device is /dev/sda4 then run as root that is
$su
enter password:
#umount /dev/sda4
#mkdir /windows
#ntfs-3g /dev/sda4 /windows
But in this case only root can create folder in /windows though ordinary user can create & delete files.See if you can make file in /windows.

Now let us make ntfs partition mounted by default & editable by all users
First comment out old statement pointing to ntfs device in /etc/fstab by prefixing line with #.
Add following line to your /etc/fstab & reboot
<device> <mountpoint> ntfs-3g defaults 0 0
Where device is
Code:
sda4 for hd(0,3)
As a general rule 
/dev/sda<m+1th alphabet><n+1> for partition hd(m,n).
Hope now you understand.
mount point is folder where it will be mounted.I think usually it is /windows/drive_letter.
Copy corresponding folder from just commented line in /etc/fstab.
Make sure such folder exist.If not then
$su
enter password:
#mkdir desired_folder
you can get also device from commented line if you aren't able to decide.
I think ntfs-3g is available on most GNU/linux OS by default.

Hope this helps.if you find my post useful than thank me by pressing thumbs up button.

Last edited by sumeet inani; 12-17-2009 at 04:51 AM.
 
Old 12-17-2009, 04:16 AM   #5
kushanxp
LQ Newbie
 
Registered: Sep 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by linuxlover.chaitanya View Post
If you want to mount NTFS partitions you will need ntfs-3g package. And it should most probably be installed by default.

Just use it to mount the partitions.

mount -t ntfs-3g /dev/sdax /mnt/windows

Where sdax is the windows partition and /mnt/windows is the directory where partition is to be mounted. Both should exist before you can mount.

i have downloaded and installed ntfs-3g and a package called fuse-2.8.0
but still when i gave the command you said me its saying

mount: unknown filesystem type 'ntfs-3g'


Please help me on this..
 
Old 12-17-2009, 04:18 AM   #6
kushanxp
LQ Newbie
 
Registered: Sep 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by vinaytp View Post
Dear Kushanxp,

Try,

Code:
# mount -o rw,remount /dev/sdax
replace sdax with the windowz partition.
Hi..

i tried this and its saying

mount: /media/NTFS not mounted already, or bad option
 
Old 12-17-2009, 04:36 AM   #7
sumeet inani
Member
 
Registered: Oct 2008
Posts: 881
Blog Entries: 26

Rep: Reputation: 47
I have given a looong but step by step way.Why don't you try it ? Just trying to help.
 
Old 12-17-2009, 05:01 AM   #8
kushanxp
LQ Newbie
 
Registered: Sep 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by sumeet inani View Post
I have given a looong but step by step way.Why don't you try it ? Just trying to help.
Hi..

Im on SuSE Enterprise Server 11 and theres no ntfs-3g, but i downloaded and installed, but still i cant mount the using ntfs-3g, its saying

mount: unknown filesystem type 'ntfs-3g'

Seems ntfs-3g not there..

how can i solve this problem
 
Old 12-17-2009, 05:41 AM   #9
sumeet inani
Member
 
Registered: Oct 2008
Posts: 881
Blog Entries: 26

Rep: Reputation: 47
Give content of /etc/fstab.Enclose the file content in codes.
Also you can try
$which ntfs-3g
to see if application is present.

Last edited by sumeet inani; 12-17-2009 at 05:42 AM.
 
Old 12-17-2009, 05:43 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
How did you install ntfs-3g? Did you use Yast for it? It is always better to use the package manager to install packages.
I have used it and it works.
 
Old 12-17-2009, 06:34 AM   #11
kushanxp
LQ Newbie
 
Registered: Sep 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Smile

Quote:
Originally Posted by sumeet inani View Post
Give content of /etc/fstab.Enclose the file content in codes.
Also you can try
$which ntfs-3g
to see if application is present.
Hi,

problem solved, there was a compile error in
secaudit.c file of ntfs-3g directory i corrected that and installed it again, now its working, but seems i can copy through command line to NTFS drive. anyway its OK now, Thanks for your support.

here are the steps i have followed, this will be usefull to anyone,

you will get following listed errors when you trying to make the files

secaudit.c:262:24: error: attr/xattr.h: No such file or directory
secaudit.c: In function ‘showmounted’:
secaudit.c:5033: warning: implicit declaration of function ‘getxattr’
make[2]: *** [ntfs_3g_secaudit-secaudit.o] Error 1
make[2]: Leaving directory `/media/MEDIA/Linux/ntfs-3g-2009.11.14/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/media/MEDIA/Linux/ntfs-3g-2009.11.14'
make: *** [all] Error 2

you have to replace the line 262 with

#include <sys/xattr.h>

and you should have installed libattr library

Thats all
 
Old 12-17-2009, 07:16 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
I have a simpler solution:

On CentOS, RH, Fedora

yum install ntfs-3g

On apt systems:

sudo apt-get install ntfs-3g

On suse;

yast
 
Old 12-17-2009, 10:56 PM   #13
sumeet inani
Member
 
Registered: Oct 2008
Posts: 881
Blog Entries: 26

Rep: Reputation: 47
to kushanxp,
You said that
Code:
now its working, but seems i can copy
through command line to NTFS drive. 
anyway its OK now.
In my explanatory post I have provided tip to to do all kinds of operations(delete,copy,paste,move) on ntfs partition even in graphical interface.
Why do you think that with ntfs-3g you can copy only with command prompt ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting ntfs partiton in read write mode gopal_patil06 Linux - Hardware 1 01-02-2008 01:34 AM
How to mount a read write NTFS partition CircuitSix Linux - Hardware 3 12-07-2005 03:21 AM
NTFS and Read-write mode (captive and other solutions) in mandrake 9.1 (bamboo) mimithebrain Linux - Newbie 5 05-19-2004 12:23 PM
Can't mount NTFS in read-write mode Tyco Linux - Hardware 4 06-08-2003 12:52 PM
Mounting NTFS in read / write mode escrotto General 5 12-04-2001 05:26 AM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration