LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2005, 05:55 AM   #1
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Rep: Reputation: 15
How to mount my vfat file system?


Friends,

Here is the list which i recieved by typing "fdisk -l"

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/hda2 2551 4864 18587205 f Win95 Ext'd (LBA)
/dev/hda5 2551 4864 18587173+ c Win95 FAT32 (LBA)

Disk /dev/hdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1288 10241437+ 83 Linux
/dev/hdb3 1289 1810 4192965 83 Linux
/dev/hdb4 1811 4865 24539287+ f Win95 Ext'd (LBA)
/dev/hdb5 1811 1941 1052226 82 Linux swap

From the above list i found that iam having the vfat system in "/dev/hdb4"
i tried this command #mount /dev/hdb4 /winfat
its throwing the below error
mount: error while guessing filesystem type
mount: you must specify the filesystem type

So, Am i having the vfat file system or not?
if im not having vfat file system how can i create a fat or vfat file system now.

Thanks & Regards
Sathyguy
 
Old 10-17-2005, 06:13 AM   #2
cyberjun
Member
 
Registered: Mar 2005
Distribution: Gentoo kernel 2.6.14
Posts: 96

Rep: Reputation: 15
Hi,
The correct command is

mount -t vfat /dev/hdb4 /winfat

assuming you have already created a directory called /winfat under your root directory. The recommended way is:

1. mkdir /mnt/winfat
2. chmod 777 /mnt/winfat
3. mount -t vfat /dev/hdb4 /mnt/winfat


Now if you get error messages like "vfat not supported", then you forgot to compile vfat support in your kernel. If you want you can
recompile your kernel with the appropriate option and then it should work.

--cyberjun
 
Old 10-17-2005, 06:39 AM   #3
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Original Poster
Rep: Reputation: 15
Thanks for your reply....
Below is the error

# mkdir /mnt/winfat
# chmod 777 /mnt/winfat/
# mount -t vfat /dev/hdb4 /mnt/winfat/
mount: wrong fs type, bad option, bad superblock on /dev/hdb4,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)

now what might be the problem and how can i overcome?

--Sathyguy
 
Old 10-17-2005, 06:48 AM   #4
jordan023
LQ Newbie
 
Registered: Oct 2005
Location: Vancouver, British Columbia
Distribution: RedHat 9, Windows 2000, freeBSD
Posts: 23

Rep: Reputation: 15
make sure its vfat do a
mount -l that will tell you the file system(s)
then do that command
 
Old 10-17-2005, 06:50 AM   #5
cyberjun
Member
 
Registered: Mar 2005
Distribution: Gentoo kernel 2.6.14
Posts: 96

Rep: Reputation: 15
Hi,
This might be the problem with kernel support for vfat. To confirm try to mount a partition from the first disk i.e hda. For example you can try

mount -t vfat /dev/hda2 /mnt/winfat

If this one also fails then the problem is with the kernel support and you need a recompilation of kernel with vfat support enabled. If this one works, then I will have to give it more thought or someone else can provide insight.

--cyberjun
 
Old 10-17-2005, 06:55 AM   #6
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Quote:
Originally posted by sathyguy
Thanks for your reply....
Below is the error

# mkdir /mnt/winfat
# chmod 777 /mnt/winfat/
# mount -t vfat /dev/hdb4 /mnt/winfat/
mount: wrong fs type, bad option, bad superblock on /dev/hdb4,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)

now what might be the problem and how can i overcome?

--Sathyguy
Hello,
its clearly indicating that u r trying to mount the extended partition. I also confirmed it from your "fdisk -l" entries.
you can mount the logical partitions and not the extended one

regards

Edit: ( correct me if i'm wrong )
 
Old 10-17-2005, 07:05 AM   #7
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Original Poster
Rep: Reputation: 15
ok guys...see
i went to the gui...i selected the hardware browser
in that i have seen two harddisk one is hda (windows) and the other one is hdb(linux)
under hdb
i have hdb1 to hdb5 after that i have 22937mb free space in hdb like below....

/dev/hdb
/dev/hdb1 1 13 102 ext3
/dev/hdb2 14 1288 10001 ext3
/dev/hdb3 1289 1810 4095 ext3
/dev/hdb4 1811 4865 23964 extended
/dev/hdb5 1811 1941 1028 linux-swap
1942 4865 22937 freespace

so can i use some 10000mb for vfat.
now how can i only 10000mb for vfat in that 22937mb?
i will use only 10000mb for vfat other 12937mb will be a free space. i will use it in future.


Thanks
Sathyguy
 
Old 10-17-2005, 07:25 AM   #8
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
your entries running fdisk -l
Quote:
Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1288 10241437+ 83 Linux
/dev/hdb3 1289 1810 4192965 83 Linux
/dev/hdb4 1811 4865 24539287+ f Win95 Ext'd (LBA)
/dev/hdb5 1811 1941 1052226 82 Linux swap
now hdb4 is the extended partition of 24.5 GB's
in that extended you have 1.05 GB of swap.
Rest all is free........
Just make more logical partitions. What's the problem ???
do
fdisk /dev/hdb
m ( for help ) and create more logical partitions according to your need

regards
 
Old 10-18-2005, 05:28 AM   #9
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Original Poster
Rep: Reputation: 15
ok i did.....but its showing "No FileSystem"

what i did is....

$fdisk /dev/hdb
$n
$default (1942)
$default (4865)
$w

thats all...after that i rebooted.
after rebooting i checked in the GUI --> Hardware Browser
there its showing

hdb6 1942 4865 22937 No Filesystem

so how can i make this file system as fat32?

Thanks
Sathyguy
 
Old 10-18-2005, 07:54 AM   #10
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Hello,
#fdisk /dev/hda
Command (m for help): Hence type 'm'

Command (m for help): m
Command action
a toggle a bootable flag
b edit bsd disklabel
c toggle the dos compatibility flag
d delete a partition
l list known partition types
m print this menu
n add a new partition
o create a new empty DOS partition table
p print the partition table
q quit without saving changes
s create a new empty Sun disklabel
t change a partition's system id
u change display/entry units
v verify the partition table
w write table to disk and exit
x extra functionality (experts only)

so you can use 'n' option to create new partitions
using 'l' you can see different partitions types
using 't' you can change partitions system id......i.e to different file systems
then at the last type 'w' to write table to disk and exit.

trying doing this.

regards
 
Old 10-18-2005, 07:57 AM   #11
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
$fdisk /dev/hdb
$n
$default (1942)
$default (4865)
$w

these defaults are the default size its taking......... you can/should specify your own

regards
 
Old 10-31-2005, 01:56 AM   #12
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Original Poster
Rep: Reputation: 15
Now i have created a logical partition
/dev/hdb6 1942 4865 22937 c Win95 FAT32 (LBA)

But I am not able to see this partition in my windows 2000 OS.
Is it possible to see the above partition in my windows OS?
 
Old 10-31-2005, 03:02 AM   #13
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
It's possible that windows hasn't automatically allocated a drive letter to your fat32 partition. to do so:[list=1][*]right click "my computer".[*]select "manage".[*]from the list on the left, select "Disk Management" (under "Storage").[*]in the top-right pane, right-click your fat32 partition.[*]select "Change drive letter and path".[*]click "add".[*]select a drive letter and click "ok".[*]close all the windows that are still open.[/list=1]
 
Old 11-01-2005, 05:08 AM   #14
sathyguy
Member
 
Registered: Sep 2005
Location: Indian Working in Saudi Arabia
Distribution: Redhat Linux AS 3.0
Posts: 93

Original Poster
Rep: Reputation: 15
I tried but no use.
I am able to see only the 20GB, 1GB and 100MB.
The 20GB has already taken a drive letter as F:
I am having 40GB+40GB HDD. first 40GB im using for windows. second 40GB is for linux.
But i wonder the second 40GB is showing more than 40GB.
for your information please see the below "fdisk -l"
Quote:
Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/hda2 2551 4864 18587205 f Win95 Ext'd (LBA)
/dev/hda5 2551 4864 18587173+ c Win95 FAT32 (LBA)

Disk /dev/hdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1288 10241437+ 83 Linux
/dev/hdb3 1289 1810 4192965 83 Linux
/dev/hdb4 1811 4865 24539287+ f Win95 Ext'd (LBA)
/dev/hdb5 1811 1941 1052226 82 Linux swap
/dev/hdb6 1942 4865 23486998+ c Win95 FAT32 (LBA)
Now I am not able to see the /dev/hdb6 either in linux or in windows. only if i type fdisk -l im able to see this hdb6.
Below is my "df -h"
Quote:
Filesystem Size Used Avail Use% Mounted on
/dev/hdb2 9.7G 8.1G 1.2G 88% /
/dev/hdb1 99M 9.0M 85M 10% /boot
none 247M 0 247M 0% /dev/shm
/dev/hdb3 4.0G 82M 3.7G 3% /var
/dev/hda5 18G 4.5G 14G 26% /mnt/winfat
i want to merge the hdb6 with /dev/hdb2 (as this one is having less space)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
Mounting file system in a file with mount Denes Programming 6 11-11-2005 01:04 PM
how to mount a readonly file system? redsector Linux - Newbie 4 05-16-2005 02:48 AM
Cannot Mount File System slappycakes Linux - Hardware 18 10-13-2003 11:33 AM
How do i mount Vfat file in Linux rdaves@earthlink.net Linux - Newbie 3 05-22-2001 12:06 AM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration