LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2005, 11:54 PM   #1
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Rep: Reputation: 15
how to mount my fat32 partition in rh9??


hello there again... i wanna see my fat32 partitions when im using linux... what will i do with fstab??

according to my hardware browser, these are my partitions:

hda2--------extended
hda5--------fat32
hda1--------ntfs
hdb4--------extended
hdb5--------ext3
hdb1--------fat32
hdb2--------ext3
hdb3--------linux swap

tnx!!
 
Old 01-31-2005, 12:28 AM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
> what will i do with fstab?
reading the manual ('man fstab') might help. So might searching the web. If not, come back and state clearly what you don't understand. Hope this helps,

Jonas
 
Old 01-31-2005, 12:46 AM   #3
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Re: how to mount my fat32 partition in rh9??

Quote:
Originally posted by linus johann
hello there again... i wanna see my fat32 partitions when im using linux... what will i do with fstab??

according to my hardware browser, these are my partitions:

hda2--------extended
hda5--------fat32
hda1--------ntfs
hdb4--------extended
hdb5--------ext3
hdb1--------fat32
hdb2--------ext3
hdb3--------linux swap

tnx!!
It is not enough information we need to help you. You already have /etc/fstab file, post it's copy here.
 
Old 01-31-2005, 01:27 AM   #4
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
i wanna automount my fat32 partition everytime i boot to linux... i tried adding this line to fstab:

/dev/hda2 vfat defaults 1 1.... didnt work

tried: /dev/hda5 vfat defaults 1 1... also didnt work...

what seems to be wrong or missing here???
 
Old 01-31-2005, 01:38 AM   #5
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
See my previous message and also I want to see what shows to you command fdisk -l.
 
Old 01-31-2005, 02:03 AM   #6
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
here is my fstab file: (i added the bottom line there) dont know if thatś correct


LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda5 vfat defaults 1 1
 
Old 01-31-2005, 02:05 AM   #7
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
hereś also the result of fdisk -l ::

Disk /dev/hda: 20.0 GB, 20020396032 bytes
255 heads, 63 sectors/track, 2434 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 731 5871726 7 HPFS/NTFS
/dev/hda2 732 2434 13679347+ f Win95 Ext'd (LBA)
/dev/hda5 732 2434 13679316 b Win95 FAT32

Disk /dev/hdb: 10.2 GB, 10242892800 bytes
240 heads, 63 sectors/track, 1323 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 475 3590968+ b Win95 FAT32
/dev/hdb2 476 489 105840 83 Linux
/dev/hdb3 490 558 521640 82 Linux swap
/dev/hdb4 559 1323 5783400 f Win95 Ext'd (LBA)
/dev/hdb5 559 1323 5783368+ 83 Linux
 
Old 01-31-2005, 02:23 AM   #8
lomnhom
Member
 
Registered: Jan 2005
Location: Ha Noi, Viet Nam
Distribution: Fedora Core
Posts: 61

Rep: Reputation: 15
First you have to create a directory for mounting your FAT32 (ex /mnt/dream)

Second you may try this command
mount -t vfat /dev/hda5 /mnt/dream

And if you like RH automount this for you, add this linre to /etc/fstab file

/dev/hda5 /mnt/dream vfat defaults 0 0

Last edited by lomnhom; 01-31-2005 at 02:56 AM.
 
Old 01-31-2005, 02:52 AM   #9
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Your fstab should be look like that:
Note that 1) all after '#' are comments for you and are not important;
2) 'umask=0' means that all files are not executable on this partition;
3) 'ro' parameter for NTFS means READ ONLY (it is really not good idea to write anything to NTFS
under Linux - support of this file system in Linux is still not good);
4) you need to create /mnt/win_c, /mnt/win_d, /mnt/win_e directories
Code:
#device		mountpoint	filesystemtype	options
#
LABEL=/		/		ext3		defaults		1	1
LABEL=/boot	/boot		ext3		defaults		1	2
none		/dev/pts	devpts		gid=5,mode=620		0	0
none		/proc		proc		defaults		0	0
none		/dev/shm	tmpfs		defaults		0	0
/dev/hdb3	swap		swap		defaults		0	0
/dev/cdrom	/mnt/cdrom	udf,iso9660	noauto,owner,kudzu,ro	0	0
/dev/cdrom1	/mnt/cdrom1	udf,iso9660	noauto,owner,kudzu,ro	0	0
/dev/fd0	/mnt/floppy	auto		noauto,owner,kudzu	0	0
#/dev/hda5	vfat				defaults		1	1
/dev/hda5	/mnt/win_d	vfat		umask=0			0	0
/dev/hda1	/mnt/win_c	ntfs		umask=0,ro		0	0
/dev/hdb1	/mnt/win_e	vfat		umask=0			0	0

Last edited by RomanG; 01-31-2005 at 03:03 AM.
 
Old 01-31-2005, 03:23 AM   #10
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
yaikkss!! now im in trouble!! i couldnt boot to linux... how do i edit my fstab file in repair mode??? i tried it but it says that it's a read-only file... can't overwrite the fstab file using vi...

oh my!! after all the hard work of configuring my squid and samba, and installing the video driver....HUMMPPHH!!! ARRRGhh!!!

pls help !!! (im using windows XP right now as i type this)
 
Old 01-31-2005, 03:30 AM   #11
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Step by step, what did you do?
 
Old 01-31-2005, 04:02 AM   #12
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
i used this (added the last line): then i rebooted my pc.... i think i even added a umask option

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda5 /mnt / vfat defaults 0 0


how do i make the fstab file writable (not read-only)... so that i can restore the original config
 
Old 01-31-2005, 04:06 AM   #13
linus johann
Member
 
Registered: Jan 2005
Location: philippines
Distribution: rh 9
Posts: 71

Original Poster
Rep: Reputation: 15
how do i create the directories??? where??
 
Old 01-31-2005, 04:20 AM   #14
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
Creating directories:
this command changes your current directory to that you want (/mnt)
cd /mnt
this one creates directory
mkdir win_d

There is a very good help for every command in linux, just type man yourcommand.
press space for continue and 'q' to exit.
 
Old 01-31-2005, 05:37 AM   #15
RomanG
Member
 
Registered: Jan 2005
Location: Russia, Kazan
Distribution: Mandrake 10.2, RedHat sometimes..
Posts: 110

Rep: Reputation: 15
To make fstab writable run
chmod o+w /etc/fstab
this will make fstab writable for owner of this file, i.e. for root.
You must be root (superuser) to edit this file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 07:54 PM
Can't mount FAT32 partition EcceVery Debian 5 09-13-2004 05:53 AM
mount of fat32 partition mys71 Red Hat 2 05-09-2004 02:54 PM
Mount fat32 partition? CletusJones Slackware 19 12-28-2003 08:13 PM
How to mount a new fat32 partition IceOnly Linux - Software 2 06-11-2003 01:10 PM


All times are GMT -5. The time now is 01:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration