LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-09-2004, 01:48 AM   #1
Niversphere
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake, RedHat, Debian and Gentoo
Posts: 2

Rep: Reputation: 0
Unhappy How to mount External Hard disk in Mandrake 10.0


As above. Mandrake detects the external harddisk connected as a USB device but i cannot access the contents of it . Guys can u teach me how to mount the external harddisk ?

Thanks in advance.

Norman
 
Old 09-09-2004, 02:23 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
If you don't have a scsi drive then your USB drive is named sda1. So as root do:
Code:
mount /dev/sda1 /mnt/<somedir>
Keep in mind that if the drive has a windows partition you must precede /dev/sda1 with -t vfat or -t ntfs (for fat32 or ntfs partitions) and that the directory <somedir> must exist before mount. If you have other scsi drives then the command dmesg will tell you then device name of your disk.
 
Old 09-09-2004, 03:11 AM   #3
Niversphere
LQ Newbie
 
Registered: Sep 2004
Distribution: Mandrake, RedHat, Debian and Gentoo
Posts: 2

Original Poster
Rep: Reputation: 0
thanks

=0)
 
Old 09-09-2004, 03:57 AM   #4
robinang
LQ Newbie
 
Registered: Sep 2004
Posts: 9

Rep: Reputation: 0
er...thanks niversphere for helping me ask this question here...

but my hdd is partition into 3 partition and it is all in NTFS ....
anyone can help me with the mounting?

Thanks again people....


No pain no gain and open source rocks

 
Old 09-09-2004, 04:07 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,772

Rep: Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294Reputation: 1294
You can try:
Code:
mount -t ntfs /dev/sda1 /mnt/<whatever>
for the 1st partition and change to sda2 and sda3 for the rest 2. Also change the mountpoints
 
Old 09-10-2004, 07:03 AM   #6
robinang
LQ Newbie
 
Registered: Sep 2004
Posts: 9

Rep: Reputation: 0
ok ok it says i can only mount if i am root...
i su to root...but then when i mount it in root...
i can only access the files on the external drive using my root account using the terminal i wanna give access to the drives to my user account hw do i go abt doing that? Any help would be greatly appreciated....

BTW i am using mandrake 10.0


Thanks people
 
Old 09-10-2004, 07:21 AM   #7
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
#chgrp users /mnt/<whatever>
#chmod 770 /mnt/<whatever>
...should do it.

egag
 
Old 09-10-2004, 10:41 AM   #8
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Rep: Reputation: 30
If you want it to mount up as a permanent fixture on your system, and your system is picking it up, in KDE 3.2 you can right click on the desktop and choose new device. Then pick the device from the list, and it will drop an icon on the desktop for that device. Then you can right click on that icon when you need to mount it and choose MOUNT, and it will mount it for you. That's how I run my cd writer when changing cd's in and out.

You can also make sure it always appears as a directory your system can access by adding the device to the file

/etc/fstab

Do a bit of reading about that file before you edit it. Usually you can copy the settings from something else you have mounted that is a similar filesystem to make a new row in the file.

Make sure after you edit fstab that you have an empty line at the end or it will issue a warning during boot.
 
Old 09-15-2004, 10:44 AM   #9
runelolk
LQ Newbie
 
Registered: Feb 2004
Location: Århus, Denmark
Distribution: Mandrake 9.2
Posts: 9

Rep: Reputation: 0
Monted USB HD is read only?

Hi there

Hope you guys can help me with this porblem.

I have a USB HD which is run in NTFS mode, the reason for this is that I want to be able to read it on any Windows XP box.
My problem is that the disc is Read-only

First: When linux discovers the HD it's mounted as a "fat" partition, which for obvious reasons does not work.

What I did was to unmount the drive, and the mount it this way:
mount -t ntfs /dev/sda1 /mnt/windows
Which makes it possible for root to read the files on the drive.

If i do the mount command I get:
/dev/ide/host0/bus0/target0/lun0/part1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /proc/bus/usb type usbdevfs (rw)
none on /dev type devfs (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,mode=0620)
/dev/ide/host0/bus0/target0/lun0/part6 on /home type ext3 (rw)
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
none on /mnt/removable type supermount (rw,dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
none on /mnt/removable2 type supermount (rw,dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
/dev/scsi/host0/bus0/target0/lun0/part1 on /mnt/windows type ntfs (rw)

What I get from the last line is that the USB HD is mounted as r/w
But I get the message that the file system is "Read-only"
[root@dhcppc0 root]# chgrp users /mnt/windows
chgrp: ændrer gruppe for '/mnt/windows': Read-only file system
[root@dhcppc0 root]# chmod 770 /mnt/windows
chmod: ændrer rettigheder på '/mnt/windows': Read-only file system

I can still only access the /mnt/windows as root, I can still only read files, not write files to the HD
How do I correct this problem?
 
Old 12-11-2006, 02:25 PM   #10
asturbcn
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
Sorry but actually, Linux only support NTFS file system in read only mode. :-(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount an external ntfs usb hard disk dmpop Mandriva 5 03-03-2013 10:45 AM
Mount external USB 2.0 hard disk with NTFS? Musikolo Linux - Hardware 8 09-15-2006 09:11 AM
Mount points on usb devices (dig. camera, zip drive, external hard disk) Impaler Linux - Hardware 3 05-29-2006 11:08 PM
mount external usn hard-disk alaios Linux - Hardware 1 04-22-2005 02:14 PM
External Firewire hard disk drive - mount glitches shultzc Linux - Hardware 0 10-09-2004 06:31 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration