LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to mount External Hard disk in Mandrake 10.0 (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-mount-external-hard-disk-in-mandrake-10-0-a-228464/)

Niversphere 09-09-2004 02:48 AM

How to mount External Hard disk in Mandrake 10.0
 
As above. Mandrake detects the external harddisk connected as a USB device but i cannot access the contents of it . Guys can u teach me how to mount the external harddisk ?

Thanks in advance.

Norman

bathory 09-09-2004 03:23 AM

If you don't have a scsi drive then your USB drive is named sda1. So as root do:
Code:

mount /dev/sda1 /mnt/<somedir>
Keep in mind that if the drive has a windows partition you must precede /dev/sda1 with -t vfat or -t ntfs (for fat32 or ntfs partitions) and that the directory <somedir> must exist before mount. If you have other scsi drives then the command dmesg will tell you then device name of your disk.

Niversphere 09-09-2004 04:11 AM

thanks

=0)

robinang 09-09-2004 04:57 AM

er...thanks niversphere for helping me ask this question here...

but my hdd is partition into 3 partition and it is all in NTFS ....
anyone can help me with the mounting?

Thanks again people....


No pain no gain and open source rocks

;)

bathory 09-09-2004 05:07 AM

You can try:
Code:

mount -t ntfs /dev/sda1 /mnt/<whatever>
for the 1st partition and change to sda2 and sda3 for the rest 2. Also change the mountpoints

robinang 09-10-2004 08:03 AM

ok ok it says i can only mount if i am root...
i su to root...but then when i mount it in root...
i can only access the files on the external drive using my root account using the terminal i wanna give access to the drives to my user account hw do i go abt doing that? Any help would be greatly appreciated....

BTW i am using mandrake 10.0
:)

Thanks people

egag 09-10-2004 08:21 AM

#chgrp users /mnt/<whatever>
#chmod 770 /mnt/<whatever>
...should do it.

egag

Linux24 09-10-2004 11:41 AM

If you want it to mount up as a permanent fixture on your system, and your system is picking it up, in KDE 3.2 you can right click on the desktop and choose new device. Then pick the device from the list, and it will drop an icon on the desktop for that device. Then you can right click on that icon when you need to mount it and choose MOUNT, and it will mount it for you. That's how I run my cd writer when changing cd's in and out.

You can also make sure it always appears as a directory your system can access by adding the device to the file

/etc/fstab

Do a bit of reading about that file before you edit it. Usually you can copy the settings from something else you have mounted that is a similar filesystem to make a new row in the file.

Make sure after you edit fstab that you have an empty line at the end or it will issue a warning during boot.

runelolk 09-15-2004 11:44 AM

Monted USB HD is read only?
 
Hi there

Hope you guys can help me with this porblem.

I have a USB HD which is run in NTFS mode, the reason for this is that I want to be able to read it on any Windows XP box.
My problem is that the disc is Read-only

First: When linux discovers the HD it's mounted as a "fat" partition, which for obvious reasons does not work.

What I did was to unmount the drive, and the mount it this way:
mount -t ntfs /dev/sda1 /mnt/windows
Which makes it possible for root to read the files on the drive.

If i do the mount command I get:
/dev/ide/host0/bus0/target0/lun0/part1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /proc/bus/usb type usbdevfs (rw)
none on /dev type devfs (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,mode=0620)
/dev/ide/host0/bus0/target0/lun0/part6 on /home type ext3 (rw)
none on /mnt/floppy type supermount (rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
none on /mnt/removable type supermount (rw,dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
none on /mnt/removable2 type supermount (rw,dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,codepage=850)
/dev/scsi/host0/bus0/target0/lun0/part1 on /mnt/windows type ntfs (rw)

What I get from the last line is that the USB HD is mounted as r/w
But I get the message that the file system is "Read-only"
[root@dhcppc0 root]# chgrp users /mnt/windows
chgrp: ændrer gruppe for '/mnt/windows': Read-only file system
[root@dhcppc0 root]# chmod 770 /mnt/windows
chmod: ændrer rettigheder på '/mnt/windows': Read-only file system

I can still only access the /mnt/windows as root, I can still only read files, not write files to the HD
How do I correct this problem?

asturbcn 12-11-2006 03:25 PM

Sorry but actually, Linux only support NTFS file system in read only mode. :-(


All times are GMT -5. The time now is 09:03 PM.