LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-27-2012, 07:30 PM   #1
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Rep: Reputation: Disabled
How to mount an external ntfs drive with full read/write permissions for everyone


Yes a long title, and it pretty much says it all.. I need to mount an external drive in a different way than what is being done now.

The drive is to be used by both windows and linux. Its running on my Raspberry Pi box, with samba and the windows machine has no problems reading / writing to the drive.

However the Linux machine it self cant. I use RaspBMC with Transmission installed. I want it to save the torrents to this drive, but it cant because it doesnt have permission to. And from what i have read around the web, you cant change linux folder permissions on a windows ntfs drive. Which makes sense, but i've also heard that you can mount the drive in a different way so that its mounted with FULL read/write permissions for everyone .. So thats what i've been up to, but it fails.

Heres what i did..

in Terminal, i go to /mnt/ .. Here i create a folder called Backup..

Then i use "sudo nano /etc/fstab/" to edit what is mounted upon boot.

My fstab file looks like this:

Code:
proc            /proc           proc    defaults         0       0
devpts          /dev/pts        devpts  rw,nosuid,noexec,relatime,gid=5,mode=620        0       0
/dev/mmcblk0p1  /boot           vfat    defaults         0       0
/dev/mmcblk0p2  /               ext4    defaults,noatime 0       0
I then add the UUID for my external NTFS harddrive, so that fstab looks like this

Code:
proc            /proc           proc    defaults         0       0
devpts          /dev/pts        devpts  rw,nosuid,noexec,relatime,gid=5,mode=620        0       0
/dev/mmcblk0p1  /boot           vfat    defaults         0       0
/dev/mmcblk0p2  /               ext4    defaults,noatime 0       0
UUID=5E3E02343E02062D /mnt/backup ntfs-3g gid=everyone,fmask=113,dmask=002 0 0
Save, exit and reboot.. But the drive isnt shown anywhere when its booted up.. Other than that, i really dont like this way of doing it.

Somewhere it must be written that when an removeable ntfs drive is attached it should have some predetermined permissions, and i would like to change this somehow. So that all removeable ntfs drives that becomes attached and mounted are mounted with permissions granting everyone read/write access.. Is this possible?
 
Old 11-28-2012, 12:48 AM   #2
suresh.k
Member
 
Registered: Aug 2011
Location: Hyderabad, AP, India
Distribution: centos, Ubuntu
Posts: 163
Blog Entries: 1

Rep: Reputation: Disabled
If you are using CentOS.
Install package called fuse-ntfs-3g

#yum install fuse-ntfs-3g
then check that Disk has recognized or not
#fdisk -l

Then mount to you folder
#mount /dev/[diskname] /mnt
 
Old 11-28-2012, 01:26 AM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,374

Rep: Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383
Sounds like you want the 'users' option to mount http://linux.die.net/man/8/mount
 
Old 11-28-2012, 04:11 AM   #4
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
I've found out that the Transmission program has a user named "Debian-Transmission" .. Shouldn't i be able to add this user to a group that has permission to write to the drive ? Like Superusers ?

EDIT:
Adding the user Debian-Transmission to the list in "sudo visudo" with ALL=(ALL) ALL i still cant write to the drive ..

Last edited by Da9L; 11-28-2012 at 08:43 AM.
 
Old 11-28-2012, 09:21 AM   #5
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
Sounds like you want the 'users' option to mount http://linux.die.net/man/8/mount
Can you explain this a little more in detail ? I would love to be able to not use fstab as its an external drive
 
Old 11-28-2012, 09:39 PM   #6
cbtshare
Member
 
Registered: Jul 2009
Posts: 619

Rep: Reputation: 42
simply mount the drive with

Quote:
-o umask=000
 
Old 11-29-2012, 11:35 AM   #7
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cbtshare View Post
simply mount the drive with
The drive is already mounted when I boot .. is there a file I can edit with that tag that applies to all external ntfs drives?
 
Old 11-29-2012, 07:28 PM   #8
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,374

Rep: Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383Reputation: 2383
No, edit the fstab entry for each drive you want opened up.
By default, Linux sets things up in a relatively secure manner unless otherwise directed. This is a GOOD thing
 
Old 11-30-2012, 02:32 AM   #9
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
No, edit the fstab entry for each drive you want opened up.
By default, Linux sets things up in a relatively secure manner unless otherwise directed. This is a GOOD thing
But editing fstab is a pain if I replace harddrive more than once a day..
 
Old 11-30-2012, 08:06 AM   #10
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
you might want to look into autofs then.
 
Old 12-03-2012, 05:54 AM   #11
Da9L
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lleb View Post
you might want to look into autofs then.
Sorry for the late answer.. I have installed this and its a little confusing (iam a newb) ..

Could you provide a quick how-to for what configuration files to edit and how i would do it when i want it to work with all removeable ntfs media ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 11.10 HELP NO longer have Read Write Permissions on external NTFS USB Drive rstoesser Ubuntu 1 10-25-2011 03:23 PM
Granting full read/write permissions to all files for a specific user laserjim Linux - Security 10 01-31-2009 11:17 AM
Trying to mount an external UBS drive with ntfs as read/write Sanford Stein Linux - Newbie 7 08-27-2008 09:04 AM
How to mount a read write NTFS partition CircuitSix Linux - Hardware 3 12-07-2005 02:21 AM
Can't mount NTFS in read-write mode Tyco Linux - Hardware 4 06-08-2003 11:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration