LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-12-2009, 12:53 PM   #1
fahadaziz
LQ Newbie
 
Registered: Aug 2008
Posts: 27

Rep: Reputation: 15
Question How to mount a device ?


Hi,

i am trying to mount a cdrom in /mnt/cdrom directory but every time
i am getting an error here it is

[root@mustu cdrom]# mount /media/Corvit\ Systems /mnt/cdrom/
mount: you must specify the filesystem type

please help me out in mounting this device.

Thanks and regards,

Faddi.
 
Old 02-12-2009, 01:03 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You need to give the device that you're trying to mount to /mnt/cdrom, e.g. /dev/cdrom.
 
Old 02-12-2009, 06:11 PM   #3
servat78
Member
 
Registered: Jan 2009
Posts: 100

Rep: Reputation: 17
Just as the error message tells you: you have to specify the file system. Your command misses the file type and the device.
Do something like:

mount -t ext3 /dev/sda1 /media/mountpoint

Have a look at 'man mount' for details.

Debian

Last edited by servat78; 02-19-2009 at 11:20 AM.
 
Old 02-12-2009, 06:32 PM   #4
millgates
Member
 
Registered: Feb 2009
Location: 192.168.x.x
Distribution: Slackware
Posts: 651

Rep: Reputation: 269Reputation: 269Reputation: 269
i think you don't have to specify filename when mounting a cdrom; i think iso9660 is default
you have to specify the device to mount, though.
You're mounting "/media/Corvit\ Systems" in "/mnt/cdrom/" - isn't the cdrom already mounted in "/media/Corvit\ Systems" ?
 
Old 02-12-2009, 06:56 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Please follow the advice of servat78, above, and look at the output of the man mount command. Pay attention to the order of the arguments: the syntax is "mount [options] <device> <mount_point>," and you have the order reversed in your sample command.
 
Old 02-12-2009, 10:55 PM   #6
fahadaziz
LQ Newbie
 
Registered: Aug 2008
Posts: 27

Original Poster
Rep: Reputation: 15
Talking Thanx for the posts

Hi,

I came to know that i was doing wrong and yes it is... i was using fedora 10 release and in that there is no need of mounting the device as it already does....i was messing up with previous versions of linux distros as in redhat linux 9 you have to mount the device but in fedora 10 you dont.....


thanx linuxquestions.org
 
  


Reply

Tags
devices, mounting


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount as a device: mount dvd-iso file in /dev/dvd sadarax Linux - General 21 02-02-2011 11:59 PM
Mount problem - device already mounted or mount point busy zahoo Linux - General 7 08-28-2009 05:02 PM
mount one device to two mount points secretlydead Linux - General 3 03-28-2007 05:30 AM
how can I mount this device: da0: <USB 2.0 Storage Device alkad_mzu *BSD 2 11-15-2003 06:15 PM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration