LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-25-2011, 08:22 AM   #1
msbstar
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.4
Posts: 122

Rep: Reputation: 16
Question How to modify my "PATH" in Ubuntu "bashrc" for a software?


Hello Every body,

I was installing a software in my Ubuntu 9.10 and after
installation completed it prompted the following warning:
-------------------------------------------------------------
Warning:

Your PATH does not point to your newly installed
/home/pc/Reflex/software/bin/esorex.

To ensure execution of the newly installed software you should modify your PATH.
---------------------------------------------------------------
Note that "esorex" is the executable file and by typing its name
in the Terminal the program starts.

What should I write in my "bashrc" as PATH to that program?

I would be very grateful if anyone could help me in this matter.

With best regards,
Hassan
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-25-2011, 08:31 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,870
Blog Entries: 14

Rep: Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112Reputation: 1112
PATH=$PATH:/home/pc/Reflex/software/bin

That tells it to append the new path for the esorex binary to your existing PATH. Note that you either have to logout and login again or source the revised bashrc with the "." command (e.g. ". ./.bashrc" for the .bashrc if sitting in your home directory) for this to update your PATH.

You can also type the PATH=... shown above at command line to simply add it to your current PATH but that will go away when you logout if you haven't updated bashrc or a similar file.

You can type "echo $PATH" to see what your current PATH is set to then again after you've modified the bashrc and reloaded it. It should look something like: /bin:/usr/bin:/usr/local/bin - it may have more or less than that and may be in a different order.
 
2 members found this post helpful.
Old 01-25-2011, 08:37 AM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hi,

why did you install the executables in your /home directory?

I think the /usr/local path for such an installation would be the better solution.

Anyway, edit your .bashrc (within your homedirectory) and add a line
Code:
PATH="/home/pc/Reflex/software/bin:$PATH"
be sure to read the manpage for the shell bash in order to learn about under which circumstances the .bashrc file is sourced! There are different profilefiles for different distributions. The default is that ~/.profile is sourced if bash is invoked as a login-shell and ~/.bashrc if it's not. So you may add the new path to your .profile as well.

Markus
 
1 members found this post helpful.
Old 01-25-2011, 08:47 AM   #4
msbstar
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.4
Posts: 122

Original Poster
Rep: Reputation: 16
Hi, "markush" and "MensaWater".
Thanks for your helpful replies.

Best,
Hassan
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora "software sources" vs. Ubuntu "software repositories" taylorkh Fedora 2 01-23-2011 06:38 PM
Cedega from Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Software 0 03-30-2005 11:24 AM
Cedega and Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Games 0 03-26-2005 02:48 AM
"No Java virtual machine could be found from your PATH" - ignores bashrc shaider Linux - Software 7 10-09-2004 12:38 AM
How to modify dial options ( From "pulse" to "tone" ) nykey Linux - Newbie 3 11-24-2003 01:39 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration