LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-14-2005, 11:29 PM   #1
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Rep: Reputation: 15
how to manually configure xorgconfig


(forgive my horribly newbie question. i'm sure it can be solved with little trouble)

i've configured xorgconfig (slackware) several times in efforts to set the screen resolution to 1024 x 768, but when i launch into GUI it reverts to 800 x 600 (the highest resolution available in the gui configuration menu). despite being unable to find horizontal/vertical refresh rates for my laptop, i configured everything else accordingly.

i have a feeling that this requires some editing of the xorgconfig file. if so, can someone tell me what and how to do it? if not, what else can i do to fix the resolution?
 
Old 07-14-2005, 11:51 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
cd to the directory containing the xorg.conf file (/etc/X11):

$ cd /etc/X11

su to root, enter password, then use a text editor (nano, vim, etc.) to make the changes:

# vim xorg.conf


make changes, restart X.
 
Old 07-15-2005, 01:08 AM   #3
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
what part of the file should i modify -- how should it be changed?
 
Old 07-15-2005, 02:24 AM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Please post the specs for the laptop and/or monitor you are using, as well as the video card you are using. Most likely the fix is pretty minor; it probably will only require that a couple of additional resolution choices get added, or that a different video driver be used. If you can post the current contents of your file, in addition to the laptop specs, I'd guess that this issue can be solved reasonably quickly. -- J.W.

Welcome to LQ!
 
Old 07-15-2005, 06:02 PM   #5
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
okay, specs that i think might be relevant (hopefully the correct relevant jargon) copied from what documentation i have:

++ laptop (dell latitude CP M233XT)

microprocessor type: x86; i586 (intel pentium microporcessor with MMX technology 233 or 166 MHz)
bus architecture: PCI, 33 MHz
system chip set: intel mobile 430TX PCIset
memory: 4 GB
max RAM: 128 MB
memory module capacities and type: 16-, 32-, 64-, and 128-MB, 3.3-V EDO SODIMMS

++ video

video type: 128-bit, hardware-accelerated PCI
video controller: NeoMagic 2160
integrated video memory: 2 MB
video resolution: 800 x 600 px, 16 million colors (however, the integrated video adapter can support up to 1024 x 768 on an external monitor)

++ display

type: active-matrix color (TFT)
max resolution/colors: 1024 x 768; 262,144 colors
dot pitch: 0.26 mms
response time: 50 ms
*refresh rates were not included

++
contents of xorg.conf that i think are pertinent to the issue at hand:

Code:
section "Monitor"

     Identifier "My Monitor"
     HorizSync 31.5, 35.5
     VertRefresh 50-90

Section "Device"
     Identifier "Standard VGA"
     VendorName "Unkown"
     BoardName   "Unkown"
     Driver  "vga"

Section "Device"
    Identifier "NeoMagic (laptop/notebook)"
    Driver   "neomagic"
    #VideoRam 2048

Section "Screen"
    Identifier "Screen 1"
    Device "Neomagic (laptop/notebook)"
    Monitor "My Monitor"
    DefaultDepth 24

Subsection "Display"
        Depth 8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort  0  0
        Virtual   1280 1024
EndSubsection
Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600"
        Viewport  0  0
        Virtual  1024 768
EndSubection
Subsection "Display"
        Depth 24
        Modes "800x600" "640x480"
        ViewPort  0  0
        Virtual  800 600

that's all for now... thanks.

Last edited by aquilolumen; 07-15-2005 at 08:16 PM.
 
Old 07-15-2005, 08:54 PM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
Quote:
Originally posted by aquilolumen
Code:
section "Monitor"

Section "Screen"
    Identifier "Screen 1"
    Device "Neomagic (laptop/notebook)"
    Monitor "My Monitor"
    DefaultDepth 24

Subsection "Display"
        Depth 8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort  0  0
        Virtual   1280 1024
EndSubsection
Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600"
        Viewport  0  0
        Virtual  1024 768
EndSubection
Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
        ViewPort  0  0
        Virtual  800 600

that's all for now... thanks.
it should be very simple (hopefully). if you notice, it tells you the default depth is set for 24. so just go down to the Depth 24 section and add the resolution you want to the Modes line, in this case 1024x768. if the external adapter is set up to work, that should do it.

you could also change the default depth to 16 to see if it worked, it might even look okay enough to use on the laptop screen.

Last edited by synaptical; 07-15-2005 at 08:59 PM.
 
Old 07-15-2005, 11:39 PM   #7
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
nope, it didn't work. well, it did work in the sense that "1024x768" popped up as one of the resolution options in gui, but selecting that didn't change anything. i also changed the default depth to 16, but with similar results.

the reasoning makes sense, and yet i must've done something wrong. i also tried to alter the default gui by commenting out lines pertaining to gnome in /etc/rc.d/rc.4. gnome still popped up after initiating startx, which leads me to believe that i didn't edit either of the two files correctly.

to edit xorg.conf, i typed in (as root): vi /etc/X11/xorg.conf
then i scrolled down to the abovementioned code and inserted "1024x768" after Mode under 24.
after that, i hit <esc> to return to command mode and typed ":wq" to save and quit the editor.
then as root i typed "startx" to start X.

what went wrong?

(forgive me if i do not reply for several days, i will be gone while access to a computer in the near future is questionable)

Last edited by aquilolumen; 07-15-2005 at 11:49 PM.
 
Old 07-16-2005, 12:06 AM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
yep, it sounds like you did everything right with vim. the problem with the gui starting is that in most cases i think you need to edit ~/.xinitrc to change the startx gui, not the rc.* files. but one thing at a time. (no harm done -- we hope. what distro are you using, btw? it's helpful to others to put that in your profile. FC i guess?).

it appears we might have to go more in depth and get your video drivers loaded or installed. this looks like a great page for reference.

as root, try to modprobe the drivers: # modprobe neomagic. if they load (do lsmod |grep neomagic to see if they're there), restart X and hopefully you'll be in business. if you get the fatal message, you'll pretty much have to bite the bullet and compile them into your kernel.

that won't be too hard so don't worry, we'll walk you through it, but just take it one step at a time.

Last edited by synaptical; 07-16-2005 at 12:16 AM.
 
Old 08-01-2005, 09:26 PM   #9
aquilolumen
Member
 
Registered: Jul 2005
Distribution: slackware
Posts: 43

Original Poster
Rep: Reputation: 15
i apologize for the extremely long delay --

looking at ~/.xinitrc, i think i'm supposed to tweak this line
Code:
# Start the window manager:
exec gnome-session
but i don't know what/how to do it.

'modprobe neomagic' returned with 'Can't locate module neomagic'. lsmod |grep neomagic didn't return with anything. i suppose the acquistion of drivers are in store...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to configure updatedb to update locate database manually septanla Linux - General 4 12-22-2010 03:05 PM
Where is xorgconfig? infornography Fedora 4 02-09-2005 03:33 AM
DISCUSSION: How To Configure the KDE 3.3 Menu manually (without KMenuEdit) MasterPatricko LinuxAnswers Discussion 0 11-16-2004 02:04 PM
no mouse - need to configure touchpad manually breenbaron Linux - Laptop and Netbook 2 03-28-2004 12:16 PM
physical scsi channel mapping to scsiX device node mapping, how to configure manually drthornt Linux - Hardware 3 02-09-2003 12:50 PM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration