LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2011, 03:56 AM   #16
katiwhompas
LQ Newbie
 
Registered: Jan 2009
Posts: 13

Rep: Reputation: 1
How Precious...


Perhaps you did not read the entire post? Some keyboards on laptops in particular Older Toshiba and some Asus models do not give you the pipe. Instead when you hit SHIFT + \ you get a > instead of a |

When this happens you can mess with all the key combos you want to try, you will not get the pipe. You have to remap the keys to get it to work correctly.

Just FYI Bob...
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-22-2013, 05:17 PM   #17
crtlbreak
LQ Newbie
 
Registered: Jan 2012
Posts: 5

Rep: Reputation: Disabled
Pipe Symbol

[Alt Gr] and ¬ (to the left of #1 on the kb) delivered my Pipe "|" symbol on a UK keyboard on both fedora and ubuntu
 
Old 05-23-2013, 12:15 AM   #18
Beryllos
Member
 
Registered: Apr 2013
Location: Massachusetts
Distribution: Debian
Posts: 314

Rep: Reputation: 121Reputation: 121
Ceci n'est pas une pipe.
http://en.wikipedia.org/wiki/The_Treachery_of_Images
 
Old 05-24-2013, 12:15 PM   #19
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958
Please indicate clearly when you are reopening old threads. People often don't notice that the conversation is long dead, and may respond to people who aren't even around any more. And only post at all if you have something important to add to it, like corrections or updated information.

As often seems to happen though, I can take this opportunity to add something substantial of my own to the topic. A universal way to input the pipe character (along with many others) is with the x-windows multi-key system. My compose file shows it as being created with <multi><v><l> (or lv,VL,LV) and <multi><slash><ascicircum> and its reverse (/^,^/).
 
Old 05-24-2013, 12:33 PM   #20
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 4,475
Blog Entries: 10

Rep: Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639Reputation: 1639
Mr. New, where are you located geographically, or better yet do you now realize that the | is a pipe symbol which you've derived from shift+\? Or, have you tried this and found that it doesn't work, even though it looked acceptable on the screen?
 
Old 05-24-2013, 02:22 PM   #21
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958
Mr. New's last post here was 7 years ago. He's Mr. Old News now.

But thanks for providing a perfect example of what I was just talking about.
 
1 members found this post helpful.
Old 10-02-2013, 10:41 AM   #22
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Debian 8 (Jessie)
Posts: 87

Rep: Reputation: 15
Wrong Keyboard Mappings

I was having a problem with the pipe symbol so I did a google search and this thread was right at the top. Actually turns out I had my keyboard mapped to a US layout rather than a UK layout; you'd think the british pound and euro signs on the keys would have tipped me off! A lot of the laptops we're using in this part of the world (Kenya, and Africa in general) include lots of ex-UK second-hand laptops so the wrong keyboard mappings can be a problem. Though, I suspect, that wasn't the problem markw8500 was talking about when he posted 8 years ago (wow!)

Last edited by tux_addict; 10-02-2013 at 10:46 AM.
 
Old 05-24-2015, 04:32 PM   #23
postcd
Member
 
Registered: Oct 2013
Posts: 400

Rep: Reputation: Disabled
If nothing works and you even cant paste the symbol, try:
wget https://en.wikipedia.org/wiki/Vertical_bar -q -O ./pipe && cat ./pipe | grep "<p>The <b>vertical bar</b>" && rm -rf ./pipe

it should output pipe symbol among others or this:

cat /root/.ssh/known_hosts

there can be pipe too
 
1 members found this post helpful.
Old 05-25-2015, 07:23 AM   #24
AnanthaP
Member
 
Registered: Jul 2004
Location: Chennai, India
Distribution: UBUNTU 5.10 since Jul-18,2006 on Intel 820 DC
Posts: 813

Rep: Reputation: 195Reputation: 195
It is the ascii character 124 which is:
(ALT+NUMLOCK)1 + 2, 4 on a keyboard interacting with the prompt.

| in html/unicode and so on

OK

Last edited by AnanthaP; 06-04-2015 at 09:04 AM.
 
Old 05-25-2015, 08:57 AM   #25
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 12,603
Blog Entries: 25

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Member response

Hi,

For a necro thread this would be one place that can be found to be useful; https://en.wikipedia.org/wiki/Vertical_bar#Pipe
 
Old 05-29-2015, 06:58 AM   #26
DJ Shaji
Member
 
Registered: Dec 2004
Location: Yo Momma's house
Distribution: Fedora Rawhide, ArchLinux
Posts: 513
Blog Entries: 15

Rep: Reputation: 106Reputation: 106
Quote:
Originally Posted by postcd View Post
If nothing works and you even cant paste the symbol, try:
wget https://en.wikipedia.org/wiki/Vertical_bar -q -O ./pipe && cat ./pipe | grep "<p>The <b>vertical bar</b>" && rm -rf ./pipe
By far the best response I've seen
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 03:33 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 05:51 AM
[Redhat] make "admin" account same privledges as "root" Bi0haZarD Linux - Networking 20 01-12-2005 11:47 AM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 04:31 PM
i just finished typing "./configure" and "make" in mplayer directory... kublador Linux - General 4 02-22-2003 04:12 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration