LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2009, 05:14 AM   #1
p03p
Member
 
Registered: Feb 2009
Posts: 52

Rep: Reputation: 15
how to lock screen resolution??


Im using debian with gnome and im using this pc mostly remotely. And this is also the reason my monitor is not connected to the pc. But i recently found out that when the monitor is not connected the resolution goes to 800x600 and when i connect the monitor i can select 1280x1024 again.

How can i maintain using 1280x1024 without connecting the monitor?? I guess it has something to do with /etc/X11/xorg.conf

Pls help me out
 
Old 02-27-2009, 06:02 AM   #2
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
Please post your /etc/X11/xorg.conf
 
Old 02-27-2009, 06:11 AM   #3
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
here it is:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection

Last edited by p03p; 02-27-2009 at 08:50 AM.
 
Old 02-27-2009, 08:51 AM   #4
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
Someone who knows?
 
Old 02-27-2009, 12:32 PM   #5
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
anyone?
 
Old 02-27-2009, 01:06 PM   #6
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
is that all of it your xorg.conf? i dont' see any modelines
you are looking for this section
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TVOverScan" ".5"
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
make sure only the resolution you want to use is in the section, that might work
 
Old 02-27-2009, 10:56 PM   #7
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
that was really my whole conf.

what do i got to do?

Last edited by p03p; 02-28-2009 at 12:14 PM.
 
Old 02-28-2009, 05:14 PM   #8
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
pls help me out
 
Old 03-04-2009, 11:41 AM   #9
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
im still having this problem, someone know what i got to do to fix it?
 
Old 03-04-2009, 01:03 PM   #10
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
replace your screen section in xorg.conf with something like this:
Code:
Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection
 
Old 03-04-2009, 01:17 PM   #11
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
I have replaced my screen with that and restarted the pc but its still the same as before
 
Old 03-04-2009, 04:05 PM   #12
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Video card.

What type of video card are you using?
 
Old 03-04-2009, 04:14 PM   #13
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
im not sure its integraded in my main board Asrock K7S41GX
And this is the spec i found:

- Integrated Mirage Graphics
- Shared Memory Max. 64MB
 
Old 03-04-2009, 04:16 PM   #14
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
New Info.

Please post your new modified xorg.conf.
 
Old 03-04-2009, 04:27 PM   #15
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
Here it is

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM "Lock screen" item fails to lock down. Swan1 SUSE / openSUSE 9 02-03-2009 01:00 AM
Correct desktop resolution. Incorrect screensaver & lock resolution mybootorg Linux - General 6 05-03-2006 03:39 AM
How to disable Lock Screen when close laptop screen? amosbatto Linux - Laptop and Netbook 2 01-17-2006 12:12 AM
Screen Lock up when enabling full screen in VLC unux82 Linux - Software 0 07-20-2005 04:01 AM
Screen lock changes screen resolution ohzo Linux - Laptop and Netbook 0 06-23-2004 12:13 PM


All times are GMT -5. The time now is 04:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration