LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-02-2010, 11:28 PM   #1
bettyhills
LQ Newbie
 
Registered: Jun 2007
Location: Maryland
Distribution: Ubuntu II 8.10
Posts: 22

Rep: Reputation: 15
How to keep HDD mounted thru restart?


The Fat32 master HDD in my Intrepid Ibex 8.04 Ubuntu PC is mounted and stays so.

I installed a second (slave) ntfs HDD into the Ubuntu PC. Each time I turn it on, the drive needs to be mounted.

What (exact steps) do I need to do so that the slave drive stays mounted after the PC is turned off.

The goal: When the PC is turned on, I'd like the slave HDD already mounted and ready to use.

TIA
 
Old 02-03-2010, 12:38 AM   #2
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mandriva, CentOS, Ubuntu
Posts: 456

Rep: Reputation: 69
Have a look inside the file
Quote:
/etc/fstab
You will need to put in a line to mount the drive you want. For example:
Quote:
/dev/sdb1 /mnt/data ntfs-3g defaults 0 0
 
1 members found this post helpful.
Old 02-03-2010, 03:05 PM   #3
bettyhills
LQ Newbie
 
Registered: Jun 2007
Location: Maryland
Distribution: Ubuntu II 8.10
Posts: 22

Original Poster
Rep: Reputation: 15
The slave drive is named "Public."
What line would you add or alter?
Here are the contents of the fstab file:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=98d7ef1c-f15c-44a0-87b9-8972cb42639e / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=d73ce4ff-e7b9-407b-bf7d-3ebf30ebb157 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0

Thanks.
 
Old 02-03-2010, 03:43 PM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,388
Blog Entries: 3

Rep: Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479
Hi,

Quote:
Originally Posted by bettyhills View Post
The slave drive is named "Public."
What line would you add or alter?
Here are the contents of the fstab file:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=98d7ef1c-f15c-44a0-87b9-8972cb42639e / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=d73ce4ff-e7b9-407b-bf7d-3ebf30ebb157 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0

Thanks.
It appears you have '/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0' in your '/etc/fstab' listed above. Looks like the system added the line.

 
1 members found this post helpful.
Old 02-03-2010, 04:12 PM   #5
bettyhills
LQ Newbie
 
Registered: Jun 2007
Location: Maryland
Distribution: Ubuntu II 8.10
Posts: 22

Original Poster
Rep: Reputation: 15
Yes. Restarted the system several times and the slave drive stays mounted. Thank you.
 
Old 02-03-2010, 05:37 PM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,388
Blog Entries: 3

Rep: Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479Reputation: 1479
Hi,

I suggest that you read from these links;

Linux Documentation Project
Rute Tutorial & Exposition
Linux Command Guide
Utimate Linux Newbie Guide
LinuxSelfHelp
Getting Started with Linux
Advanced Bash-Scripting Guide
Linux Home Networking


The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
  


Reply

Tags
hdd, mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change the permission of a mounted HDD? Hardcor3 Linux - Newbie 3 03-25-2009 12:57 AM
External HDD won't restart on boot-up PaulFXH Linux - Hardware 0 07-25-2007 05:50 AM
mounted HDD on hoary fireedo Ubuntu 1 06-06-2005 12:36 PM
problem accessing mounted hdd linuxmandrake Linux - Newbie 1 11-20-2004 05:37 PM
Running red hat 9 with hdd mounted read only encode Linux - General 1 02-18-2004 09:42 PM


All times are GMT -5. The time now is 11:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration