LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How to keep HDD mounted thru restart? (http://www.linuxquestions.org/questions/linux-newbie-8/how-to-keep-hdd-mounted-thru-restart-786569/)

bettyhills 02-02-2010 10:28 PM

How to keep HDD mounted thru restart?
 
The Fat32 master HDD in my Intrepid Ibex 8.04 Ubuntu PC is mounted and stays so.

I installed a second (slave) ntfs HDD into the Ubuntu PC. Each time I turn it on, the drive needs to be mounted.

What (exact steps) do I need to do so that the slave drive stays mounted after the PC is turned off.

The goal: When the PC is turned on, I'd like the slave HDD already mounted and ready to use.

TIA

ongte 02-02-2010 11:38 PM

Have a look inside the file
Quote:

/etc/fstab
You will need to put in a line to mount the drive you want. For example:
Quote:

/dev/sdb1 /mnt/data ntfs-3g defaults 0 0

bettyhills 02-03-2010 02:05 PM

The slave drive is named "Public."
What line would you add or alter?
Here are the contents of the fstab file:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=98d7ef1c-f15c-44a0-87b9-8972cb42639e / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=d73ce4ff-e7b9-407b-bf7d-3ebf30ebb157 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0

Thanks.

onebuck 02-03-2010 02:43 PM

Hi,

Quote:

Originally Posted by bettyhills (Post 3851215)
The slave drive is named "Public."
What line would you add or alter?
Here are the contents of the fstab file:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=98d7ef1c-f15c-44a0-87b9-8972cb42639e / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=d73ce4ff-e7b9-407b-bf7d-3ebf30ebb157 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0

Thanks.

It appears you have '/dev/sdb1 /media/Public ntfs-3g defaults,locale=en_US.UTF-8 0 0' in your '/etc/fstab' listed above. Looks like the system added the line.

:hattip:

bettyhills 02-03-2010 03:12 PM

Yes. Restarted the system several times and the slave drive stays mounted. Thank you.

onebuck 02-03-2010 04:37 PM

Hi,

I suggest that you read from these links;

Linux Documentation Project
Rute Tutorial & Exposition
Linux Command Guide
Utimate Linux Newbie Guide
LinuxSelfHelp
Getting Started with Linux
Advanced Bash-Scripting Guide
Linux Home Networking

:hattip:
The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!


All times are GMT -5. The time now is 07:13 PM.