LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2015, 05:11 AM   #1
siery
LQ Newbie
 
Registered: Dec 2015
Posts: 28

Rep: Reputation: Disabled
Exclamation How to intall sdl2 without dependencies hell?


Hey.
I would like to install a sdl2 library for my Ubuntu and Debian Jessie. But when i simply go for "apt-get -t trusty-backports install libsdl2-dev" there comes a great heap of dependencies:

Code:
libsdl2-dev : Depends: libsdl2-2.0-0 (= 2.0.2+dfsg1-8) but it is not installable
               Depends: libdbus-1-dev but it is not going to be installed
               Depends: libegl1-mesa-dev
               Depends: libgl1-mesa-dev
               Depends: libgles2-mesa-dev
               Depends: libglu1-mesa-dev but it is not going to be installed
               Depends: libpulse-dev but it is not going to be installed
               Depends: libsndio-dev but it is not installable
               Depends: libudev-dev but it is not going to be installed
               Depends: libwayland-dev but it is not going to be installed
               Depends: libx11-dev but it is not going to be installed
               Depends: libxcursor-dev but it is not going to be installed
               Depends: libxext-dev but it is not going to be installed
               Depends: libxi-dev but it is not going to be installed
               Depends: libxinerama-dev but it is not going to be installed
               Depends: libxkbcommon-dev but it is not going to be installed
               Depends: libxrandr-dev but it is not going to be installed
               Depends: libxss-dev but it is not going to be installed
               Depends: libxt-dev but it is not going to be installed
               Depends: libxv-dev but it is not going to be installed
               Depends: libxxf86vm-dev but it is not going to be installed
Is there any way to install a package with all it's depends packages?
Thanks, Siery.
 
Old 12-26-2015, 10:05 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,564

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
SDL is linked to everything. Do you need the latest version?
 
Old 12-26-2015, 01:26 PM   #3
siery
LQ Newbie
 
Registered: Dec 2015
Posts: 28

Original Poster
Rep: Reputation: Disabled
Yes indeed .
 
  


Reply

Tags
apt-get, installation, package


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SDL2 Released dugan Linux - News 1 08-13-2013 03:49 PM
Because of "dependencies" hell,... me210 Fedora 4 01-18-2007 05:00 AM
Is it posible to intall FC5 with just 3 intall CD's ponky2x Fedora - Installation 1 07-26-2006 11:08 AM
Another dependencies hell. nidua18 Linux - Software 4 09-27-2003 01:12 PM
RPM Software Intall....failed dependencies?? bison42 Linux - Software 3 09-02-2001 12:03 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration