LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-22-2015, 12:40 PM   #16
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154

Editing post #6 : That's the 'Edit' button in post #6.


Also : Please do not quote your own posts.
The quoted / repeated content in posts #13 and #14 can be deleted.


Please read post #7, about the post #6 "tcl text" :
""Not usable as tcl code. Too many typos, forbidden characters, etc.""


-
 
Old 03-24-2015, 12:59 AM   #17
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
Unhappy about my post #14 and #15

hello sir
I have edites my post #14 and #15.
please give me answer of my both post as early as possible because its urgent. sorry for delaying and thanks for your help
 
Old 03-24-2015, 07:30 AM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
$ patch p0 < zrp-diff2014_ns233.patch is a typo.

The patch command is : patch -p0 < zrp-diff2014_ns233.patch
I.e. -p0 instead of p0.
... See "the patch manual", $ man patch
http://linux.die.net/man/1/patch


Don't know if you have other questions ?
Can be answered when you have edited post #6 to 'CODE Tags'


-
 
1 members found this post helpful.
Old 03-25-2015, 09:25 AM   #19
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
Unhappy problemm while running zrp example.

hello sir
in last post as you said, I follow the procedure and my patch is installed now. thank you so much for you help.
but after installing it, it also give me a notification that given below,
============================================================
* Build nam-1.13
============================================================
ln: creating symbolic link `otcl/otcl-1.13': File exists
ln: creating symbolic link `tclcl/tclcl-1.19': File exists
cd: 574: can't cd to ./nam-1.13
./install: 585: ./configure: not found
Nam configuration failed! Exiting ...
Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.

and after the command, $ patch -p0 < zrp-diff2014_ns233.patch, I follow the same procedure as given in the link provided by you. the steps are,
c) $ export CC=gcc-4.4 CXX=g++-4.4 && ./install
e) $ cd ns-2.33/
f) $ cp ns ns-zrp
g) $ sudo cp ns-zrp /usr/local/bin/

but when I was trying to run the example given by the link which is provided by you
https://drive.google.com/file/d/0B7S...it?usp=sharing

by using a command,
$ ns-zrp zrp-Demo1-1.tcl
then I get an error which is given below
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33$ cd ns-zrp
bash: cd: ns-zrp: Not a directory.
then what I do now??
and also please give me answer of my thread about nam. please sir its urgent.
 
Old 03-25-2015, 09:53 AM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Ref. post #19.

Nam : Install a package : See post #2.


Quote:
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33$ cd ns-zrp
1) The Desktop is not for building applications.
Default is /home/name/tmp/.
Ns2 : /home/name/<any-directory>/ , except for /home/name/Desktop/.

2) $ cd ns-zrp : You can't do that.
Please try with $ /usr/local/bin/ns-zrp zrp-Demo1-1.tcl


-
 
Old 03-27-2015, 02:09 AM   #21
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
about installing nam

hello sir
as you said in your last post to see your post #2 for installing nam.
but when I follow the link you have given in your post #2, which is,
http://www.linuxquestions.org/questi...-4175524760/#2

A 64bits OS : nam_1.14_amd64.deb
32bits : nam_1.15-10_i386.deb

then,I get a message from my package installer which is given below.
could not open nam-1.14-amd64-2.deb, and also give the message,
the package might be corrupted or you are not allowed to open the file. check the permission

now what can I do now. please help me..
 
Old 03-27-2015, 10:41 AM   #22
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Ref. post #21.

What is it you have now ? A 32bits OS or a 64bits OS ?
This command will reply with architecture : $ uname -m

i686 = 32bits : Use nam_1.15-10_i386.deb
x86_64 = 64bits : Use nam_1.14_amd64.deb

The install : $ sudo dpkg -i <package>.deb
( If the 'Package Installer' isn't working.)


-
 
1 members found this post helpful.
Old 03-29-2015, 10:48 AM   #23
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
about your post #22

hello sir
first thank you so much for helping me to run ZRP example.
but there is problem while installing nam.
when I was trying to install nam
i686 = 32bits : Use nam_1.15-10_i386.deb
x86_64 = 64bits : Use nam_1.14_amd64.deb
using command,
$ sudo dpkg -i <package>.deb
I get an error given below,
dpkg: error processing nam_1.14_amd64.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
nam_1.14_amd64.deb
what can I do now..?
and sir I have installed Ubuntu 10.04 using VMware workstation 8.0.
 
Old 03-29-2015, 11:24 AM   #24
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Repeat : "This command will reply with architecture : $ uname -m
So please answer if your OS is i686 or x86_64.


Installing a nam package :
1) Download the package.
2) $ pwd : To know your current location.
3) $ cd Downloads/ ( Or wherever you keep the package.)
4) $ sudo dpkg -i [package-name].deb


-

Last edited by knudfl; 03-29-2015 at 01:19 PM.
 
Old 03-30-2015, 02:17 AM   #25
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
about post #23

ref to your post #24
hello sir
sorry sir its about your post #24 not #23.
when i type the command,
$ uname -m
then i get answer, i686.
But when i follow your procedure,
1)Download the package.
2) $ pwd : To know your current location.
3) $ cd Downloads/ ( Or wherever you keep the package.)
4) $ sudo dpkg -i [package-name].deb
then i get an error given below,
dpkg: error processing [nam-1.14-1.el6.i686.rpm (--install):

cannot access archive: No such file or directory

dpkg: error processing ].deb (--install):

cannot access archive: No such file or directory

Errors were encountered while processing:

[nam-1.14-1.el6.i686.rpm

].deb
.
I have downloaded the nam package from the site given by you in post #2.
http://www.linuxquestions.org/questi...-4175524760/#2
and also i want to include here that in my download folder, it is not showing my all downloads.
now what can i do..? please sir its very urgent.

Last edited by neha$$; 03-30-2015 at 02:19 AM.
 
Old 03-30-2015, 02:56 AM   #26
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
Unhappy About nam packages

Hello sir,
As you have suggested previously,I opened that link for nam package and I have downloaded that package but after dowmloading where it goes?.What is its location? & when we try to open it,it didn't show any content to me. when i try to open the folder of downloaded nam it shows the location,
/usr/local/bin/nam.
and also i have downloaded nam= nam-1.14-1.el6.i686.rpm,
now what can i do..??
 
Old 03-30-2015, 08:19 AM   #27
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Ref. posts #26, #25

Not quite clear what you mean : Where are the downloaded packages ?


The package for your Ubuntu - i686 is : nam_1.15-10_i386.deb

Install : sudo dpkg -i nam_1.15-10_i386.deb


-
 
Old 03-31-2015, 02:43 AM   #28
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
Unhappy about installing nam

hello sir
as you said to me to install the nam package which is, nam_1.15-10_i386.deb. but when i try to download that package, it shows me unknown time required to download. it didnt get download. so i downloaded nam package, nam-1.14-10_i386.deb from the post which you have suggested to one person. it has successfully installed. m i going in correct way??
but also when i was trying to run zrp-Demo1-1.tcl example, it only runs on ns enviornment, but not on nam. please help me.
and also i want the zrp example which will run on nam.

Last edited by neha$$; 03-31-2015 at 02:44 AM.
 
Old 03-31-2015, 05:29 AM   #29
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Re post #28.

Nam : nam-1.14(-10_i386.deb) : Same facilities as version 1.15. So OK.


Quote:
zrp-Demo1-1.tcl example, it only runs on ns enviornment
The command e.g. $ ns235-zrp zrp-Demo1-1.tcl
.. creates the files scatternet10.tr and scatternet10.nam .
Running nam : $ nam scatternet10.nam


-

Last edited by knudfl; 04-02-2015 at 11:25 AM.
 
Old 04-02-2015, 10:39 AM   #30
neha$$
LQ Newbie
 
Registered: Jan 2015
Posts: 21

Original Poster
Rep: Reputation: Disabled
About post #29

Hello sir,
As you have suggested in post #29,I have followed your instructions as below & I am getting result as given below,
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33/zrp$ ls
constants.h scatternet10.tr scatternet20.tr zrp-Demo1-1.tcl zrp.h
scatternet10.nam scatternet20.nam zrp.cc zrp-Demo2-1.tcl zrp.o
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33/zrp$ ns-zrp zrp-Demo1-1.tcl
num_nodes is set 10
INITIALIZE THE LIST xListHead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
using backward compatible Agent/CBR; use Application/Traffic/CBR instead
Starting Simulation...
channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
highestAntennaZ_ = 1.5, distCST_ = 550.0
SORTING LISTS ...DONE!
NS EXITING...
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33/zrp$ scatternet10.nam
scatternet10.nam: command not found
neha@neha-desktop:~/Desktop/ns-allinone-2.33/ns-2.33/zrp$
so please tell me,what to do now to get results on nam.
 
  


Reply

Tags
ns2, zrp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nam ns2.34 error maryyum Linux - Newbie 15 09-04-2014 07:40 AM
to install ns2 along with nam and udp-lite patch sakibamu Linux - Software 1 11-26-2013 05:25 PM
[SOLVED] ns2.29 -nam Ndia Linux - Software 1 05-26-2013 04:20 AM
nam not working ns2.33 fabe856 Linux - Software 3 04-20-2012 02:03 PM
[SOLVED] NS2 Nam Issue atb2010 Linux - Newbie 2 03-17-2011 10:52 AM


All times are GMT -5. The time now is 08:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration