LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-05-2010, 10:06 AM   #1
Manish87
Member
 
Registered: May 2010
Posts: 116

Rep: Reputation: 18
How To install metasploit in Fedora?


Hi,

i am using fedora12,i have downloaded the metasploit framework and it is in tar.bz2 form,i wanted to know how i could install it in fedora? i tryed it in windows ,worked smoothly since it was in .exe form! bt here in fedora i am not sure on how i could install it!


Thanks in advance


Kind Regards,
Manish
 
Old 06-05-2010, 11:34 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,652

Rep: Reputation: 536Reputation: 536Reputation: 536Reputation: 536Reputation: 536Reputation: 536
Read the documentation? http://www.metasploit.com/redmine/pr.../Install_Linux
There's probably also a README and INSTALL file to read once you unpack the tar.bz2.
 
Old 06-05-2010, 11:52 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
1)
ftp://ftp.sunet.se/pub/os/Linux/dist...0.1.noarch.rpm
> metasploit-3.3.3-1mdv2010.1.noarch.rpm
2)
ftp://ftp.sunet.se/pub/os/Linux/dist...0.1.noarch.rpm
> metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm

3) su
4) yum install ruby
5)
Code:
yum --nogpgcheck localinstall metasploit-3.3.3-1mdv2010.1.noarch.rpm metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm
/usr/bin/msfgui
.. will open metasploit. . .. Looks OK , Fedora 12 !
..
 
Old 06-05-2010, 12:44 PM   #4
Manish87
Member
 
Registered: May 2010
Posts: 116

Original Poster
Rep: Reputation: 18
Hi,

Thanks For the Response AlucardZero and knudfl


knudfl,i the first 3 commands we done without any problem but the last command is not geting exucuted


O/p:


[root@Home Manish]# yum --nogpgcheck localinstall metasploit-3.3.3-1mdv2010.1.noarch.rpm metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm
Loaded plugins: presto, refresh-packagekit
Setting up Local Package Process
Cannot open file: metasploit-3.3.3-1mdv2010.1.noarch.rpm. Skipping.
Cannot open file: metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm. Skipping.
Nothing to do


Kind Regards,
Manish
 
Old 06-05-2010, 12:55 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
Assume the two rpm packages downloaded to a folder, e.g. Downloads/

cd Downloads/
# yum --nogpgcheck localinstall <package> <package>

If it fails, please do : # yum install ruby-gtk2 ruby-libglade2

And : # rpm -Uvh <package> <package>
..

Last edited by knudfl; 06-05-2010 at 12:58 PM.
 
Old 06-05-2010, 01:11 PM   #6
Manish87
Member
 
Registered: May 2010
Posts: 116

Original Poster
Rep: Reputation: 18
Hey,

o/p of "yum --nogpgcheck localinstall <package> <package>" command:


[root@Home Downloads]# yum --nogpgcheck localinstall metasploit-3.3.3-1mdv2010.1.noarch.rpm

Loaded plugins: presto, refresh-packagekit
Setting up Local Package Process
Examining metasploit-3.3.3-1mdv2010.1.noarch.rpm: metasploit-3.3.3-1mdv2010.1.noarch
metasploit-3.3.3-1mdv2010.1.noarch.rpm: does not update installed package.
Nothing to do




o/p of "yum install ruby-gtk2 ruby-libglade2" command:


yum install ruby-gtk2 ruby-libglade2
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Package ruby-gtk2-0.19.4-1.fc12.i686 already installed and latest version
Package ruby-libglade2-0.19.4-1.fc12.i686 already installed and latest version
Nothing to do



ruby is already updated to the latest packet,i feel the error is in the first command itself!!



Kind Regards,
Manish
 
Old 06-05-2010, 01:44 PM   #7
Manish87
Member
 
Registered: May 2010
Posts: 116

Original Poster
Rep: Reputation: 18
Hey,


thnx knudfl it worked!! since the first command that is yum --nogpgcheck localinstall <package> <package> dint worked,as said by knudfl i used the second and third command,heres the o/p of second and third command!


[root@Home Downloads]# rpm -Uvh metasploit-3.3.3-1mdv2010.1.noarch.rpm metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm


warning: metasploit-3.3.3-1mdv2010.1.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 26752624
Preparing... ########################################### [100%]
package metasploit-3.3.3-1mdv2010.1.noarch is already installed
package metasploit-gui-3.3.3-1mdv2010.1.noarch is already installed



[root@Home Downloads]# yum --nogpgcheck localinstall metasploit-3.3.3-1mdv2010.1.noarch.rpm metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm


Loaded plugins: presto, refresh-packagekit
Setting up Local Package Process
Examining metasploit-3.3.3-1mdv2010.1.noarch.rpm: metasploit-3.3.3-1mdv2010.1.noarch
metasploit-3.3.3-1mdv2010.1.noarch.rpm: does not update installed package.
Examining metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm: metasploit-gui-3.3.3-1mdv2010.1.noarch
metasploit-gui-3.3.3-1mdv2010.1.noarch.rpm: does not update installed package.
Nothing to do


we goto the folder where metasloit has been downloaded!(in my case download)



Kind Regards,
Manish
 
Old 06-05-2010, 01:56 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
""Nothing to do"" usually means : already installed.

Did the application work ? $ msfgui

..
 
Old 06-05-2010, 01:59 PM   #9
Manish87
Member
 
Registered: May 2010
Posts: 116

Original Poster
Rep: Reputation: 18
Hi,

Yes it did,after i went to /usr/bin/msfgui



Kind Regards,
Manish
 
Old 06-30-2010, 03:48 PM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,266

Rep: Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661Reputation: 2661
Message from @Manish87
Code:
Hi knudfl,
Thanx for helping me on how to install metasploit framework
(several post bacK).since i am a fedora user you had suggested 
me to download metasploit tool from the link 
ftp://ftp.sunet.se/pub/os/Linux/dist....noarch.rpm.do you have 
any other other backtrack tools such as airdump, hydra in there??
Kind Regards,
Manish
'airodump-ng' → # yum install aircrack-ng

Source, etc.
http://www.aircrack-ng.org/doku.php?id=downloads
http://download.aircrack-ng.org/aircrack-ng-1.1.tar.gz
>>> aircrack-ng-1.1.tar.gz
Documentation:
http://www.aircrack-ng.org/doku.php?id=airodump-ng

I will add some lines, when I know more about hydra.
..
 
  


Reply

Tags
metasploit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
metasploit frameword 3.2 error zion_rulz Linux - Distributions 0 05-29-2009 08:33 AM
LXer: Portrait: Metasploit godfather H.D. Moore LXer Syndicated Linux News 0 10-30-2008 11:50 PM
metasploit dellthinker Linux - Software 0 01-21-2007 06:49 PM
Metasploit & Nessus games1 Linux - Software 1 10-05-2006 06:24 AM
LXer: Fear the Metasploit Framework LXer Syndicated Linux News 0 09-27-2006 03:33 PM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration