LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2014, 11:12 PM   #1
gonny95
Member
 
Registered: Feb 2014
Distribution: Slackware,Ubuntu
Posts: 84

Rep: Reputation: Disabled
How to install lxde on slackware


I'm trying to install lxde on 32-bit slackware14.1

I installed lxde-common, pcmanfm, lxsession and their requirements from slackbuilds

But when I try to start lxde using 'startlxde' command,
It says that
Code:
root@localhost:~#startlxde
** Message:main.vala:99: Session is LXDE
** Message:main.vala:100: DE is LXDE

(lxsession:1960): Gtk-WARNING **: cannont open display:
root@localhost:~#
And I also want to know how to uninstall KDE and xfce and their associated packages completely
 
Old 02-26-2014, 01:12 AM   #2
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 958

Rep: Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608
The "proper" way to start a desktop environment is to add it to your .xinitrc file so that you can issue the 'startx' command, which should not require you to be root in order to execute.

Slackware ships with a bunch of sample .xinitrc in /etc/X11/xinit/

The idea is that you will startx and then it will look at your user's .xinitrc file to figure out what desktop you want to launch.


You also might be able to launch lxde from KDM or XDM, which you can launch as root, and then find lxde as an option in the desktop options before logging in.
 
Old 02-26-2014, 01:39 AM   #3
gonny95
Member
 
Registered: Feb 2014
Distribution: Slackware,Ubuntu
Posts: 84

Original Poster
Rep: Reputation: Disabled
I looked at /etc/X11/xinit/ there is already lxde.xinitrc file
So I changed default x window manager using xwmconfig
Then I can run startx but there are no icons, no panels, even no mouse pointer(There is a mouse pointer but invisible.I can do right-click and pop up menu appears)
What I can see is just an wallpaper
 
Old 02-26-2014, 02:00 AM   #4
gonny95
Member
 
Registered: Feb 2014
Distribution: Slackware,Ubuntu
Posts: 84

Original Poster
Rep: Reputation: Disabled
I installed lxappearance and lxappearance-opconf then works fine. thanks
 
Old 02-26-2014, 02:24 AM   #5
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 958

Rep: Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608Reputation: 608
Forgot about xwmconfig :-)
Glad you got it figured out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14 on VirtualBox, minimal XCFE/LXDE install AdiLQ123 Linux - Newbie 19 06-18-2013 03:35 AM
Will we ever get LXDE officially in Slackware? storkus Slackware 16 05-15-2013 07:13 AM
LXDE desktop for slackware 13.1 - testing ponce Slackware 114 11-30-2012 07:03 PM
Lxde, standard in Slackware? cwizardone Slackware 2 07-27-2011 09:34 PM
How do I start LXDE on Slackware 12.1? oranyelik Slackware 24 01-29-2009 03:04 AM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration