LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2008, 01:58 PM   #1
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Rep: Reputation: 69
How to install debuginfo for GDB


I've been using gdb to view assembly language and this came up

Missing separate debuginfos, use: debuginfo-install glibc.i686

How do I install that, and where from?
Could you guys give me a step to step on how to, thanks.
 
Old 06-26-2008, 03:15 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
Hi.

I don't use it myself, but dubuginfo-install is a program used to download and install the debugging information you need for, in this case, the C library code.

You should be able to just run this in a terminal:
Code:
debuginfo-install glibc.i686
and it should install the glibc debugging library for you, using your distro's package manager.

You may need to install the debuginfo-install program if it isn't already installed.
 
1 members found this post helpful.
Old 06-26-2008, 03:47 PM   #3
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Original Poster
Rep: Reputation: 69
Didn't work. I tried typing it in as root. Then I tried yum install debuginfo-install glibc.i686 and yum install debuginfo-install
 
Old 06-26-2008, 04:13 PM   #4
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Original Poster
Rep: Reputation: 69
Solved it by typing
rpm yum-utils
debuginfo-install glibc
 
1 members found this post helpful.
Old 11-13-2009, 10:46 PM   #5
thebusker
LQ Newbie
 
Registered: Mar 2009
Location: Illinois
Distribution: Fedora
Posts: 5
Blog Entries: 2

Rep: Reputation: 0
Bingo

I was having the same problem, and that solved it. Thank you.
 
Old 05-14-2010, 01:34 AM   #6
Chrus
LQ Newbie
 
Registered: May 2010
Posts: 1

Rep: Reputation: 0
Missing separate debuginfos, use: debuginfo-install glibc-2.10.2-1.i686

Quote:
Originally Posted by trist007 View Post
Solved it by typing
rpm yum-utils
debuginfo-install glibc
The first one said I cound't run the install command because I am not the root
and the above quote just shows the the rpm commands and doesn't install anything


My original error message was
Missing separate debuginfos, use: debuginfo-install glibc-2.10.2-1.i686

HELP!!! I cannot finish my debugging because i end up crashing at some point.
 
Old 05-16-2010, 03:10 PM   #7
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
Quote:
Originally Posted by Chrus View Post
The first one said I cound't run the install command because I am not the root
and the above quote just shows the the rpm commands and doesn't install anything


My original error message was
Missing separate debuginfos, use: debuginfo-install glibc-2.10.2-1.i686

HELP!!! I cannot finish my debugging because i end up crashing at some point.
Chrus: it may be faster to read through your code and figure out what could cause the crash. But you will need to use su to install commands as root. Also, these commands will only work on RPM based systems like Red Hat or Fedora.
 
Old 11-01-2010, 02:25 AM   #8
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,672
Blog Entries: 29

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
This link may also be helpful here:
http://download.opensuse.org/debug/d...s/suse/x86_64/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing separate debuginfo for - GDB TheIndependentAquarius Linux - Software 2 11-26-2012 02:59 AM
[SOLVED] How to install kernel-devel and kernel-debuginfo puntino Gentoo 5 08-02-2012 02:42 AM
zypper install gdb, does not install the latest version of GDB TheIndependentAquarius SUSE / openSUSE 4 12-30-2010 04:00 AM
GDB error: Missing separate debuginfo for /lib64/ld-linux-x86-64.so.2 TheIndependentAquarius Programming 1 07-09-2010 05:31 PM
Debuginfo itshankar47 Linux - Software 2 04-04-2010 09:01 PM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration