LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-28-2006, 03:31 AM   #1
sunnydayzrback
LQ Newbie
 
Registered: Jan 2006
Posts: 25

Rep: Reputation: 15
how to install audio drivers for Ubuntu 5.10


I installed ubuntu 5.10 Os. I also installed the real player but
i am unable to listen to audio files. Plz tell me where I can get the Audio drivers for Intel D915gavl MotherBoard for Ubuntu 5.10. I have the motherboard cd. Will it be sufficient?my audo drivers are realtek
when i typed ls mod it gave the following report


Module Size Used by
rfcomm 34972 0
l2cap 22404 5 rfcomm
bluetooth 43012 4 rfcomm,l2cap
cpufreq_userspace 4444 0
cpufreq_stats 5124 0
freq_table 4484 1 cpufreq_stats
cpufreq_powersave 1920 0
cpufreq_ondemand 5916 0
cpufreq_conservative 6820 0
i915 17920 1
drm 58004 2 i915
video 16004 0
tc1100_wmi 6916 0
sony_acpi 5516 0
pcc_acpi 11392 0
hotkey 9508 0
dev_acpi 11396 0
i2c_acpi_ec 5760 0
i2c_core 19728 1 i2c_acpi_ec
button 6672 0
battery 9604 0
container 4608 0
ac 4996 0
ipv6 217408 6
af_packet 20232 2
floppy 52692 0
pcspkr 3652 0
rtc 11832 0
tpm_nsc 6528 0
tpm 9504 1 tpm_nsc
snd_hda_intel 15872 1
snd_hda_codec 72064 1 snd_hda_intel
snd_pcm_oss 46368 0
snd_mixer_oss 16128 1 snd_pcm_oss
snd_pcm 78344 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 21764 1 snd_pcm
snd 48644 8 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 9184 1 snd
snd_page_alloc 10120 2 snd_hda_intel,snd_pcm
shpchp 80612 0
pci_hotplug 24628 1 shpchp
intel_agp 21276 1
agpgart 32328 3 drm,intel_agp
dm_mod 50364 1
tsdev 7616 0
evdev 9088 0
psmouse 26116 0
mousedev 10912 1
parport_pc 31812 1
lp 11460 0
parport 32072 2 parport_pc,lp
md 40656 0
ext3 115976 1
jbd 48536 1 ext3
thermal 13192 0
processor 23100 1 thermal
fan 4740 0
8139too 23552 0
8139cp 18432 0
mii 5248 2 8139too,8139cp
ehci_hcd 29448 0
uhci_hcd 28048 0
usbcore 104188 3 ehci_hcd,uhci_hcd
sd_mod 17424 3
ide_cd 36996 0
cdrom 33952 1 ide_cd
ide_generic 1664 0
ata_piix 9476 11
libata 47876 1 ata_piix
scsi_mod 124872 2 sd_mod,libata
piix 9476 1
ide_core 125268 3 ide_cd,ide_generic,piix
unix 24624 695
vesafb 8088 0
capability 5000 0
commoncap 6784 1 capability
vga16fb 12232 1
vgastate 8320 1 vga16fb
softcursor 2432 2 vesafb,vga16fb
cfbimgblt 2944 2 vesafb,vga16fb
cfbfillrect 3840 2 vesafb,vga16fb
cfbcopyarea 4480 2 vesafb,vga16fb
fbcon 34176 72
tileblit 2560 1 fbcon
font 8448 1 fbcon
bitblit 5248 1 fbcon


are my sound drivers installed???

Last edited by sunnydayzrback; 01-28-2006 at 03:38 AM.
 
Old 01-28-2006, 07:11 AM   #2
yakkmeister
Member
 
Registered: Jan 2005
Location: QLD Australia
Distribution: SuSE + Ubuntu + DeMuDi ... whatever does the job :D
Posts: 40

Rep: Reputation: 15
Looks like a sound driver is installed ...
Try lspci and see what it comes up with.
I believe your soundcard is a realtek AC97 ... ?
That's a very generic card (chip) and linux support is very good in the driver department.
You may want to double-check that the volume levels are up, and that your audio isn't muted.
If that doesn't work, try checking the volume settings in the application you are using (which is ... ?)
You may also need to check that said application is configured correctly to output to your soundcard.
 
Old 01-28-2006, 08:34 AM   #3
sunnydayzrback
LQ Newbie
 
Registered: Jan 2006
Posts: 25

Original Poster
Rep: Reputation: 15
on typing lspci the following came up


sunil@pogo:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 915G/P/GV Processor to I/O Controller (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 915G/P/GV PCI Express Root Port (rev 04)
0000:00:02.0 VGA compatible controller: Intel Corp. 82915G Express Chipset Famil y Graphics Controller (rev 04)
0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definiti on Audio Controller (rev 03)
0000:00:1c.0 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Exp ress Port 1 (rev 03)
0000:00:1c.1 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Exp ress Port 2 (rev 03)
0000:00:1c.2 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Exp ress Port 3 (rev 03)
0000:00:1c.3 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Exp ress Port 4 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB 2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FB/FR (ICH6/ICH6R) LPC Interface Bridg e (rev 03)
0000:00:1f.1 IDE interface: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
0000:00:1f.2 IDE interface: Intel Corp. 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Contro ller (rev 03)
0000:06:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C /8139C+ (rev 10)

so is my sound card installed?
Yes the volume levels up and audio isnt muted
i didnt get the last line of what u said! ie how do you configure an application to sound card? My application is Totem movie player which came with Ubuntu 5.10

Last edited by sunnydayzrback; 01-28-2006 at 08:40 AM.
 
Old 02-06-2006, 03:44 AM   #4
yakkmeister
Member
 
Registered: Jan 2005
Location: QLD Australia
Distribution: SuSE + Ubuntu + DeMuDi ... whatever does the job :D
Posts: 40

Rep: Reputation: 15
http://www.darktempler.de/Toshiba-Laptop-2430-101.htm

according to this laptop owner, you can modprobe AC97 drivers to get it to work, and it should do so very well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Drivers in Ubuntu - refuses to install? Waerner Linux - Newbie 5 07-15-2005 08:22 AM
Audio in Ubuntu not working ummyeah Linux - Newbie 4 06-23-2005 06:05 PM
Slackware Audio: Can't install Nforce drivers summ0n3r Linux - Hardware 1 03-20-2005 02:44 PM
ac97 audio drivers and rtl8139 drivers Julian2005 Linux - Hardware 5 02-16-2005 01:36 PM
Ubuntu audio Stapler Linux - Software 3 01-22-2005 08:00 PM


All times are GMT -5. The time now is 08:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration