LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-09-2005, 07:10 PM   #1
tanya
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Rep: Reputation: 0
how do I get Num Lock to be turned on by defult on Red Hat Enterprise Linux WS ?


I have to turn on the Num Lock every time I log in. This is little thing, of course, but it is inconvenient. How can I get it to turn on automatically when I log in? (already checked the keyboard preferences, there is no such option ) I am using Red Hat Enterprise Linux WS
Thanks a lot.

Last edited by tanya; 01-09-2005 at 07:12 PM.
 
Old 01-09-2005, 07:14 PM   #2
Slayer097
Member
 
Registered: Dec 2004
Distribution: Slack 10
Posts: 59

Rep: Reputation: 15
I've noticed that too with every distro I've ever tried. It becomes annoying -- especially when you have numbers in your password because as you log in to KDE/GNOME, it turns the num lock off again. I have never found a solution to that, but if I come across one in the future I'll be sure to let you know.

EDIT: Search LQ and found that Andrew Benton already posted a solution for KDE. Check out the thread here.

EDIT AGAIN: Alternatively, if you don't want to compile the C program you can just follow the directions here. Hope this helps.

Last edited by Slayer097; 01-09-2005 at 07:19 PM.
 
Old 01-09-2005, 09:28 PM   #3
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 62
For KDE: There is a setting in the KDE control centre for this.

GNOME: There is a program called setnumlock (www.geocities.com/cucnews/setnumlock.html) Compile it and add it to the start up programs, under "session" I think. You can add the command to .xinitrc

TERMINAL: "setleds +num" will turn numlock on. However it will turn off again when you start x.

--Ian
 
Old 02-06-2005, 08:02 PM   #4
tanya
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
red hat linux enterprise andox Linux - Newbie 1 07-21-2004 12:26 PM
Red Hat Enterprise Linux v3.0 Mats_Piss_Piss Red Hat 6 05-04-2004 10:04 PM
Red Hat Enterprise Linux v3.0 Mats_Piss_Piss General 1 04-24-2004 09:42 AM
Red Hat Enterprise linux israel Linux - Software 2 04-13-2004 03:27 PM
Red Hat Enterprise vs. Red Hat Linux Project RedHatMN Linux - Distributions 2 07-29-2003 05:16 AM


All times are GMT -5. The time now is 12:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration