LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2007, 01:37 AM   #16
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83

beta still means beta though, and as masonm correctly pointed out, using a beta version of anything in a production environment is IMHO irresponsible if not foolhardy. Of course, that statement applies a lot more to a corporate environment than a home PC, but even so, presumably if there is a need or desire to mount the NTFS partition, the data on the NTFS partition must have some value, and therefore should not be subjected to unnecessary risk of damage or loss.

The OP didn't furnish details about where/how this would be used, and given that even the ntfs-3g maintainers state that the software is in beta status, the ability to write to NTFS in Linux should continue to be considered as experimental. Granted, ntfs-3g may be quite reliable, but until it loses the beta label I would only consider it for use in a non-essential, test environment. Just my 2 cents
 
Old 01-01-2007, 02:32 AM   #17
arindom
Member
 
Registered: Nov 2006
Location: India
Distribution: Ubuntu 11.04
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by igu
Arindom quite probably hit a SELinux bug which is explained here with the solution: http://www.ntfs-3g.org/support.html#selinux

Ntfs-3g is quite widely used already and there isn't anything wrong with its reliability. In fact, most distributions already replaced the "stable" captive-ntfs with the "beta" ntfs-3g because it's miles ahead both in reliability and speed.
This has turned out to be a great learing experience for me and for those users who are trying to switch over to Linux.

Regarding the importance of data in my Windows partition, I have taken a backup and if something at all happens, I do not risk much. I have decided long ago that I am going to use Linux. So I have to take chances (if any).

As suggested here I am mentioning the steps taken by me to activate ntfs-3g in my system. As I have already installed ntfs-3g earlier, I am starting from the next step.

I am following the steps written here :

a) Changed
SUBSYSTEM=="block", GROUP="disk", MODE="0640"
as
SUBSYSTEM=="block", GROUP="disk", MODE="0660"
in /etc/udev/rules.d/50-udev.rules

b) Added my username by
$ usermod -a -G disk,fuse username

c) Changed permissions of the mounted NTFS directory :
$ chmod 777 /mnt/windows

d) As mentioned in SELINUX bug workaround :
Set SELINUX to "permissive" in /etc/selinux/config

e) Added this line to /etc/fstab:
/dev/hda1 /mnt/windows ntfs-3g dmask=022,fmask=133,noauto,locale=hu_HU.UTF-8,user 0 0

And then System reboot.

Result :
No error message in booting. But -
$ ls /mnt/windows
showing nothing

Tried in SU mode
$ ntfs-3g /dev/hda1 /mnt/windows

NOW IT IS WORKING. I have tried writing and that also worked.

So everything is ok except I have to give the ntfs-3g command everytime I boot? I will wait for your's suggestion.


I understand that ntfs-3g is in beta state and as because it is still having the beta tag the user runs the risk of using a beta software. But as correctly pointed out by J.W., it is the question of how much important data is there in my windows partition is the important factor. As I have taken a backup so I took the chance.

Thank you all for your help. Please help me to clear the last hurdle.
 
Old 01-01-2007, 07:38 AM   #18
igu
Member
 
Registered: Jan 2003
Distribution: Fedora, Gentoo, SUSE, Mandriva
Posts: 127

Rep: Reputation: 15
Remove the 'noauto' option from the /etc/fstab line. It means don't mount during boot.
 
Old 01-01-2007, 09:38 AM   #19
arindom
Member
 
Registered: Nov 2006
Location: India
Distribution: Ubuntu 11.04
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by igu
Remove the 'noauto' option from the /etc/fstab line. It means don't mount during boot.
Thanks, now it is working correctly.

I would like to point it out here that while shutting down Fedora I am getting an unmount (audit) error. I can't read it properly because by then it is switching off. But from the language of the error message it seems if I unmount the windows partition before switching off then it would be better. Do I have to unmount the partition everytime before switching off? Please advise.
 
Old 01-01-2007, 11:12 AM   #20
igu
Member
 
Registered: Jan 2003
Distribution: Fedora, Gentoo, SUSE, Mandriva
Posts: 127

Rep: Reputation: 15
Can you find anything in /var/log/messages? It seems you still have some SELinux bug. It's a very serious problem if you can't unmount filesystems during shutdown because you can easily lose data. This is true for any filesystem.
 
Old 01-01-2007, 11:19 AM   #21
arindom
Member
 
Registered: Nov 2006
Location: India
Distribution: Ubuntu 11.04
Posts: 165

Original Poster
Rep: Reputation: 30
No there is absolutely nothing in /var/log/messages. It's blank.
 
Old 01-01-2007, 03:28 PM   #22
igu
Member
 
Registered: Jan 2003
Distribution: Fedora, Gentoo, SUSE, Mandriva
Posts: 127

Rep: Reputation: 15
What's the error message when you type 'umount -a' as root? Anything new in /var/log/messages?
 
Old 01-01-2007, 10:35 PM   #23
arindom
Member
 
Registered: Nov 2006
Location: India
Distribution: Ubuntu 11.04
Posts: 165

Original Poster
Rep: Reputation: 30
There is no error if I "umount /mnt/windows" (I am only unmounting the hda1 here). It is unmounting. Regarding the shutdown time messages all it is perfectly ok.

No there is still nothing in /var/log/messages.

As things stand now I have to manually unmount the Windows partition. Is it that way only?

Last edited by arindom; 01-01-2007 at 11:03 PM.
 
Old 01-05-2007, 11:59 PM   #24
igu
Member
 
Registered: Jan 2003
Distribution: Fedora, Gentoo, SUSE, Mandriva
Posts: 127

Rep: Reputation: 15
Update the selinux-policy package. It have fixed the SELinux bugs related to ntfs-3g. There shouldn't be even need for the Permissive mode anymore.
 
Old 01-06-2007, 07:52 AM   #25
arindom
Member
 
Registered: Nov 2006
Location: India
Distribution: Ubuntu 11.04
Posts: 165

Original Poster
Rep: Reputation: 30
That's good news. I hope I can update the SELinux-policy package by yum extender/update utility. Thanks igu for your help all along this problem.
 
Old 02-12-2007, 09:52 AM   #26
radu.miron
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 7.04 Fiesty Fawn
Posts: 13

Rep: Reputation: 0
Yo...people...could you tell me How to mount my Windows partitions on FC6? I just want to read them, not write ...

Thanks!
 
Old 02-12-2007, 04:44 PM   #27
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Hello radu.miron
You should have opened a new thread to ask your question, as it is not related to read/write mounting of a ntfs partition.

But I will try to answer nevertheless.
1) look for the Windows partition on your disk :
in a root console do
fdisk -l <device>
from 'man fdisk'
Quote:
The device is usually one of the following:
/dev/hda
/dev/hdb
/dev/sda
/dev/sdb
(/dev/hd[a-h] for IDE disks, /dev/sd[a-p] for SCSI disks, /dev/ed[a-d] for ESDI disks, /dev/xd[ab] for XT disks).
A device name refers to the entire disk.
eg, on my machine 'fdisk -l /dev/hda' gives :
Périphérique Amorce Début Fin Blocs Id Système
/dev/hda1 * 1 3698 29704153+ 7 HPFS/NTFS
...

so the Windows partition is /dev/hda1 for me
2) create a directory where you want to mount that partition :
eg, mkdir /mnt/windows
3) try to mount it manually under root, running :
mount -t ntfs /dev/hda1 /mnt/windows
change the partition and the directory accordingly.
 
Old 02-12-2007, 06:03 PM   #28
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Two things:

1) To use fuse (which ntfs-3g does), you should be a member of the fuse group.
2) selinux can not parse a filesystem name containing a dash. Thus:
..2a) You can not use ntfs-3g unless you set selinux to "permissive" mode.
..2b) While you should review the selinux audit logs for intrusion attempts, etc, when you're running in "permissive" mode, the messages re "fuse" and "ntfs-3g" are expected, and can be ignored.
 
Old 02-15-2007, 06:40 AM   #29
radu.miron
LQ Newbie
 
Registered: Jan 2007
Distribution: Ubuntu 7.04 Fiesty Fawn
Posts: 13

Rep: Reputation: 0
Thanks for the quick answer man...I succeeded in mounting my ntfs partitions, but....after I restart, they aren't mounted anymore, and when the system checks whether all it's components are OK( just after the boot loader ), it says right there that he couldn't mount the partitions because smthing with FUSE...(I didn't memorize the entire error). The thing is that I added in the file /etc/fstab the lines( sda1 & sda5 being my windows partitions ) :
[HTML]/dev/sda1 /media/c_drive ntfs-3g ro,defaults,umask=0222 0 0
/dev/sda5 /media/d_drive ntfs-3g ro,defaults,umask=0222 0 0 [/HTML]
But it seems not working, so every time I start the system, I hae to manually remount my ntfs partitions :|
 
Old 02-15-2007, 09:33 AM   #30
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
See if you can find the error message in /var/log/messages. I suspect that the message is that your fuse kernel module is an older version, and that ntfs-3g requires version 2.6.3 to work (more) reliably. On my Fedora system, I had to compile that version from source since the Fedora project hasn't yet updated their distributed version.

For what it's worth, my fstab entry looks like this:
Code:
$ cat /etc/fstab | grep ntfs
/dev/hda1               /ntfs/c            ntfs-3g rw,uid=root,gid=disk 0 0
I notice that you're mounting the filesystem "ro." If you don't need write access, the drivers from the ntfs-project are (slightly) easier to install and use. (Just search for "ntfs" in your repository.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS Read/Write HOW-TO Guide aoryx Linux - Software 3 12-29-2006 09:27 PM
Does Linux support Read-Write in NTFS? hackerarchangel Linux - Newbie 3 09-25-2005 03:31 AM
How to enable read-write support on NTFS? theMonkeY Linux - Software 4 06-26-2004 01:23 PM
Mounting NTFS read-write fredws Linux - Newbie 19 08-16-2003 05:11 PM
NTFS Read Write Snabber Linux - Newbie 1 12-23-2002 07:42 PM


All times are GMT -5. The time now is 08:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration