LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2003, 03:42 PM   #1
frontier1
Member
 
Registered: Feb 2003
Location: Culpeper,Va
Distribution: Mandrake 9.2 Knoppix 3.3 SuSe 9.0
Posts: 140

Rep: Reputation: 15
How to get DVD and CD-burner


devices probed and recognized and edited correctly in /etc/fstab????

Can anyone point me in the right direction?
 
Old 04-02-2003, 03:49 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
the right direction for what? please ask slightly more detailed questions in future....
 
Old 04-02-2003, 06:14 PM   #3
frontier1
Member
 
Registered: Feb 2003
Location: Culpeper,Va
Distribution: Mandrake 9.2 Knoppix 3.3 SuSe 9.0
Posts: 140

Original Poster
Rep: Reputation: 15
ok, no problem, I'm just trying to understand how linux recognizes drives, ie: DVD, CD-burner , CD-rom. I think my DVD player is hdc, or is it sr0? the specific problem I'm having is, I have sound working and my dvd drive is listed in my /etc/fstab file as:

/dev/cdroms/cdrom0 /mnt/cdrom

If I insert a cd in this drive it plays just fine, but when I open up mplayer and insert a DVD I get this error message:

Couldn't open DVD device: /dev/dvd

Do I need to somehow link /dev/dvd to /dev/cdroms/cdrom0?

Also my cd-burner isn't recognized at all, I am not sure if it is a scsi device, but I think it is. I have enabled scsi and cd-rom scsi support in the kernel.

Are there commands to probe for these devices, and to list their device paths. How do I enable these devices in /etc/fstab?
 
Old 04-02-2003, 08:01 PM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yes. You do need to link it to that device. Names aren't really important to linux, it won't recognize your burner and automatically refer to it as such (well depending on your setup and your distro it might). Same with DVD. So you have to make those links yourself:
ln -sf /dev/cdroms/cdrom0 /dev/dvd

This creates a symlink that programs (like mplayer) can use to determine your dvd device. Other options with mplayer include -dvd-device switch:
mplayer -vo xv -dvd-device /dev/cdroms/cdrom0 (check the man, I'm not 100% on that syntax). That way you won't have to make the symlink if you don't want to/can't.

You should check out your bootloader, look for an "append" line to see if scsi emulation is there for your drives. It will list the device as:
hdc=ide-scsi

As an example. If nothing is there, then your burner is not recognized as being a scsi-emulated device, and you'll want to add an entry for it similar to my example, replacing the device with the one that your burner is.

Check dmesg for more info on what block device your ROMs are assigned.

To see dmesg:
dmesg | less
As into a terminal.

Cool
 
Old 04-02-2003, 08:13 PM   #5
frontier1
Member
 
Registered: Feb 2003
Location: Culpeper,Va
Distribution: Mandrake 9.2 Knoppix 3.3 SuSe 9.0
Posts: 140

Original Poster
Rep: Reputation: 15
Ok, I issued the dmesg command, My DVD is hdc and my cd-rw is hdd . Looks like SCSI is messed up, I enabled it in the kernel, but not as a module, here is a line from dmesg: SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
 
Old 04-02-2003, 08:23 PM   #6
frontier1
Member
 
Registered: Feb 2003
Location: Culpeper,Va
Distribution: Mandrake 9.2 Knoppix 3.3 SuSe 9.0
Posts: 140

Original Poster
Rep: Reputation: 15
Thank You!
ln -sf /dev/cdroms/cdrom0 /dev/dvd

This command worked perfectly. I can now play DVD's using mplayer

Unfortunately now, the KSCD program won't open (for audio cd's)
and when I click on the cd/dvd-rom icon, I get this error

The reported error was:
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0,
or too many mounted file systems
 
Old 04-02-2003, 09:16 PM   #7
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Rep: Reputation: 30
Quote:
ln -sf /dev/cdroms/cdrom0 /dev/dvd
OK- after issuing that command you now have essentially two names for the DVD drive right? Linux calls it /dev/cdroms/cdrom0 but you call it /dev/dvd which is much easier to remember and it will aid you in changing/adding drives(that's another subject almost). Now you likely need to do the same with your cdrom drive. I have never used kscd so ?? but.....it needs to know where your cdrom is. You can find out thusly:

Different distros name drives differently so your mileage may vary.

~$ ls -al /dev/cdrom

lrwxrwxrwx 1 root root 3 Mar 27 08:41 /dev/cdrom -> scd1
Notice how it says "/dev/cdrom points to /dev/scd1

Now check the dvd drive
~$ ls -al /dev/dvd
This command can be interpreted as "tell me where /dev/dvd points to"

lrwxrwxrwx 1 root root 9 Mar 27 11:33 /dev/dvd -> /dev/scd0

Quote:
Unfortunately now, the KSCD program won't open (for audio cd's)
Pardon my ignorance but I think mplayer may also play cd's.

Quote:
and when I click on the cd/dvd-rom icon, I get this error

The reported error was:
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0,
or too many mounted file systems
Those icons are unneccesary, convenient pehaps but you can fix that later.
If /dev/cdrom is linked to the same drive as /dev/dvd then kscd is probably looking for the wrong drive eh? If /dev/cdrom linked to /dev/cdrom0 then you need to get rid of that link - how?

rm /dev/cdrom

I just posted a few examples- again your experience and exact syntax will likely differ. It is my guess that simply relinking /dev/cdrom properly will fix it. If you're unsure of which link to remove post back. I apparently like to learn the hard way and just do it!!
 
Old 04-02-2003, 10:26 PM   #8
frontier1
Member
 
Registered: Feb 2003
Location: Culpeper,Va
Distribution: Mandrake 9.2 Knoppix 3.3 SuSe 9.0
Posts: 140

Original Poster
Rep: Reputation: 15
Thank you very much, it all works correctly, this linux stuff is fun
 
Old 04-02-2003, 10:55 PM   #9
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Rep: Reputation: 30
Quote:
Originally posted by frontier1
this linux stuff is fun
Indeed Linux does rock.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you have a DVD or a CD Burner ? rvijay Linux - Hardware 6 05-21-2005 06:49 PM
Dvd-burner help minm Linux - Newbie 9 12-18-2004 04:50 AM
can't mount a dvd on a cd burner/dvd rom drive dr_zayus69 Linux - Hardware 7 12-09-2004 09:56 AM
DVD Burner.... Basslord1124 Fedora 4 11-15-2004 09:42 PM
dvd-rom drive won't play movies and dvd burner won't record calble Linux - Hardware 1 08-09-2004 08:35 AM


All times are GMT -5. The time now is 12:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration