LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-16-2007, 12:14 AM   #1
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
how to force x to use a resolution?


Hi all,

I have ibm T23 with supersavage and I have a LCD monitor support 1440x900.
Now I can set my video card up to 1400x1050. Is it possible to force my video to use 1440x900? Or is there a way to word around?

Thanks!

Last edited by compass; 10-16-2007 at 12:15 AM.
 
Old 10-16-2007, 12:34 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Hi,

and welcome to LQ!


And should be a way to do that - however, it can depend on a few
things as to whether and how that can be done.

a) What distro are you using?

b) Which window manager/desktop environment are you using?



Cheers,
Tink
 
Old 10-16-2007, 12:41 AM   #3
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Hi, thanks for your reply.

I'm using slackware and gnome as the desktop. I also installed fluxbox.
 
Old 10-16-2007, 12:46 AM   #4
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I also found the following messages in xorg.0.log
(II) SAVAGE(0): Supported Future Video Modes:
(II) SAVAGE(0): #0: hsize: 1400 vsize 1050 refresh: 75 vid: 20368
(II) SAVAGE(0): #1: hsize: 1440 vsize 900 refresh: 75 vid: 3989
(II) SAVAGE(0): #2: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
(II) SAVAGE(0): #3: hsize: 1280 vsize 960 refresh: 60 vid: 16513
(II) SAVAGE(0): #4: hsize: 1280 vsize 800 refresh: 75 vid: 3969
(II) SAVAGE(0): #5: hsize: 1280 vsize 800 refresh: 60 vid: 129
(II) SAVAGE(0): #6: hsize: 1152 vsize 921 refresh: 76 vid: 36977
(II) SAVAGE(0): #7: hsize: 1152 vsize 864 refresh: 75 vid: 20337
...
(II) SAVAGE(0): Supported additional Video Mode:
(II) SAVAGE(0): clock: 89.0 MHz Image Size: 410 x 257 mm
(II) SAVAGE(0): h_active: 1440 h_sync: 1488 h_sync_end 1520 h_blank_end 1600
h_border: 0
(II) SAVAGE(0): v_active: 900 v_sync: 903 v_sync_end 909 v_blanking: 926 v_b
order: 0
(II) SAVAGE(0): Ranges: V min: 56 V max: 76 Hz, H min: 31 H max: 84 kHz, Pix
Clock max 140 MHz
...
(II) SAVAGE(0): Modeline "1440x900" 136.75 1440 1536 1688 1936 900 903 909
942 -hsync +vsync

...
(--) SAVAGE(0): No suitable BIOS mode found for 1440x900 59Hz.
(II) SAVAGE(0): Not using mode "1440x900_60.00" (no mode of this name)
(--) SAVAGE(0): No suitable BIOS mode found for 1440x900 49Hz.
(II) SAVAGE(0): Not using mode "1440x900_50.00" (no mode of this name)


Does this mean my card support 1440x900? Thanks
 
Old 10-16-2007, 12:56 AM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Good choice of distro ;}
Quote:
Does this mean my card support 1440x900? Thanks
Sure does. To enforce it you should be able to add a
line with the explicit resolution to /etc/X11/xorg.conf


Find your screen section, and add Modes "1440x900" to the
resolutions you're wanting to use.

I only assume that your section says Savage for the device,
but you get the gist :}

Code:
Section "Screen"
        Identifier      "Default Screen"
        Device          "Savage"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1440x900"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1440x900"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1440x900"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1440x900"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1440x900"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1440x900"
        EndSubSection
EndSection


Cheers,
Tink
 
Old 10-16-2007, 01:22 AM   #6
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Tink, I added those lines to xorg.conf. When I start fluxbox, the screen is cut from bottom. I checked xdpyinfo, the dimension is 1400x1050. I also tried gnome. The resolution is automatically changed to 1280x1024. It seems my video card does not support it? confused.
 
Old 10-16-2007, 01:52 AM   #7
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Here are more info. from xorg.0.log:
(--) SAVAGE(0): Found 13 modes at this depth:
[10e] 320 x 200, 70Hz
[111] 640 x 480, 60Hz, 72Hz, 75Hz, 85Hz, 100Hz
[114] 800 x 600, 60Hz, 72Hz, 75Hz, 85Hz, 100Hz
[117] 1024 x 768, 60Hz, 70Hz, 75Hz, 85Hz, 100Hz
[11a] 1280 x 1024, 60Hz, 75Hz, 85Hz
[11d] 640 x 400, 70Hz
[122] 1600 x 1200, 60Hz, 75Hz, 85Hz
[133] 320 x 240, 72Hz
[13c] 1400 x 1050, 60Hz, 75Hz
[143] 400 x 300, 72Hz
[153] 512 x 384, 70Hz
[173] 720 x 480, 75Hz
[17e] 720 x 576, 75Hz

Does it mean my video card only support those modes?
 
Old 10-16-2007, 04:31 AM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Which colour depth is it pertaining to? And how much video RAM
does the box have?


Cheers,
Tink
 
Old 10-16-2007, 04:37 AM   #9
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I tried 16 and 24. None of them works.
I have 16m video memory on board. My LCD on laptop has a max resolution of 1024x768 and the external LCD is 1440x900.
 
Old 10-16-2007, 04:55 AM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Which video driver did X pick for the Savage chip? Not that I have
any experience with these ...


Cheers,
Tink
 
Old 10-16-2007, 05:03 AM   #11
compass
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I think it uses "SuperSavage". See the log:


(II) SAVAGE: driver (version 2.1.3) for S3 Savage chipsets: Savage4,
Savage3D, Savage3D-MV, Savage2000, Savage/MX-MV, Savage/MX,
Savage/IX-MV, Savage/IX, ProSavage PM133, ProSavage KM133,
Twister PN133, Twister KN133, SuperSavage/MX 128, SuperSavage/MX 64,
SuperSavage/MX 64C, SuperSavage/IX 128, SuperSavage/IX 128,
SuperSavage/IX 64, SuperSavage/IX 64, SuperSavage/IXC 64,
SuperSavage/IXC 64, ProSavage DDR, ProSavage DDR-K

....

(II) SAVAGE(0): Primary V_BIOS segment is: 0xc000
(II) SAVAGE(0): VESA BIOS detected
(II) SAVAGE(0): VESA VBE Version 2.0
(II) SAVAGE(0): VESA VBE Total Mem: 15168 kB
(II) SAVAGE(0): VESA VBE OEM: S3 Incorporated. Paramont BIOS
(II) SAVAGE(0): VESA VBE OEM Software Rev: 1.0
(II) SAVAGE(0): VESA VBE OEM Vendor: S3 Incorporated.
(II) SAVAGE(0): VESA VBE OEM Product: VBE 2.0
(II) SAVAGE(0): VESA VBE OEM Product Rev: Rev 1.0
(--) SAVAGE(0): Chip: id 8c2e, "SuperSavage/IXC 64"
(--) SAVAGE(0): Engine: "SuperSavage"
(--) SAVAGE(0): AGP card detected
(**) SAVAGE(0): BusType set to AGP
(**) SAVAGE(0): Using AGP DMA
(**) SAVAGE(0): DMA disabled
(**) SAVAGE(0): Using AGP 4x mode
(**) SAVAGE(0): Using 16 MB AGP aperture
(==) SAVAGE(0): Write-combining range (0xe8000000,0x4000000)
(==) SAVAGE(0): Write-combining range (0xe4000000,0x4000000)
(==) SAVAGE(0): Using gamma correction (1.0, 1.0, 1.0)
(--) SAVAGE(0): probed videoram: 16384k
 
Old 12-22-2010, 01:27 AM   #12
jwebster
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
Change Xorg.conf

Try:
Option "UseBIOS" "False"
It works for my Acer 1440x900 monitor.
UPDATE:Turn of the built-in LCD by:
Option "CrtOnly" "True"

Now I wonder if xorg can do dual-head xinerama.
UPDATE: Under Windows XP it does.

Last edited by jwebster; 01-16-2011 at 04:40 AM. Reason: Update to avoid crash of X server (hence the whole system)
 
  


Reply

Tags
resolution, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Correct desktop resolution. Incorrect screensaver & lock resolution mybootorg Linux - General 6 05-03-2006 03:39 AM
Script to force resolution/hertz range loadedmind Red Hat 6 03-07-2006 05:32 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 04:16 AM
Text Resolution, Graphic resolution. Change from prompt dlublink Suse/Novell 2 01-28-2005 12:50 PM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration