LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-23-2012, 10:22 AM   #1
masuch
Member
 
Registered: Sep 2011
Location: /dev/null
Distribution: ubuntu 64bits
Posts: 129

Rep: Reputation: Disabled
Question how to fix inactive ... RAID 0


Hi,

I have cat /proc/mdstat:

md122 : inactive sdm2[1] sdo2[3] sdn2[2]
122870016 blocks super 1.2


/dev/sdl3: LABEL="raid0ocz" UUID="d2a38127-0270-4d9f-b434-524e9e390b8d" TYPE="ext4"
/dev/sdm2: UUID="152fb8b4-9526-5477-57e0-dde891307b7b" UUID_SUB="326b2e62-6c84-7913-7dca-62543941670f" LABEL="raid0ocz" TYPE="linux_raid_member"
/dev/sdn2: UUID="152fb8b4-9526-5477-57e0-dde891307b7b" UUID_SUB="36dbf9b0-796d-9d94-5773-449916f2b65d" LABEL="raid0ocz" TYPE="linux_raid_member"
/dev/sdo2: UUID="152fb8b4-9526-5477-57e0-dde891307b7b" UUID_SUB="afa32a55-83d8-da9e-992e-4b4b05c52e65" LABEL="raid0ocz" TYPE="linux_raid_member"

How can I fix it ?

thank you,
kind regards,
M.
 
Old 05-24-2012, 07:12 AM   #2
r0b0
Member
 
Registered: Aug 2004
Location: Europe
Posts: 602

Rep: Reputation: 49
Hi,

You can just run
Quote:
mdadm -A /dev/md122
and it will become active again.

If you get this error on every boot, you probably need to edit your /etc/mdadm/mdadm.conf file, try appending output of
Quote:
mdadm --examine --scan
to the end of your mdadm.conf
 
Old 05-26-2012, 03:31 AM   #3
masuch
Member
 
Registered: Sep 2011
Location: /dev/null
Distribution: ubuntu 64bits
Posts: 129

Original Poster
Rep: Reputation: Disabled
thank you for help.
Unfortunately I tried that before and It did not help - so I have to stop and create the new one bear in mind to lost all data of course.
 
  


Reply

Tags
error, raid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem with software raid! inactive array, won't mount -Thomas- Linux - Software 9 05-29-2012 04:19 AM
power outage turned raid ext3 into ext2, how to fix ? ghoulsblade Linux - Server 3 10-17-2011 04:45 PM
Stupid RAID error(s). How should I fix this? ABL Linux - Server 2 08-03-2009 02:14 PM
Software RAID 6 Drives Marked As Spares And The md Drive is inactive jc_cpu Linux - Server 11 06-04-2009 11:06 AM
Linux Raid 1 Mirror bad on SCSI HDD. Howto fix? blkcamarozr28 Linux - Enterprise 1 10-17-2005 07:19 PM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration