LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2014, 10:13 AM   #1
nickole
LQ Newbie
 
Registered: Nov 2014
Location: canada
Distribution: debain
Posts: 2

Rep: Reputation: Disabled
Unhappy how to fix broken package


i am using kali linux and and got broken package problem when try to install some package with message:

apt-get install pidgin

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pidgin : Depends: libpurple0 (>= 2.8.0) but it is not going to be installed
Depends: perl-base (>= 5.14.2-21+deb7u2) but 5.14.2-21+deb7u1 is to be installed
E: Unable to correct problems, you have held broken packages.


what should i do ? plz help

Last edited by nickole; 11-06-2014 at 12:19 PM.
 
Old 11-06-2014, 11:16 AM   #2
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
Can you please specify what distro and version you're using? What's the output of 'uname -a'?
 
Old 11-06-2014, 12:17 PM   #3
nickole
LQ Newbie
 
Registered: Nov 2014
Location: canada
Distribution: debain
Posts: 2

Original Poster
Rep: Reputation: Disabled
oops..!! my apologize

using kali* linux
Kali GNU/Linux 1.0.9" version
description : Debain

Last edited by nickole; 11-06-2014 at 01:05 PM.
 
Old 11-07-2014, 04:12 PM   #4
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
I suspected you had a very old distro that wasn't very supported anymore and was missing packages from the repository, but I see that 1.0.9 is pretty new. So I don't know. Sorry.
 
Old 11-07-2014, 04:27 PM   #5
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,163
Blog Entries: 10

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Quote:
Originally Posted by nickole View Post
you have held broken packages.
if you have Synaptic, open it and look at "Pinned".
look for libpurple0 and perl-base, are they "pinned"?
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to fix broken package joboy Ubuntu 18 10-24-2016 11:40 AM
how to fix a broken package nuris Linux - Newbie 5 07-21-2012 04:25 PM
Warning--Icedove 2.0.0.0-3 package broken (+fix) David the H. Debian 1 05-25-2007 10:25 AM
Broken Package during upgrade - unable to fix farslayer Debian 6 10-02-2006 12:10 PM
Aptitude--How to fix broken package kkruecke Debian 1 08-29-2006 04:12 PM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration